Welcome to MSFN

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


JFMichaud

W7 unattend first logon command (Resolved)

8 posts in this topic

Hi i'm trying to add a first logon command but each time i try it in different location in the unattend i've end up with a syntax error and sysprep is unable to read the unattend?

Here is my unattend witch run with no error except the red section ... <SynchronousCommand wcm:action="add"> on that line?

[code<?xml version="1.0" encoding="utf-8"?>
<unattend xmlns="urn:schemas-microsoft-com:unattend">
<settings pass="windowsPE">
<component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">
<SetupUILanguage>
<UILanguage>fr-CA</UILanguage>
</SetupUILanguage>
<InputLocale>0c0c:00011009</InputLocale>
<UserLocale>fr-CA</UserLocale>
<UILanguage>fr-CA</UILanguage>
<SystemLocale>fr-CA</SystemLocale>
</component>
<component name="Microsoft-Windows-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">
<UserData>
<AcceptEula>true</AcceptEula>
<FullName></FullName>
<Organization>bob</Organization>
<ProductKey>
<Key></Key>
<WillShowUI>Always</WillShowUI>
</ProductKey>

</UserData>
</component>
</settings>
<settings pass="oobeSystem">
<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">
<AutoLogon>
<Enabled>true</Enabled>
<LogonCount>1</LogonCount>
<Username>Administrator</Username>
<Password>
<Value>Password</Value>
<PlainText>true</PlainText>
</Password>
</AutoLogon>
<FirstLogonCommands>
<SynchronousCommand wcm:action="add">
<CommandLine>c:\batch.bat</CommandLine>
<Description>Description_of_command1</Description>
<Order>1</Order>
</SynchronousCommand>
<SynchronousCommand wcm:action="add">
<CommandLine>c:\batch2.bat</CommandLine>
<Description>Description_of_command2</Description>
<Order>2</Order>
</SynchronousCommand>
</FirstLogonCommands>
<OOBE>
<HideEULAPage>true</HideEULAPage>
<NetworkLocation>Work</NetworkLocation>
<ProtectYourPC>1</ProtectYourPC>
<SkipMachineOOBE>true</SkipMachineOOBE>
<SkipUserOOBE>true</SkipUserOOBE>
</OOBE>
<TimeZone>Eastern Standard Time</TimeZone>
<UserAccounts>
<AdministratorPassword>
<Value>Password</Value>
<PlainText>true</PlainText>
</AdministratorPassword>
</UserAccounts>
</component>
<component name="Microsoft-Windows-International-Core" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">
<InputLocale>0c0c:00011009</InputLocale>
<UserLocale>fr-CA</UserLocale>
<UILanguage>fr-CA</UILanguage>
<SystemLocale>fr-CA</SystemLocale>
</component>
</settings>
<settings pass="specialize">
<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">
<ComputerName>%Entrez le nom de l'ordinateur%</ComputerName>
<CopyProfile>true</CopyProfile>
<RegisteredOrganization>Bottle</RegisteredOrganization>
<RegisteredOwner>Beer</RegisteredOwner>
<Display>
<ColorDepth>32</ColorDepth>
<HorizontalResolution>1680</HorizontalResolution>
<RefreshRate>60</RefreshRate>
<VerticalResolution>1050</VerticalResolution>
</Display>
</component>
<component name="Microsoft-Windows-Deployment" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<RunSynchronous>
<RunSynchronousCommand wcm:action="add">
<Order>1</Order>
<Path>net user administrator /active:yes</Path>
</RunSynchronousCommand>
</RunSynchronous>
</component>
<component name="Microsoft-Windows-IE-InternetExplorer" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<Home_Page>http://www.google.ca</Home_Page>
<DisableFirstRunWizard>true</DisableFirstRunWizard>
<DisableWelcomePage>true</DisableWelcomePage>
</component>
<component name="Microsoft-Windows-UnattendedJoin" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<Identification>
<Credentials>
<Domain>%Inscrire le domaine%</Domain>
<Username>%Nom pour rejoindre domaine%</Username>
<Password>%Mot de passe%</Password>
</Credentials>
<JoinDomain>%Please select a domain to join{bob;beer}%</JoinDomain>
</Identification>
</component>

</settings>
</unattend>]

thanks for the help

Edited by JFMichaud
0

Share this post


Link to post
Share on other sites

Maybe you can try like this:


<FirstLogonCommands>
<SynchronousCommand wcm:action="add">
<CommandLine>cmd /c c:\batch.bat</CommandLine>
<Description>Description_of_command1</Description>
<RequiresUserInput>false</RequiresUserInput>
<Order>1</Order>
</SynchronousCommand>
<SynchronousCommand wcm:action="add">
<CommandLine>cmd /c c:\batch2.bat</CommandLine>
<Description>Description_of_command2</Description>
<RequiresUserInput>false</RequiresUserInput>
<Order>2</Order>
</SynchronousCommand>
</FirstLogonCommands>

*Edit:please attach your Autounattend.xml file because some lines are missing:


<settings pass="oobeSystem">
<component name="Microsoft-Windows-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

Edited by myselfidem
0

Share this post


Link to post
Share on other sites

Hi

thanks for the respond but the command itself is ok...

the problem is with the wcm action:add

and it occurs before i run sysprep...i type the command to run sysprerp but a popup message appear and says

'wcm' is an undeclared namespace line 55 wich is <SynchronousCommand wcm:action="add">

thanks

0

Share this post


Link to post
Share on other sites

*Edit:please attach your Autounattend.xml file because some lines are missing:


<settings pass="oobeSystem">
<component name="Microsoft-Windows-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

I'll try with that line and post if it change somathing...

Thanks

0

Share this post


Link to post
Share on other sites

I've just tested...i don't have a error now on the unattend file and i don't get an error when i check with the windows Aik tool...

The error now is when the sysprep run in the oobe section it says that a there is a missing component

thanks

Edited by JFMichaud
0

Share this post


Link to post
Share on other sites

Try to remove inside OOBE section:


<SkipUserOOBE>true</SkipUserOOBE>

*Edit: Oops, sorry it seems I made an error with copy/paste the path:

Correct value:

<settings pass="oobeSystem">

<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

Edited by myselfidem
0

Share this post


Link to post
Share on other sites

Thanks myselfidem adding the component correct description solved my problem

Thanks a lot

0

Share this post


Link to post
Share on other sites

I'm glad you found the solution ! :)

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.