Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account


Photo

2008 Foundation Backup Issue


  • Please log in to reply
11 replies to this topic

#1
athome

athome

    Newbie

  • Member
  • 23 posts
  • OS:none specified
  • Country: Country Flag
Hello,

I manage a Windows 2008 Foundation Server that I took over from another IT company. I manage services for them and one is backing up the system. The previous IT company used Acronis to backup the system. i have changed the server to a domain controller as it was just a file server before. I removed all the software from the previous It company and updated Windows to SP2 and then added a 750gb hard drive for their data. Here are the specs:

HP Proliant ML310 g5p
Intel Xeon E3210
4GB Ram
64bit
250GB hard drive(2x) Mirrored(OS)
750GB hard drive - simple(data)


I bought three new 750GB external drives and added them for the backup location. All went well. After updating the system, I installed the backup feature and ran my first backup. The C:\ drive is backing up fine, but get an error on the F:\ drive where the company data files are. The error simply states "Incorrect Function". The errors I got previously were related to providers and have since removed all instances of the Acronis via their website forums and now just get "Incorrect Function" when backing up the F:\ drive. I have reinstalled the feature as well as cleaned the registry, but the error persists. Not sure if this is an HP, Microsoft, or Drive issue and could use some help.

When I run the vssadmin commmands, here is what I get:



Microsoft Windows [Version 6.0.6002]

Copyright © 2006 Microsoft Corporation. All rights reserved.




C:\Users\Administrator>vssadmin list writers

vssadmin 1.1 - Volume Shadow Copy Service administrative command-line tool

© Copyright 2001-2005 Microsoft Corp.




Writer name: 'ASR Writer'

Writer Id: {be000cbe-11fe-4426-9c58-531aa6355fc4}

Writer Instance Id: {73c10c82-ba8a-4ef8-b833-0313823fdd6c}

State: [1] Stable

Last error: No error




Writer name: 'System Writer'

Writer Id: {e8132975-6f93-4464-a53e-1050253ae220}

Writer Instance Id: {e9299557-e2ca-4660-b80c-d044cbed0df8}

State: [1] Stable

Last error: No error




Writer name: 'DFS Replication service writer'

Writer Id: {2707761b-2324-473d-88eb-eb007a359533}

Writer Instance Id: {878437b4-2cd5-40c8-8fe5-dd5add97caae}

State: [1] Stable

Last error: No error




Writer name: 'COM+ REGDB Writer'

Writer Id: {542da469-d3e1-473c-9f4f-7847f01fc64f}

Writer Instance Id: {863f0361-41b1-48fa-a0a7-017237a2fa1f}

State: [1] Stable

Last error: No error




Writer name: 'NTDS'

Writer Id: {b2014c9e-8711-4c5c-a5a9-3cf384484757}

Writer Instance Id: {d347d4cd-49c5-4c28-9514-95ae7e5f6872}

State: [1] Stable

Last error: No error




Writer name: 'Registry Writer'

Writer Id: {afbab4a2-367d-4d15-a586-71dbb18f8485}

Writer Instance Id: {fe7ab90f-0d38-457d-b8b3-9eb5d1543e50}

State: [1] Stable

Last error: No error




Writer name: 'Shadow Copy Optimization Writer'

Writer Id: {4dc3bdd4-ab48-4d07-adb0-3bee2926fd7f}

Writer Instance Id: {cf858205-ded3-4f3c-92eb-6badf56da91e}

State: [1] Stable

Last error: No error




Writer name: 'BITS Writer'

Writer Id: {4969d978-be47-48b0-b100-f328f07ac1e0}

Writer Instance Id: {2901d884-30ca-4465-a6fe-4e10181f85b8}

State: [1] Stable

Last error: No error




Writer name: 'Dhcp Jet Writer'

Writer Id: {be9ac81e-3619-421f-920f-4c6fea9e93ad}

Writer Instance Id: {1f936d70-4d94-4978-b205-09590030518e}

State: [1] Stable

Last error: No error




Writer name: 'WMI Writer'

Writer Id: {a6ad56c2-b509-4e6c-bb19-49d8f43532f0}

Writer Instance Id: {49513b4d-f454-405a-9a54-9722f52fbc63}

State: [1] Stable

Last error: No error







C:\Users\Administrator>vssadmin list providers

vssadmin 1.1 - Volume Shadow Copy Service administrative command-line tool

© Copyright 2001-2005 Microsoft Corp.




Provider name: 'Microsoft Software Shadow Copy provider 1.0'

Provider type: System

Provider Id: {b5946137-7b9f-4925-af80-51abd60b20d5}

Version: 1.0.0.7







C:\Users\Administrator>



any help would be greatly appreciated. I have run out of options I am aware of. I have enclosed a snapshot of the backup error. it states the the "backup ended before completion" and the error reads "incorrect function".

thank you

Attached Files


athome
MCP MCDST SCA MCSA


How to remove advertisement from MSFN

#2
Tripredacus

Tripredacus

    K-Mart-ian Legend

  • Super Moderator
  • 9,758 posts
  • OS:Server 2012
  • Country: Country Flag

Donator

Log file location: %WINDIR%\Logs\WindowsServerBackup

Have you run CHKDSK on the F: drive?

When you say you "I removed all the software from the previous It company" does this include the OS or a reinstall of it? If not, are you using the same user accounts that were on the server previous to you making the changes?
MSFN RULES | GimageX HTA for PE 3-5 | lol probloms
msfn2_zpsc37c7153.jpg

#3
athome

athome

    Newbie

  • Member
  • 23 posts
  • OS:none specified
  • Country: Country Flag
I did not reinstall the OS, I removed Acronis and some small utilities that they used for remote connection. It was just a file server and the only thing they were backing up was the C:\ drive. I then added the new drive. I removed their user accounts, then changed the admin password, and then updated all OS updates. Then I created/installed domain services. After checking for new updates at that time, (none) I installed the backup feature from the management console.

I was hesitant of running chkdsk at that time, but did read in a forum to do so, but that was on a drive that had been used prior. the 750gb drive I installed was straight from HP and into the case. attached is the log file, you may have to change the ext back to .etl

Thanks for your help.

Attached Files


Edited by athome, 02 October 2012 - 12:21 PM.

athome
MCP MCDST SCA MCSA

#4
allen2

allen2

    Not really Newbie

  • Member
  • PipPipPipPipPipPipPip
  • 1,812 posts
Does the server was restarted since acronis was removed ?
Could you describe exactly what you did to remove acronis properly ?
What does the eventlogs give you when the error happen ?
Does this happen with every kind of data ?
Did you tried this kind of vss fix ?

#5
Tripredacus

Tripredacus

    K-Mart-ian Legend

  • Super Moderator
  • 9,758 posts
  • OS:Server 2012
  • Country: Country Flag

Donator

After searching for 2 minutes, it seems there might be some way to get the logs to actually show some Format Information...

But regarding the actual problem, it seems the backup can fail if it encounters an Access Denied scenario caused by these possibles:
- Encountered a file that is in use and/or locked by another process
- some backup files were deleted during write due to another process (ie. anti-virus)
Reference: http://msdn.microsof...530(VS.85).aspx

I would really take a look-see into Event Viewer at the time of the error-out of the Backup... which seems to be 9:00PM looking at your .ETL. And I don't just mean the top-level logs (Application, Security, System) but also drill into the ones in Applications and Services logs. You might luck out and find something in there someplace that leads you on the right track.

You should also be able to find the logs created by Windows Backup when the operation fails, since you didn't post that already.
MSFN RULES | GimageX HTA for PE 3-5 | lol probloms
msfn2_zpsc37c7153.jpg

#6
athome

athome

    Newbie

  • Member
  • 23 posts
  • OS:none specified
  • Country: Country Flag
Allen2: not sure I want to try that fix from Semantec as I did not have that installed, as it is not for Windows 2008 and may cause functionality problems as a result. I appreciate the comment and I have seen that in my search to solve this problem. Thanks for the suggestion though.


Tripredacus: Interesting that you should state that as I have had a few errors in the event viewer related to that very thing. I will check out that error and get back with an update. I also plan on running chkdsk tonight which will take some time to complete.
athome
MCP MCDST SCA MCSA

#7
allen2

allen2

    Not really Newbie

  • Member
  • PipPipPipPipPipPipPip
  • 1,812 posts
The vss fix from symantec is to fix vss issues that can cause backup to fail it is related to all vss based backup tools and not to a specific product. And wbackup is vss based by default.

#8
athome

athome

    Newbie

  • Member
  • 23 posts
  • OS:none specified
  • Country: Country Flag
Hello,

I ran the chkdsk on the drive and everything went well, I restarted all services and again tried a backup. C:\ completes fine, but F:\ ends prematurely and does not complete. The error only reads "Incorrect Function" I have verified the permissions and am not getting any errors. I tried running the backup under a new administrator with enterprise admin permissions, yet it still fails. There are no errors in "event log" for me to look at. When looking in the Logs folder in Windows Directory, I see only wbadmin.1.etl files and wbadminUI.1.etl files only. I am clueless here, where else can I go or do?

It seems that it is related only to the F:\ drive which holds the data for the company. I am hesitant to do the vssfix.bat fix as I can do a backup of the C:\ drive, but no the F:\ This seems to indicated that is it drive specific rather than VSS.
athome
MCP MCDST SCA MCSA

#9
allen2

allen2

    Not really Newbie

  • Member
  • PipPipPipPipPipPipPip
  • 1,812 posts
Indeed vss might not be broken except if there is an application vss compliant on the F: volume. Microsoft SQL server or exchange for example are vss compliant.
When the backup start, it ask vss to create a shadow copy of the volume which will ask all vss compliant applications to do the same and when everyone is ready the shadow copy will be created and the backup tool will backup the shadow copy will be deleted after the backup.
You could try to manually create a shadow copy or do it from command line with "vssadmin create shadow".
This way you'll know if the issue is vss related or not.

#10
athome

athome

    Newbie

  • Member
  • 23 posts
  • OS:none specified
  • Country: Country Flag
Allen2
Are you saying to do a shadow copy of just the F:\ drive or both drives? I do not have any SQL or Exchange running on the computer. It is Foundation only with a domain. Very small amount of services running. In my case, why is there not backup logs created? is this a lead into what could be wrong as well?
athome
MCP MCDST SCA MCSA

#11
athome

athome

    Newbie

  • Member
  • 23 posts
  • OS:none specified
  • Country: Country Flag
Allen2,


I ran the command and here is the results. Should I be looking for something more. This command took only 2 seconds to complete. is that normal, or should it have been done is longer time, or created a copy of F:\ somewhere?


C:\Windows\system32>vssadmin create shadow /for=f: /autoRetry=2<br style="font-family: Calibri; font-size: 16px; ">

vssadmin 1.1 - Volume Shadow Copy Service administrative command-line tool<br style="font-family: Calibri; font-size: 16px; ">© Copyright 2001-2005 Microsoft Corp.<br style="font-family: Calibri; font-size: 16px; ">

Successfully created shadow copy for 'f:\'<br style="font-family: Calibri; font-size: 16px; "> Shadow Copy ID: {b1b9c93e-a067-4ea9-af61-249d35d015eb}<br style="font-family: Calibri; font-size: 16px; "> Shadow Copy Volume Name: \\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy20<br style="font-family: Calibri; font-size: 16px; ">C:\Windows\system32>
athome
MCP MCDST SCA MCSA

#12
allen2

allen2

    Not really Newbie

  • Member
  • PipPipPipPipPipPipPip
  • 1,812 posts
If there is no activity or only very little then it is pretty normal it take only few seconds.
And yes only for the F: drive. Be sure to remove it after checking it was created successully and disable the automatic creation of news shadow copies as creating one could change the parameters on some OS.
Then you issue isn't vss related.
I find it strange that you don't get any related eventlogs when the backup run / fail.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users



How to remove advertisement from MSFN