Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account


Photo

STOP 0x1E in SRV.SYS

- - - - -

  • Please log in to reply
8 replies to this topic

#1
ppgrainbow

ppgrainbow

    Advanced Member

  • Member
  • PipPipPip
  • 437 posts
  • OS:Vista Ultimate x64
  • Country: Country Flag
Hello! :hello:

I was pretty much bored when I decided that I wanted to backup the contents of my Tecra 720CDT laptop with Windows 95 OSR2 installed. However, moments after Microsoft Backup tried to transfer the backup contents of the data from the hard drive onto one of the USB hard drives on my Win2k desktop when one of the directories on the drive is mapped as a network drive, a STOP 0x1E (KMODE_EXCEPTION_NOT_HANDLED) error occurs referencing to SRV.SYS (Server driver).

The version of the SRV.SYS file (found in \WINNT\system32\drivers) is version 5.0.2195.7368 with a date stamp of 2011-08-27 01:08:22. Here are the stop errors that I received so far:

1. STOP 0x0000001e (0xc0000005, 0xbd339d1e, 0x00000000, 0x00000040) (srv.sys - Address 0xbd339d1e base at 0xbd32a000 DateStamp 0x4b20fa01)
2. STOP 0x0000001e (0xc0000005, 0xbd3b1d1e, 0x00000000, 0x00000040) (srv.sys - Address 0xbd3b1d1e base at 0xbd3a2000 DateStamp 0x4b20fa01)

Version 5.0.2195.7368 of SRV.SYS (Server driver) is found in the UURollup v10c, which could be buggy and crash Win2k when transferring files over a network.

Is there any way to fix this bug referencing to the SRV.SYS driver? :whistle:

Edited by ppgrainbow, 02 October 2012 - 04:48 PM.

AVA Direct FX AM3+ specs: Zalman ZM Z9-U3 Black Mid-Tower case / ASUS M5A97 R2.0 / AMD FX-4300 3.8 GHz quad-core processor / Fractal Design Integra R2 500W PSU/ Hyper 212 EVO CPU cooler / Western Digital BLACK SERIES 1 TB (WD1003FZEX) SATA III 7200 RPM / Lite-On iHas124 Black 24x DVD-RW / Sabrent CRW-UINB internal memory card w/USB 2.0 port (to be replaced soon) / 8 GB Crucual (2 x 4GB) Ballistix Sport PC3-12800 DDR3 RAM / EVGA GeForce 8400 GS 520 MHz 1 GB GDDR3 / Microsoft Windows Vista Ultimate SP2 x64



How to remove advertisement from MSFN

#2
blackwingcat

blackwingcat

    Friend of MSFN

  • Member
  • PipPipPipPipPip
  • 735 posts
  • OS:Windows 2000 Professional
  • Country: Country Flag
Hi.

BD3B1D11 LBD3B1D11:
BD3B1D11 8945FC mov [ebp-04h],eax
BD3B1D14 8B4E58 mov ecx,[esi+58h]
BD3B1D17 2BC1 sub eax,ecx
BD3B1D19 8D4DF8 lea ecx,[ebp-08h]
BD3B1D1C 51 push ecx
BD3B1D1D 50 push eax
BD3B1D1E FF7010 push [eax+10h] <- eax=0x00000030
BD3B1D21 E87AB60200 call SUB_LBD3DD3A0
BD3B1D26 E99DB60200 jmp LBD3DD3C8


It seems v5.0.2195.7368 srv.sys general bug.


Hello! :hello:

I was pretty much bored when I decided that I wanted to backup the contents of my Tecra 720CDT laptop with Windows 95 OSR2 installed. However, moments after Microsoft Backup tried to transfer the backup contents of the data from the hard drive onto one of the USB hard drives on my Win2k desktop when one of the directories on the drive is mapped as a network drive, a STOP 0x1E (KMODE_EXCEPTION_NOT_HANDLED) error occurs referencing to SRV.SYS (Server driver).

The version of the SRV.SYS file (found in \WINNT\system32\drivers) is version 5.0.2195.7368 with a date stamp of 2011-08-27 01:08:22. Here are the stop errors that I received so far:

1. STOP 0x0000001e (0xc0000005, 0xbd339d1e, 0x00000000, 0x00000040) (srv.sys - Address 0xbd339d1e base at 0xbd32a000 DateStamp 0x4b20fa01)
2. STOP 0x0000001e (0xc0000005, 0xbd3b1d1e, 0x00000000, 0x00000040) (srv.sys - Address 0xbd3b1d1e base at 0xbd3a2000 DateStamp 0x4b20fa01)

Version 5.0.2195.7368 of SRV.SYS (Server driver) is found in the UURollup v10c, which could be buggy and crash Win2k when transferring files over a network.

Is there any way to fix this bug referencing to the SRV.SYS driver? :whistle:


+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
BlackWingCat =^^=
http://blog.livedoor.jp/blackwingcat/
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

#3
WildBill

WildBill

    Senior Member

  • Developer
  • 695 posts
  • OS:none specified
  • Country: Country Flag
Going to look at in Ida right now...

#4
WildBill

WildBill

    Senior Member

  • Developer
  • 695 posts
  • OS:none specified
  • Country: Country Flag
Ah. Found it. I missed an instruction. I'll post an update ASAP.

#5
WildBill

WildBill

    Senior Member

  • Developer
  • 695 posts
  • OS:none specified
  • Country: Country Flag
Just posted KB2508429 v9. This should fix the problem :whistle:

#6
ppgrainbow

ppgrainbow

    Advanced Member

  • Member
  • PipPipPip
  • 437 posts
  • OS:Vista Ultimate x64
  • Country: Country Flag

Just posted KB2508429 v9. This should fix the problem :whistle:


Thank you so much for telling me. I'll probably download a update to fix the problem and update it if there are anymore errors occurring. :)

By the way, can I have a link to the updated file in question?

Edited by ppgrainbow, 02 October 2012 - 07:41 PM.

AVA Direct FX AM3+ specs: Zalman ZM Z9-U3 Black Mid-Tower case / ASUS M5A97 R2.0 / AMD FX-4300 3.8 GHz quad-core processor / Fractal Design Integra R2 500W PSU/ Hyper 212 EVO CPU cooler / Western Digital BLACK SERIES 1 TB (WD1003FZEX) SATA III 7200 RPM / Lite-On iHas124 Black 24x DVD-RW / Sabrent CRW-UINB internal memory card w/USB 2.0 port (to be replaced soon) / 8 GB Crucual (2 x 4GB) Ballistix Sport PC3-12800 DDR3 RAM / EVGA GeForce 8400 GS 520 MHz 1 GB GDDR3 / Microsoft Windows Vista Ultimate SP2 x64


#7
WildBill

WildBill

    Senior Member

  • Developer
  • 695 posts
  • OS:none specified
  • Country: Country Flag
http://www.mediafire...b9n29hdqwiw3hyu

It's also in the post-EOL updates list...

#8
tomasz86

tomasz86

    www.windows2000.tk

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,510 posts
  • OS:XP Pro x86
  • Country: Country Flag
Thanks for a quick fix :)
post-47483-1123010975.png
Unofficial Service Pack 5.2 for MS Windows 2000 <- use this topic if you need help with UURollup, Update Rollup 2 and other unofficial packages

#9
ppgrainbow

ppgrainbow

    Advanced Member

  • Member
  • PipPipPip
  • 437 posts
  • OS:Vista Ultimate x64
  • Country: Country Flag

http://www.mediafire.com/download.php?b9n29hdqwiw3hyu

It's also in the post-EOL updates list...


Thank you so much! I'll apply the fix now and reboot. :)

If there are any problems, I'll report back.

AVA Direct FX AM3+ specs: Zalman ZM Z9-U3 Black Mid-Tower case / ASUS M5A97 R2.0 / AMD FX-4300 3.8 GHz quad-core processor / Fractal Design Integra R2 500W PSU/ Hyper 212 EVO CPU cooler / Western Digital BLACK SERIES 1 TB (WD1003FZEX) SATA III 7200 RPM / Lite-On iHas124 Black 24x DVD-RW / Sabrent CRW-UINB internal memory card w/USB 2.0 port (to be replaced soon) / 8 GB Crucual (2 x 4GB) Ballistix Sport PC3-12800 DDR3 RAM / EVGA GeForce 8400 GS 520 MHz 1 GB GDDR3 / Microsoft Windows Vista Ultimate SP2 x64





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users



How to remove advertisement from MSFN