Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 



Tihiy

Start Is Back - 2.1 release

Recommended Posts

Is there gonna be version that has per-machine install option at all?

Which scenario you consider to be an issue? There would be automatic updates. I plan to make Enterprise Edition after Personal Edition which would be MSI based so it can be pushed to all users via Group Policies painlessly.

Don't heat the discussion, you can send me a PM on your thoughts.

Share this post


Link to post
Share on other sites

@Tihiy

I installed this on my testing Win8 and i works great! Then i tried to install it on my testing Server 2012 and i run into a problem, if i try and launch the Config, the applicaiton simply crashes. The start menu works fine its just the configuration application that wont launch.

Is it not supposed to work on Server 2012? Getting the following error in my Event Viewer, hope you can help me with this.

-Edit: The beta1 worked fine

--

Faulting application name: StartIsBackCfg.exe, version: 0.0.0.0, time stamp: 0x50898bc7

Faulting module name: unknown, version: 0.0.0.0, time stamp: 0x00000000

Exception code: 0xc00001a5

Fault offset: 0x003ee8bd

Faulting process id: 0xfc

Faulting application start time: 0x01cdb2ff4270e176

Faulting application path: C:\Users\Administrator\AppData\Local\StartIsBack\Beta3\StartIsBackCfg.exe

Faulting module path: unknown

Report Id: 8039fd14-1ef2-11e2-93ed-005056a74627

Faulting package full name:

Faulting package-relative application ID:

--

Problem signature:

Problem Event Name: APPCRASH

Application Name: StartIsBackCfg.exe

Application Version: 0.0.0.0

Application Timestamp: 50898bc7

Fault Module Name: StackHash_dc6a

Fault Module Version: 0.0.0.0

Fault Module Timestamp: 00000000

Exception Code: c0000005

Exception Offset: PCH_7B_FROM_StartIsBack32+0x000020CA

OS Version: 6.2.9200.2.0.0.400.8

Locale ID: 1030

Additional Information 1: dc6a

Additional Information 2: dc6a66c640666fb5e05be010ae365a16

Additional Information 3: 2e15

Additional Information 4: 2e15688e505720a71fed938a8f4e3d44

--

Edited by maslow

Share this post


Link to post
Share on other sites

Yep, can confirm, it´s working like charm, no bugs or issues to report. Only AVG testified a trojan :D. After "ignore" all worked fine.

Regards

Share this post


Link to post
Share on other sites

All following items test on Win8 x86 and Win8 x64. See Server 2012 x64 note below.

Rename Start Screen to Apps auto reset works.

Server 2012 - StartIsBackCfg.exe crashes. So nothing else tested on 2012.

- Fixed critical: explorer crashes if start is apps and items in all programs are renamed

I don't get a crash however....if I rename an item (for example Internet Explorer to Internet Explorer RENAMED) then that item no longer works in Metro. If I reboot the machine, then the Metro item works again.

- Fixed critical: renaming pinned items broke them

- Fixed: renaming MFU items didn't work correctly

This one is goofy! If I rename a pinned item (for example Paint to Paint RENAMED via the pinned item) the pinned item no longer works. EVER! It's completly dead. The pinned item also remains as the old name. The actual item in accessories also remains as the old name (Paint). But if I search for Paint...it finds Paint RENAMED. Where? I couldn't find it. If i pin the Paint RENAMED thatit finds then it pins it as Paint RENAMED (2). Anyway, I have to unpin Paint then repin it to get it working. However, Paint RENAMED is now stuck somewhere in lala land.

If I rename a recently used program then it also stops working and it retains the old name. However, if I wait about a minute then it updates then it works.

- Fixed: off-by-one recent program count (if no items are pinned)

Works as expected with and without any pinned items.

- New: context menu for All Programs

Open, Open All Users and Properties.

- New: configurable Start screen hotkey

All three options work.

- New: middle mouse Start button click invokes Start screen

Works.

- New: updated config UI, PNG orbs support, animated orb gallery

Orb switching works. I tried my own orb and it works. Thinking of creating a company orb.

- New: trial and activation

Worked. Both Win8 32 and 64 activated.

Edited by ISOHaven

Share this post


Link to post
Share on other sites

Works great and I would definitely donate when it gets out of beta.

Just one request: can you please make it look more "Windows 8'ish"? (like Start8's classic start menu: http://www.theappnews.com/wp-content/uploads/2012/09/start8_095.jpg)

I was hesitating about upgrading to Windows 8, but with your solution I'm definitely upgrading, so thank you, and keep up the good work.

Share this post


Link to post
Share on other sites

BETA THREE "THE SALVATION" HAS ARRIVED

You're now ready for Windows 8 GA. Getting it in time was my ultimate goal and i hope i succeeded! From prototype to fully functional version in three weeks, quite a feat.

This beta is intended to be last beta. Note that it's 30 day trial (per user). It's fully featured and won't nag you.

After trial expires, StartIsBack will still work, but start menu will be non-functional and will nag you every boot.

This build is capable of activation, but activation itself is not tested yet, so i give license keys to few trusted pals and we'll be testing.

Buying and license key gifts to donators should come after testing.

Download: http://startisback.com/StartIsBack_betathree.zip

List of changes:

- Fixed critical: explorer crashes if start is apps and items in all programs are renamed

- Fixed critical: renaming pinned items broke them

- Fixed: renaming MFU items didn't work correctly

- Fixed: off-by-one recent program count (if no items are pinned)

- New: context menu for All Programs

- New: allow edges on secondary monitors

- New: configurable Start screen hotkey

- New: middle mouse Start button click invokes Start screen

- New: updated config UI, PNG orbs support, animated orb gallery

- New: trial and activation

- Code cleanup and optimization

And installer of course! Note that StartIsBack is installed for user only - into \Users\<User>\AppData\Local\StartIsBack

Installer is a bit lame for now, but installing per-machine won't likely be implemented for v1.0 personal edition.

Spread the word about this version, it's meant to be heard of, i hope there are no bugs :rolleyes: .

Icon is probably temporary, shamrock will stay probably. Everybody loves shamrock?

Cool!

Share this post


Link to post
Share on other sites
- Fixed critical: renaming pinned items broke them

- Fixed: renaming MFU items didn't work correctly

This one is goofy! If I rename a pinned item (for example Paint to Paint RENAMED via the pinned item) the pinned item no longer works. EVER! It's completly dead. The pinned item also remains as the old name. The actual item in accessories also remains as the old name (Paint). But if I search for Paint...it finds Paint RENAMED. Where? I couldn't find it. If i pin the Paint RENAMED thatit finds then it pins it as Paint RENAMED (2). Anyway, I have to unpin Paint then repin it to get it working. However, Paint RENAMED is now stuck somewhere in lala land.

If I rename a recently used program then it also stops working and it retains the old name. However, if I wait about a minute then it updates then it works.

Have a look in C:\Users\"Your User Name"\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\User Pinned\StartMenu and you should see the renamed one.

I get this bug on Windows 7 pinned items as well and it is annoying, I don't think there will much you can do to fix it, it's just one of those "good enough" scenarios that MS doesn't care enough about to fix.

Edit: Just tested this myself on the pinned start menu programs and when I changed the name of the pinned program it changed straight away and the program launched fine, I also renamed it back again and still works fine.

Edited by MrGRiM

Share this post


Link to post
Share on other sites

I get this bug on Windows 7 pinned items as well and it is annoying, I don't think there will much you can do to fix it, it's just one of those "good enough" scenarios that MS doesn't care enough about to fix.

I just tried it on Win7 and had no problem at all. Name change happened right away and the app launches fine.

Share this post


Link to post
Share on other sites

I get this bug on Windows 7 pinned items as well and it is annoying, I don't think there will much you can do to fix it, it's just one of those "good enough" scenarios that MS doesn't care enough about to fix.

I just tried it on Win7 and had no problem at all. Name change happened right away and the app launches fine.

Yeah it's more random and more I was having this problem with pinned programs on the taskbar.

Anyway I just tried removing pinned programs from %userprofile%\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\User Pinned\StartMenu and it had the result you mentioned earlier, the pinned programs still showed in the start menu but clicking on them didn't do anything.

I also found if you rename them in %userprofile%\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\User Pinned\StartMenu it also results in making the shortcut not work and as you said, the name does not change either.

When I used Shift+Right Click on the pinned programs in the start menu the names changed fine and it also changed the name in %userprofile%\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\User Pinned\StartMenu and the program worked as it should.

When you renamed the ones in the start menu did you just shift+Right click on them and rename them in the start menu?

Edited by MrGRiM

Share this post


Link to post
Share on other sites
This one is goofy! If I rename a pinned item (for example Paint to Paint RENAMED via the pinned item) the pinned item no longer works. EVER! It's completly dead. The pinned item also remains as the old name. The actual item in accessories also remains as the old name (Paint). But if I search for Paint...it finds Paint RENAMED. Where? I couldn't find it. If i pin the Paint RENAMED thatit finds then it pins it as Paint RENAMED (2). Anyway, I have to unpin Paint then repin it to get it working. However, Paint RENAMED is now stuck somewhere in lala land.

If I rename a recently used program then it also stops working and it retains the old name. However, if I wait about a minute then it updates then it works.

Wait wait waaaaaait. You're describing exactly unfixed behavior. How it is possible? :blink:

Can anyone else confirm that renaming pinned programs actually works or doesn't?

Okay, works for MrGRiM. How it's broken then?

Only AVG testified a trojan
Which file? Edited by Tihiy

Share this post


Link to post
Share on other sites
This one is goofy! If I rename a pinned item (for example Paint to Paint RENAMED via the pinned item) the pinned item no longer works. EVER! It's completly dead. The pinned item also remains as the old name. The actual item in accessories also remains as the old name (Paint). But if I search for Paint...it finds Paint RENAMED. Where? I couldn't find it. If i pin the Paint RENAMED thatit finds then it pins it as Paint RENAMED (2). Anyway, I have to unpin Paint then repin it to get it working. However, Paint RENAMED is now stuck somewhere in lala land.

If I rename a recently used program then it also stops working and it retains the old name. However, if I wait about a minute then it updates then it works.

Wait wait waaaaaait. You're describing exactly unfixed behavior. How it is possible? :blink:

Can anyone else confirm that renaming pinned programs actually works or doesn't?

I just tried this again and I found out when it doesn't work, if you just right click and go to properties and rename it in the general tab that's when you have a problem, if you press Shift+Right Click and select rename it works correctly.

Share this post


Link to post
Share on other sites

I just tried this again and I found out when it doesn't work, if you just right click and go to properties and rename it in the general tab that's when you have a problem, if you press Shift+Right Click and select rename it works correctly.

Uhuh. Not sure how to fix that :unsure: I thought everyone uses F2 to rename.

Edited by Tihiy

Share this post


Link to post
Share on other sites

I just tried this again and I found out when it doesn't work, if you just right click and go to properties and rename it in the general tab that's when you have a problem, if you press Shift+Right Click and select rename it works correctly.

Uhuh. Not sure how to fix that :unsure: I thought everyone uses F2 to rename.

Huh? When I highlight an item on the start menu and hit F2, nothing happens. I never use F2 on the menu but use it for everything else.

Yes, I'm just right-clicking the items then selecting properties then going to the general tab. I'll try shift tomorrow.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×