• Announcements

    • xper

      MSFN Sponsorship and AdBlockers!   07/10/2016

      Dear members, MSFN is made available via subscriptions, donations and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, become a site sponsor and ads will be disabled automatically and by subscribing you get other sponsor benefits.
Tihiy

Start Is Back - 2.1 release

2,082 posts in this topic

Here's another point of view. For home, I wouldn't really care which direction it went. Paid or ads (preferred paid). But for business...ads are a no go. I cannot implement anything ad driven.

On a side note, what's worked "well" for many people:

Free - ad driven

Paid - ad removal

Simple as that. But all in all, ads are a PITA for developers. I tried that direction once and quickly stopped.

0

Share this post


Link to post
Share on other sites

BETA ONE "THE ONE"

http://tihiy.net/files/StartIsBack_betaone.zip

* Will expire November 1.

* No longer tied to RTM explorer.exe. Should work with all updates. Works with Release Preview also (but i won't spend my efforts on it).

* Slighly improved cracking protection. Some AV programs may detect heuristic malware.

FIXED:

* Start_AdminToolsTemp issue

* Start button could be closed with Alt-F4 :blushing:

NEW:

* Start Is Apps! Now the separation between desktop and Metro i promised is here (optional). When you enable it:

- Start will be renamed to Apps

- Pin to Start will disappear from shell context menus

- Desktop programs will be hidden from Metro start screen and all apps list

* Start/App screen can show on right winkey (optional)

* Start/App screen hides on Alt-F4

* Start menu is transparent (optional)

* Taskbar is not (optional)

You must uninstall beta 0 and logoff since you can't replace files while StartIsBack is working. Don't worry, installer will come soon!

Edited by Tihiy
0

Share this post


Link to post
Share on other sites

Wow, most impressive! Uninstalling Zero and installing One now!

0

Share this post


Link to post
Share on other sites

So far with a new installation of Server 2012 and Win8....no more Reg problems. As soon as I get back from lunch I'll play with your new features.

EDIT:

Everything seems to be running great for me. The new features work. I know some people will like the no transparency. Just FYI, when you turn OFF transparency the user tile border is still transparent. I know how anal some people get about it :lol: But not me, I like the transparency. I think it looks great!

Edited by ISOHaven
0

Share this post


Link to post
Share on other sites

Just a word of caution for Server 2012 folks...most all apps on 2012 are desktop apps so....if you enable "Rename Start Screen...." then you'll wipe out just about everything except Desktop and IE. Which is odd because IE on 2012 is desktop only, no metro.

0

Share this post


Link to post
Share on other sites

WHAT TO TEST IN BETA 1:

1. * Start Menu, is it fully functional and works as you expect

2. * Start button, is it fully operational and draws as you expect

3. * Desktop, is it initialized correctly

4. * Start-up programs, are they all loaded in time

5. * Apps (Start screen), is it broken in any way

6. * Multi-monitor woes?

7. * Options for Start screen

8. * Everything else. This program will be targeted to most casual users, so behave like ones

KNOWN ISSUES LIST:

A. * Changing recent program count doesn't effect immediately

B. * "Pin to Start Menu" is not shown in left panel unless you shift+right click

C. * MFU program list is lazely populated

D. * Antiviral program may detect trojans / heuristic malware

* It's a beta quality

1. Yes with exception of known issue C.

2. Yes

3. Yes

4. Yes, they all are.

5. None broken as far as I've tested so far.

6. No anomalies noticed.

7. Can't test Right-Window key, otherwise works beatifully! The only keyboards I have with a right Windows key are PS/2 (that's NOT Playstation 2 for the young 'uns ;) ) and I don't have working generic PS/2->USB adapters, only the other way around, or ones that only apparently work with the Microsoft branded keyboards they came with, which don't have a right Windows key. I know it's TMI.

8. This program is beautiful!!!

D. Built-in Windows Defender under Windows 8 not detecting this as anything (yet). Give MS time, though. :D That would probably be the most obvious uncasual thing to casual users.

Suggestions:

1. For keyboards without a second (right) Windows key, maybe a configurable shortcut for the Apps screen?

2. One thing that has always irked me about Windows XP+ recently used programs is the most used programs (not counting pinned) are furthest away from the Start Button. Once you have the MFU program list working as normal, it would be cool if you could have an option to reverse the order of the list, too.

Edited by roirraW "edor" ehT
0

Share this post


Link to post
Share on other sites

Changed answer to #6 above, "No anomalies noticed" instead of "Haven't tested yet."

0

Share this post


Link to post
Share on other sites

Upgraded to betaone, thanks for those cool improvement in 'advanced' tab. :)

Why does the menu close on its own after you stop mouse for a second, what if you need more time to choose a program? That way it screws up the whole idea of a Start Menu. :(

Other than that it works perfectly well. I don't mind error pop ups on first run of configtool.exe, error "can't obtain data..." show up only once or twice so no biggy.

I'm not having the trouble of the menu closing on it's own. I hovered in one place (over start menu button, over other areas of start menu) for ten seconds without it doing that.

Do you have any third-party mouse driver or mouse-related software?

No, of the drivers I only have catalyst and realtek, that's it. I also made sure to shut down any third-party tools which in my pc is only classic shell and its service and reboot. Same annoyance again and only with startisback for some weird reason:

- the start menu closes on its own after I stop moving mouse for 1 second;

- if I open the start menu and quickly hit and hold 'shift' or 'control', the menu stays open for as long as I need it;

- tried everything that came to my mind as well as advanced and modern UI options in the config menu, and no luck still.

I haven't spotted any bugs except for that awful one. :(

::sad

I must mention my windows is server 2012, but I've seen other folks with startisback on their servers fine. Or could server 2012 be the problem?

0

Share this post


Link to post
Share on other sites

I've installed Beta0ne, my Windows hangs on desktop screen without icons and start menu.

I'm using italian Windows 8 Pro build 9200.

Before using your software i've installed Classic Shell and Stardock's Start 8

post-9577-0-36280100-1350372281_thumb.jp

0

Share this post


Link to post
Share on other sites

I've installed Beta0ne, my Windows hangs on desktop screen without icons and start menu.

Most likely you haven't installed it right. Anyway uninstall with reg file, Win+R should be working. And i hope you didn't left Start8/Classic Shell installed.
- the start menu closes on its own after I stop moving mouse for 1 second;

- if I open the start menu and quickly hit and hold 'shift' or 'control', the menu stays open for as long as I need it;

- tried everything that came to my mind as well as advanced and modern UI options in the config menu, and no luck still.

Let's take a look

Try downloading DebugView from sysinternals and post debug log (dbgview running when you open start menu and it closes itself) here or PM.

Also try invoking Start menu with Ctrl-Esc.

Edited by Tihiy
0

Share this post


Link to post
Share on other sites

I know it's a false positive, but this is what Bitdefender comes up with:

pTnGe.png

Edited by paradox929
0

Share this post


Link to post
Share on other sites

I've installed Beta0ne, my Windows hangs on desktop screen without icons and start menu.

I'm using italian Windows 8 Pro build 9200.

Before using your software i've installed Classic Shell and Stardock's Start 8

your instll path is wrong

copy the “Startisback” to C:\

0

Share this post


Link to post
Share on other sites

itoy, can you tell me about Chinese system experience?

0

Share this post


Link to post
Share on other sites

Time-bomb removed,

Windows Activated,

Startmenu is Back installed

5eze6w.png

this is just great!

0

Share this post


Link to post
Share on other sites

Time-bomb removed,

Windows Activated,

Startmenu is Back installed

this is just great!

THIS IS YOUR LAST AND ONLY WARNING: NO CRACKS / WAREZ TALK HERE!

nitroshift

0

Share this post


Link to post
Share on other sites

itoy, can you tell me about Chinese system experience?

It seem very good.

I have just registered today,not allow to upload pictures。

Here are some pictures link followed

2012-10-16_212824.png

2012-10-16_213020.png

2012-10-16_213641.png

0

Share this post


Link to post
Share on other sites
I must mention my windows is server 2012, but I've seen other folks with startisback on their servers fine. Or could server 2012 be the problem?

I doubt if Server 2012 is the problem, unless it is only in combination with something else.

0

Share this post


Link to post
Share on other sites
I must mention my windows is server 2012, but I've seen other folks with startisback on their servers fine. Or could server 2012 be the problem?

I doubt if Server 2012 is the problem, unless it is only in combination with something else.

Server 2012 runs fine with both his solutions. I've tested new installs, new installs that have been running for a month now and installs that were upgraded from R2 that are a few years old now. No issues.

0

Share this post


Link to post
Share on other sites

Okey doke, quite a few posts added, don'know how to post mine, gonna be huge below:

@Тихому,

I've installed Beta0ne, my Windows hangs on desktop screen without icons and start menu.

Most likely you haven't installed it right. Anyway uninstall with reg file, Win+R should be working. And i hope you didn't left Start8/Classic Shell installed.
- the start menu closes on its own after I stop moving mouse for 1 second;

- if I open the start menu and quickly hit and hold 'shift' or 'control', the menu stays open for as long as I need it;

- tried everything that came to my mind as well as advanced and modern UI options in the config menu, and no luck still.

Let's take a look

Try downloading DebugView from sysinternals and post debug log (dbgview running when you open start menu and it closes itself) here or PM.

Also try invoking Start menu with Ctrl-Esc.

Would you please instruct me how do I proceed with Debug View downloaded from sysinternals, I'm getting this:


00000001 0.00000000 [3520] popup = 0000000000000000
00000002 1.69646263 [3520] popup = 0000000000000000
00000003 4.73416519 [3520] popup = 0000000000000000
00000004 8.26265621 [3520] popup = 0000000000000000
00000005 124.57493591 [3520] popup = 0000000000000000
00000006 124.57753754 [3520] wrapped resolver
00000007 129.21714783 [3520] popup = 0000000000000000
00000008 145.44047546 [3520] popup = 0000000000000000
00000009 147.79969788 [3520] popup = 0000000000000000
00000010 150.09727478 [3520] popup = 0000000000000000

And by the way, just to make sure: I installed it by only clicking 'INSTALL_X64', without touching the X86 reg file, right?

@ISOHaven,

I must mention my windows is server 2012, but I've seen other folks with startisback on their servers fine. Or could server 2012 be the problem?

I doubt if Server 2012 is the problem, unless it is only in combination with something else.

Server 2012 runs fine with both his solutions. I've tested new installs, new installs that have been running for a month now and installs that were upgraded from R2 that are a few years old now. No issues.

Ok, I wonder are you in the built-in user account or not? Could this be due to the fact I'm not using the built-in account (which is admin type though)?

@maxtorix,

5eze6w.png

this is just great!

Wow, it's the nicest 8 I've seen so far? how did you get that awsome blur?!

Thanks.

@itoy,

I've installed Beta0ne, my Windows hangs on desktop screen without icons and start menu.

I'm using italian Windows 8 Pro build 9200.

Before using your software i've installed Classic Shell and Stardock's Start 8

your instll path is wrong

copy the “Startisback” to C:\

I too recommend 'Startisback' on C, mine is on C. However, you can change the path if you edit this line in the reg file @="C:\\StartIsBack\\StartIsBack64.dll". ;) But mind there has to be 2 slashes \\ or it won't work. Just copy as is on C. :)

-------------------------

Thank You for all your replies Folks, much appreciated. :)

0

Share this post


Link to post
Share on other sites
Ok, I wonder are you in the built-in user account or not? Could this be due to the fact I'm not using the built-in account (which is admin type though)?

I was using both the local admin account along with domain accounts.

0

Share this post


Link to post
Share on other sites

I tried it on a user account (Admin), not the default Admin account, under Server 2012.

0

Share this post


Link to post
Share on other sites

I know it's already been mentioned but AVG goes into sulky false-positive mode when I unzip the file. No biggie though, going to give it a bash anyway.

I bumped into this forum while trawling Google, I'm so glad I found it. Knew it was going to be good when my browser landed here. :)

On another note I've tried Classic Shell and the trial of Start8 and this implementation of the old start menu is by far the best I've seen.

0

Share this post


Link to post
Share on other sites

Wow, it's the nicest 8 I've seen so far? how did you get that awsome blur?!

Thanks.

he still uses the RP which supports Aero Glass.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.