• Announcements

    • xper

      MSFN Sponsorship and AdBlockers!   07/10/2016

      Dear members, MSFN is made available via subscriptions, donations and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, become a site sponsor and ads will be disabled automatically and by subscribing you get other sponsor benefits.
Tihiy

Start Is Back - 2.1 release

2,082 posts in this topic

zip and upload the 4 files that show up under "files that help describe the problem"

Sorry I haven't replied sooner. I haven't used my computer much the last month and haven't shut it down at all, so no crashes. But today, I finally did a restart after installing some Windows Updates and it happened again. The error report was slightly different:

4yrv6c1.png

Here are the four "files that help describe the problem": http://www.mediafire.com/download/v9h311ptyeemnbu/ExplorerCrash.zip

Thanks for any help you can give me with diagnosing this crash.

0

Share this post


Link to post
Share on other sites

The crash is caused by some bug in Games folder Parental control Ratings system (sic!).

Wpc!CRatingSystemCache::GetRatingSystem+0x97Wpc!CSystemSettings::GetDefaultRatingsSystemForLocale+0x408Wpc!CSystemSettings::GetCurrentRatingsSystem+0x120Wpc!CSystemSettings::GetCurrentRatingsSystemID+0x36Wpc!CGamesSettings::Initialize+0x84Wpc!CWindowsParentalControls::GetGamesSettings+0x85gameux!CGameExplorer::GetGamesSettingsForUser+0x5agameux!CGameExplorer::GetGamesSettingsForCurrentUser+0x59gameux!CGameExplorer::SetupWPC+0xa7gameux!CGameExplorer::GetGameInternal+0xe8gameux!CGameExplorer::GetGame+0x8bgameux!CGameFolder::GetGame+0x3fgameux!CGameFolder::GetPropertyStore+0x34gameux!CGameFolder::BindToObject+0x7cshell32!CShellItem::BindToHandler+0x4ddshell32!CShellItem::_GetPropertyStoreWorker+0x36bshell32!CShellItem::GetPropertyStoreForKeys+0x116SearchFolder!CGrepQuery::_EvaluateItem+0x1086SearchFolder!CRowsetEnumeration::_EnumerateRowset+0x2f1SearchFolder!CRowsetEnumeration::WaitForResults+0x3fSearchFolder!CQueryResultSet::_HandleBatches+0xbdSearchFolder!CQueryResultSet::RealizeResults+0x19f

It's manifested because StartIsBack adds Games folder into search results.

Unfortunately I'm not sure why your Games folder causes crash, nor there is a setting to remove games from search results.

You may delete your games shortcuts from Games folder one by one to find which one is faulty.

Or you can add explorer.exe into DEP exclusion list.

Edited by Tihiy
0

Share this post


Link to post
Share on other sites

The crash is caused by some bug in Games folder Parental control Ratings system (sic!).

Wpc!CRatingSystemCache::GetRatingSystem+0x97Wpc!CSystemSettings::GetDefaultRatingsSystemForLocale+0x408Wpc!CSystemSettings::GetCurrentRatingsSystem+0x120Wpc!CSystemSettings::GetCurrentRatingsSystemID+0x36Wpc!CGamesSettings::Initialize+0x84Wpc!CWindowsParentalControls::GetGamesSettings+0x85gameux!CGameExplorer::GetGamesSettingsForUser+0x5agameux!CGameExplorer::GetGamesSettingsForCurrentUser+0x59gameux!CGameExplorer::SetupWPC+0xa7gameux!CGameExplorer::GetGameInternal+0xe8gameux!CGameExplorer::GetGame+0x8bgameux!CGameFolder::GetGame+0x3fgameux!CGameFolder::GetPropertyStore+0x34gameux!CGameFolder::BindToObject+0x7cshell32!CShellItem::BindToHandler+0x4ddshell32!CShellItem::_GetPropertyStoreWorker+0x36bshell32!CShellItem::GetPropertyStoreForKeys+0x116SearchFolder!CGrepQuery::_EvaluateItem+0x1086SearchFolder!CRowsetEnumeration::_EnumerateRowset+0x2f1SearchFolder!CRowsetEnumeration::WaitForResults+0x3fSearchFolder!CQueryResultSet::_HandleBatches+0xbdSearchFolder!CQueryResultSet::RealizeResults+0x19f

It's manifested because StartIsBack adds Games folder into search results.

Unfortunately I'm not sure why your Games folder causes crash, nor there is a setting to remove games from search results.

You may delete your games shortcuts from Games folder one by one to find which one is faulty.

Or you can add explorer.exe into DEP exclusion list.

Thanks for the prompt reply! So you're saying that the crashes will stop if I add Explorer.exe as a DEP exception here:

fwGFZOo.png

No need to delete Games folder shortcuts one-by-one to find the culprit if I do the above, correct?

0

Share this post


Link to post
Share on other sites

Yes, that should fix it.

0

Share this post


Link to post
Share on other sites

this is a 64bit explorer, which can't be added there.

have you calculated the Experience score? Try to remove the games The Witcher 2 - Assassins of Kings Enhanced Edition and HL2. Those are the 2 last strings I see in the stack while the crash happens. Maybe one of the tool has an incorrect WEI score requirement which causes the crash.

0

Share this post


Link to post
Share on other sites

Thanks for the heads-up regarding 64-bit Explorer. I have run WEI already. So now I should try removing those two games you mentioned. Is it simply a matter of right-clicking and selecting "Hide This Game?"

IFERT4T.png

VQLpIA7.png

Edited by octiceps
0

Share this post


Link to post
Share on other sites

Also, I'm not sure what you mean by this:

Maybe one of the tool has an incorrect WEI score requirement which causes the crash.

Because neither Witcher 2 nor the two Half-Life 2 games show a WEI score requirement in Games Explorer. The only two games which show it are Battlefield 3 and Battlefield 4 Beta.

q4irS7D.png

B0NM9e1.png

Edited by octiceps
0

Share this post


Link to post
Share on other sites

Have you tried to hide them? Does this fix it?

0

Share this post


Link to post
Share on other sites

Have you tried to hide them? Does this fix it?

Yes I've hidden them. Now it's just a waiting game to see if the crash happens again. It always happens the same way every time, basically when I enter a search term in the Start Menu after boot. But it's random in that it doesn't happen after every reboot, just some of them. I wonder if you or Tihiy could shed some light on why it's random like this.

0

Share this post


Link to post
Share on other sites

Hi there,

Have installed and purchased StartisBack+ for my Windows 8.1 x64 machine, however setting the custom start button icon only works on my main screen - the additional monitor task menu start button still shows the default - any way to set it same for both screens?

Thankspost-382816-0-59515400-1381807188_thumb.

0

Share this post


Link to post
Share on other sites

Hi there,

Have installed and purchased StartisBack+ for my Windows 8.1 x64 machine, however setting the custom start button icon only works on my main screen - the additional monitor task menu start button still shows the default - any way to set it same for both screens?

That means you have enabled 'All screen corners are active on secondary monitors'.

0

Share this post


Link to post
Share on other sites

When I press super key, start menu opens on the screen where the last active window was. I can't find a way to force it to always open on the main screen without removing taskbar from the secondary screen. Please add an option to do that.

Edited by Dissentient
0

Share this post


Link to post
Share on other sites

When I press super key, start menu opens on the screen where the last active window was. I can't find a way to force it to always open on the main screen without removing taskbar from the secondary screen. Please add an option to do that.

You can check the SIB+ option 'Enable on corners on secondary screens'. That will make secondary monitors have standard Start button and open start menu on primary monitor only.

0

Share this post


Link to post
Share on other sites

You can check the SIB+ option 'Enable on corners on secondary screens'. That will make secondary monitors have standard Start button and open start menu on primary monitor only.

I don't want to have corners enabled on any of my monitors.

I just want an option to always open start menu on my main monitor even with taskbar present on all monitors. Enabling corners is not an option because they are annoying.

Basically, I want it to work like it did in 8.0

Edited by Dissentient
0

Share this post


Link to post
Share on other sites

Getting some glitching.

Taskbar seems to be flickering? Not sure if its a Startisback issue or a GFX Driver issue?

0

Share this post


Link to post
Share on other sites

how can we export the Settings to apply them on a 2nd PC?

0

Share this post


Link to post
Share on other sites

Getting some glitching.

Taskbar seems to be flickering? Not sure if its a Startisback issue or a GFX Driver issue?

StartIsBack does not really affect taskbar painting.

how can we export the Settings to apply them on a 2nd PC?

[HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced]

[HKEY_CURRENT_USER\SOFTWARE\StartIsBack]

Export those keys from registry.

0

Share this post


Link to post
Share on other sites

I am a registered user of Startisback. Formerlly with Win 8 Pro x64..

I updated today to Win 8.1 Pro x64. At first no more start menu. I downloaded and installed the newest startisback for 8.1, 1.01.

Now I have a Start menu back, but I lost everything I had in it before. Yes, the secondary start menu works when one clicks Programs (that menu is still how I set it), but the primary one has lost all that I had put in it before. (The one that one first sees on clicking the Start Button,)

Where are those settings for the first start menu one sees, with the items I added to it? Can I get them back? Or do I have to rebuild it from scratch? (One would think though, that SIB would have saved that data some place, from the Win8 version. I should not have to take the time to rebuild it from scratch.)

If I have to rebuild it, another problem. In Explorer, in looking at files and folders, I no longer see the option “Pin to Start Menu”, even if I hold down Shift. (“Pin to Start” is there, but that is for pinning to the Metro Start Screen, not what I want.) How do I get back “Pin to Start Menu”?

And again—is my former Start menu (with the items I added to it) still available somewhere, for me to recover? Didn't SIB save that configuration somehow?

Thank you.

PS I am actually amazed that one still needs SIB or another 3rd party app in order to have a start menu in Win 8.1 There were so many complaints about that with Win8, and so many use these 3rd party programs to get it back. So they added back a start button and one can boot to desktop in 8.1 (without a 3rd party app), but still no Start Menu! Incredibly stupid of Microsoft. But I guess good for you (SIB developer), as people still need your app.

Edited by maikii
0

Share this post


Link to post
Share on other sites

Just recently brought startisback via the gumroad paying format as I didn't particularly want to set up a paypal and the money went through ok but its the old version you get not startisback+ so I cant activate my trial or download my brought version on 8.1 :( any ideas?

Also multi monitor support is non existant but having read previous posts i see its coming soon so ill hold tight :).

0

Share this post


Link to post
Share on other sites

maikii, it seems your trial is expired.

Kingace, Gumroad purchase sends you StartIsBack exe which is exactly the same version as you download. Just dowlnoad StartIsBack+ from here http://startisback.com/#download-tab

0

Share this post


Link to post
Share on other sites

maikii, it seems your trial is expired.

Kingace, Gumroad purchase sends you StartIsBack exe which is exactly the same version as you download. Just dowlnoad StartIsBack+ from here http://startisback.com/#download-tab

Yes I have downloaded it from that link but as Gumroad only gives you a download link and doesn't give you a activation code so I cant activate the program for when the trial period ends :(.

This is the error I get:

puWmqw1.png

And this is all I got given after I brought 5 licenses:

1fqN4Oh.jpg

0

Share this post


Link to post
Share on other sites

Yes I have downloaded it from that link but as Gumroad only gives you a download link and doesn't give you a activation code so I cant activate the program for when the trial period ends :(.

Please write an e-mail to me from your purchase email and we'll find your key!

0

Share this post


Link to post
Share on other sites

Tihly,

Regarding your post #2020.

As I mentioned in my post #2018, I have purchased StartIsBack. So it is not a trial.

I was using SIB 2.1 on Win8 Pro x64. SIB was all paid for and activated.

I updated yesterday to Win8.1 Pro x64. SIB no longer worked. So I went to your site, and downloaded and installed the new version for Win 8.1 SIB+ 1.01. It works, and is listed as activated. It is not a trial.

Rather than repeat myself about what my problem is though, please reread my post 2018 and reply to it. It is not an issue of a trial expiring. I have purchased SIB, and it is activated.

Thank you.

0

Share this post


Link to post
Share on other sites

I understand what your problem is, but the symptoms - blank menu and no ability to pin items indicate that SIB thinks it's trial time out.

Sorry for the trouble. Try deleting SOFTWARE\StartIsBack\License and reactivating.

If it does not help, please write to support email.

0

Share this post


Link to post
Share on other sites

I understand what your problem is, but the symptoms - blank menu and no ability to pin items indicate that SIB thinks it's trial time out.

Sorry for the trouble. Try deleting SOFTWARE\StartIsBack\License and reactivating.

If it does not help, please write to support email.

Although it says its activated, you mean it somehow is not?

The main Start Menu isn'[ completely blank. One or two items are on it, but not those that I placed on it before 8.1. (Once again, the Programs menu is the same as before, with everything I had added., But the main start menu has lost all that I had pinned to it.

So usually, when someone using SIB 2.1 with Win8 upgrades to Win 8.1, and installs SIB+ the menu setup that one had created in SIB2.1 with win8 appears in SIB+ under Win 8.1, with no items lost?

So are you saying that without uninstalling, I should delete the file you mention. Then when one starts Properties of SIB, one will see a request to activate, then type in my activation code (which I will have to look for)? After doing that should I get back the menu setup I had created before?

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.