Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account



Photo

[W7] Domain join failed


  • Please log in to reply
6 replies to this topic

#1
Stagiair

Stagiair
  • Member
  • 4 posts
  • Joined 19-September 12
  • OS:Windows 7 x64
  • Country: Country Flag
Hello,

Hope someone can help me out.
I've been working for weeks on figuring out WDS, Sysprep, answerfile and all other terms.
I succeeded in my testenvironment and now i am deploying images on the companynetwork.
But i get stuck.. at the first computer where i want to install my image with his answerfile (unattend.xml).
Everything is going okay and works but when it finishes with installing and the moment for me is there to log in, it goes wrong.

When i try to log in on the domain it says "The trust relationship between this workstation and the primary domain failed.".
While the domain has been configured on the computer (on the loginscreen you see the domain like: DOMAIN: domain.local).
If i want to log in with the localaccount it says: "Account has been disabled" :S

Did everything as they say here: http://technet.micro...c730845(v=ws.10).aspx at the table under (Secure join) and even tried another computer, but the same problem.

What now?
I have tried everything, serious. The deadline is tomorrow.
Please help!


Unattend: http://pastebin.com/....php?i=xtpCHcXe

Edited by Stagiair, 25 October 2012 - 01:53 AM.



How to remove advertisement from MSFN

#2
Stagiair

Stagiair
  • Member
  • 4 posts
  • Joined 19-September 12
  • OS:Windows 7 x64
  • Country: Country Flag
I could do it with a script, searched an searched but there is not a single script that works to me.

Edited by Stagiair, 25 October 2012 - 07:07 AM.


#3
Tripredacus

Tripredacus

    K-Mart-ian Legend

  • Super Moderator
  • 9,843 posts
  • Joined 28-April 06
  • OS:Server 2012
  • Country: Country Flag

Donator

This XML file you posted puts the system into Audit Mode. You should be doing a domain join in OOBE instead.

Also I see you are adding the Administrator account, this account already exists.
MSFN RULES | GimageX HTA for PE 3-5 | lol probloms
msfn2_zpsc37c7153.jpg

#4
WinOutreach4

WinOutreach4

    Newbie

  • Member
  • 40 posts
  • Joined 22-March 12
  • OS:Windows 7 x64
  • Country: Country Flag
The very last line in this TechNet article says that if you use sysprep /audit to boot to audit mode, the computer will be removed from the domain. The Specialize pass runs during first boot (that's where domain join happens), so you are joining the domain, but then leaving it again when audit mode starts. So Tripredacus is correct and you should remove this part from your unattend file.

Hope this helps,

David

Windows Outreach Team - IT Pro

#5
Stagiair

Stagiair
  • Member
  • 4 posts
  • Joined 19-September 12
  • OS:Windows 7 x64
  • Country: Country Flag
Thanks guys, worked out well!
But my logoncommands don't run! :(
These are the commands that should run:
<FirstLogonCommands>
                <SynchronousCommand wcm:action="add">
                    <CommandLine>cscript //b c:\\windows\\system32\\slmgr.vbs /ipk serial-x-x-x</CommandLine>
                    <Order>1</Order>
                    <RequiresUserInput>false</RequiresUserInput>
                </SynchronousCommand>
                <SynchronousCommand wcm:action="add">
                    <CommandLine>cscript //b c:\\windows\\system32\\slmgr.vbs /ipk serial-x-x-x</CommandLine>
                    <Order>2</Order>
                    <RequiresUserInput>false</RequiresUserInput>
                </SynchronousCommand>
                <SynchronousCommand wcm:action="add">
                    <CommandLine>cscript //b c:\\windows\\system32\\slmgr.vbs /ipk serial-x-x-x</CommandLine>
                    <Order>3</Order>
                    <RequiresUserInput>false</RequiresUserInput>
                </SynchronousCommand>
                <SynchronousCommand wcm:action="add">
                    <CommandLine>cscript //b c:\\windows\\system32\\slmgr.vbs /ato serial-x-x-x</CommandLine>
                    <Order>4</Order>
                    <RequiresUserInput>false</RequiresUserInput>
                </SynchronousCommand>
                <SynchronousCommand wcm:action="add">
                    <CommandLine>cscript //b c:\\windows\\system32\\slmgr.vbs /dlv all</CommandLine>
                    <Order>5</Order>
                    <RequiresUserInput>false</RequiresUserInput>
                </SynchronousCommand>
            </FirstLogonCommands>
I have autologon enabled, so they should run when the account is logged in though?
Those are commands to activate Windows 7 and Office btw.
Under OobeSystem and under the component: Microsoft Windows Shell.
So it should work?

Thanks!

Edited by Stagiair, 26 October 2012 - 02:36 AM.


#6
Stagiair

Stagiair
  • Member
  • 4 posts
  • Joined 19-September 12
  • OS:Windows 7 x64
  • Country: Country Flag
Nevermind.
Everything works now except the computer problem.
You can't prompt for a computername and join the domain unattended.
There is something wrong with the order.

Only do the joindomain part and put the computername tags just this way:
<ComputerName>*<ComputerName>

You will get a random machinename and you can add to your logoncommands a script to rename your pc.
It's a bug we have to deal with!
Searched many days for this but this is the only solution.

#7
WinOutreach4

WinOutreach4

    Newbie

  • Member
  • 40 posts
  • Joined 22-March 12
  • OS:Windows 7 x64
  • Country: Country Flag
Great! Glad to hear that you got it working. As for the computer name while joining the domain, have you looked into Prestaging the computers in Active Directory? WDS will pull the computer name from AD if you have the machine pre-staged.


David

Windows Outreach Team - IT Pro




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users