Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 



WizardOfWoz

Unattend.xml Problem

Recommended Posts

Whenever I put my unattend.xml file in the root of the DVD, it always displays the dreaded "driver needed" screen. Without the XML fle it installs fine. What's even more wild is that I created it using the SIM in the ADK and it still does it. File is as follows:

<?xml version="1.0" encoding="utf-8"?>

<unattend xmlns="urn:schemas-microsoft-com:unattend">

<settings pass="windowsPE">

<component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

<SetupUILanguage>

<UILanguage>en-US</UILanguage>

</SetupUILanguage>

<InputLocale>en-US</InputLocale>

<SystemLocale>en-US</SystemLocale>

<UILanguage>en-US</UILanguage>

<UserLocale>en-US</UserLocale>

</component>

<component name="Microsoft-Windows-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

<UserData>

<ProductKey>

<Key>XXXXX-XXXXX-XXXXX-XXXXX-XXXXX</Key>

<WillShowUI>OnError</WillShowUI>

</ProductKey>

<AcceptEula>true</AcceptEula>

<FullName>XXX</FullName>

</UserData>

</component>

</settings>

<settings pass="specialize">

<component name="Microsoft-Windows-International-Core" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

<InputLocale>en-US</InputLocale>

<SystemLocale>en-US</SystemLocale>

<UILanguage>en-US</UILanguage>

<UserLocale>en-US</UserLocale>

</component>

<component name="Microsoft-Windows-Deployment" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

<RunSynchronous>

<RunSynchronousCommand wcm:action="add">

<Order>1</Order>

<Path>reg add &quot;HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon&quot; /v EnableFirstLogonAnimation /d 0 /t REG_DWORD /f</Path>

<Description>Disable stupid touch tutorial</Description>

</RunSynchronousCommand>

<RunSynchronousCommand wcm:action="add">

<Order>2</Order>

<Path>reg add &quot;HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Setup\OOBE&quot; /v MediaBootInstall /d 0 /t REG_DWORD /f</Path>

</RunSynchronousCommand>

<RunSynchronousCommand wcm:action="add">

<Order>3</Order>

<Path>cscript //B &quot;%windir%\system32\slmgr.vbs&quot; /rearm</Path>

<Description>Reset activation status</Description>

<WillReboot>Always</WillReboot>

</RunSynchronousCommand>

</RunSynchronous>

</component>

<component name="Microsoft-Windows-IE-InternetExplorer" processorArchitecture="wow64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

<DisableAccelerators>true</DisableAccelerators>

<DisableFirstRunWizard>true</DisableFirstRunWizard>

<DisableOOBAccelerators>true</DisableOOBAccelerators>

<Home_Page>http://www.google.com</Home_Page>

<PlaySound>false</PlaySound>

<ShowInformationBar>false</ShowInformationBar>

</component>

<component name="Microsoft-Windows-ErrorReportingCore" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

<DisableWER>1</DisableWER>

</component>

</settings>

<settings pass="oobeSystem">

<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

<OOBE>

<HideEULAPage>true</HideEULAPage>

<NetworkLocation>Home</NetworkLocation>

<ProtectYourPC>2</ProtectYourPC>

</OOBE>

<VisualEffects>

<FontSmoothing>ClearType</FontSmoothing>

<SystemDefaultBackgroundColor>14</SystemDefaultBackgroundColor>

</VisualEffects>

<RegisteredOwner>XXX</RegisteredOwner>

<TimeZone>Central Standard Time</TimeZone>

</component>

</settings>

<cpi:offlineImage cpi:source="wim:d:/win8/source/sources/install.wim#Windows 8 Pro" xmlns:cpi="urn:schemas-microsoft-com:cpi" />

</unattend>

Also, the initial language selection screen still shows (with the "Repair your computer" option). What do I need to change? All references of "x86" to "amd64"?

Share this post


Link to post
Share on other sites

Please attach your Autounattend.xml file for your Windows 8 x64!

Edited by myselfidem

Share this post


Link to post
Share on other sites

Inside your Autounattend.xml file, you can change all values: To: "

Change To:

<Path>reg add "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Setup\OOBE" /v MediaBootInstall /d 0 /t REG_DWORD /f</Path>

More help:

http://technet.micro...WindowsSettings

Microsoft-Windows-Security-SPP\SkipRearm

For most deployment scenarios, this setting is no longer needed. In Windows 8, the Windows licensing state can be reset repeatedly.

http://www.msfn.org/...ost__p__1009846

Edited by myselfidem

Share this post


Link to post
Share on other sites

also in windowsPE pass change to <InputLocale>0409:00000409</InputLocale>

You can remove <UserLocale>en-US</UserLocale> from that pass also

Valid Passes oobeSystem specialize

Edited by maxXPsoft

Share this post


Link to post
Share on other sites

Inside your Autounattend.xml file, you can change all values: To: "

Change To:

<Path>reg add "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Setup\OOBE" /v MediaBootInstall /d 0 /t REG_DWORD /f</Path>

More help:

http://technet.micro...WindowsSettings

Microsoft-Windows-Security-SPP\SkipRearm

For most deployment scenarios, this setting is no longer needed. In Windows 8, the Windows licensing state can be reset repeatedly.

http://www.msfn.org/...ost__p__1009846

That mediabootinstall command is that how you get an upgrade on install with a totally blank drive with an upgrade key? I was needing to know this because I will be changing out my main HD for a SSD so keeping the amount of writes down on the drive helps me a ton. I just need to know what the exact syntax for this needs to be because the forum always butchers it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×