theKramer

Help with unattend.xml file

7 posts in this topic

Hi all.

I get an error in the [generalize] pass when I try to use Sysprep with my unattend.xml file.

File is attached to this post.

Can anyone help me to find the issue?

Unattend.xml

0

Share this post


Link to post
Share on other sites

Microsoft-Windows-PnpSysprep

The Microsoft-Windows-PnpSysprep component specifies whether all Plug and Play information persists during the generalize and specialize configuration passes.

Typically, during the generalize configuration pass, all device information is removed from the reference computer.

During the specialize configuration pass, any Plug and Play devices that are detected on the destination computer are re-initialized.

Any Plug and Play devices that are not detected are removed from the computer.

DoNotCleanUpNonPresentDevices

Specifies whether Plug and Play information persists on the destination computer during the following specialize configuration pass.

PersistAllDeviceInstalls

Specifies whether all Plug and Play information persists on the destination computer during the generalize configuration pass.

Microsoft-Windows-Security-Licensing-SLC

The Microsoft-Windows-Security-Licensing-SLC component removes licensing values set during system installation and testing. It restores the computer to its original state before the user logs on for the first time.

Important:

This setting is deprecated and should not be used. Please use Microsoft-Windows-Security-SPP instead.

This information is for reference only.

Edited by myselfidem
0

Share this post


Link to post
Share on other sites

<!--This answer file generated by RT Seven Lite-->

I'll hope that this was edited? You should not have empty elements.

<UserAccounts>
<LocalAccounts />
<AdministratorPassword>
<Value />
</AdministratorPassword>
</UserAccounts>
<AutoLogon>
<Password>
<Value />
</Password>

Also, why do you specify BOTH the Image Name and the Install Key? You don't need both, pick one or the other.

0

Share this post


Link to post
Share on other sites

Thx for the input guys.

I have taken your suggestions on board.

I have changed the oobesystem pass to use the default admin account.

I still cannot get it to go past the generalize pass tho :(

Unattend.xml

0

Share this post


Link to post
Share on other sites

You can try this file and checked with WSIM!

Always check your file first using WSIM.

HTH


<?xml version="1.0" encoding="utf-8"?>
<unattend xmlns="urn:schemas-microsoft-com:unattend">
<settings pass="windowsPE">
<component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<SetupUILanguage>
<UILanguage>en-US</UILanguage>
</SetupUILanguage>
<InputLocale>1809:00001809</InputLocale>
<UserLocale>en-IE</UserLocale>
<UILanguage>en-US</UILanguage>
<SystemLocale>en-US</SystemLocale>
</component>
<component name="Microsoft-Windows-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<ImageInstall>
<OSImage>
<InstallFrom>
<MetaData wcm:action="add">
<Key>/IMAGE/NAME</Key>
<value>Windows 7 HOMEPREMIUM</value>
</MetaData>
</InstallFrom>
<InstallToAvailablePartition>false</InstallToAvailablePartition>
<WillShowUI>OnError</WillShowUI>
</OSImage>
</ImageInstall>
<UserData>
<ProductKey>
<Key>xxxxx-xxxxx-xxxxx-xxxxx-xxxxx</Key>
<WillShowUI>OnError</WillShowUI>
</ProductKey>
<Organization>QED</Organization>
<FullName>Administrator</FullName>
<AcceptEula>true</AcceptEula>
</UserData>
</component>
</settings>
<settings pass="oobeSystem">
<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<AutoLogon>
<Password>
<Value></Value>
<PlainText>true</PlainText>
</Password>
<Username>Administrator</Username>
<Enabled>true</Enabled>
<LogonCount>5</LogonCount>
</AutoLogon>
<UserAccounts>
<AdministratorPassword>
<Value></Value>
<PlainText>true</PlainText>
</AdministratorPassword>
</UserAccounts>
<OOBE>
<NetworkLocation>Home</NetworkLocation>
<HideEULAPage>true</HideEULAPage>
<HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE>
<SkipUserOOBE>true</SkipUserOOBE>
</OOBE>
<DisableAutoDaylightTimeSet>false</DisableAutoDaylightTimeSet>
<TimeZone>Romance Standard Time</TimeZone>
</component>
</settings>
<settings pass="generalize">
<component name="Microsoft-Windows-PnpSysprep" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<PersistAllDeviceInstalls>true</PersistAllDeviceInstalls>
</component>
<component name="Microsoft-Windows-Security-SPP" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<skiprearm>1</skiprearm>
</component>
</settings>
<settings pass="specialize">
<component name="Microsoft-Windows-Security-SPP-UX" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<SkipAutoActivation>true</SkipAutoActivation>
</component>
<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<donotcleantaskbar>true</donotcleantaskbar>
<showwindowslive>false</showwindowslive>
<ComputerName>Toulouse</ComputerName>
<Copyprofile>true</Copyprofile>
</component>
<component name="Microsoft-Windows-PnpSysprep" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<donotcleanupnonpresentdevices>true</donotcleanupnonpresentdevices>
</component>
</settings>
</unattend>

Edited by myselfidem
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.