Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account


Photo

ASMedia SATA3 in Windows 2000?

- - - - -

  • Please log in to reply
32 replies to this topic

#26
Phenomic

Phenomic

    Member

  • Member
  • PipPip
  • 276 posts
  • OS:none specified
  • Country: Country Flag


I love the new logo. Is that a feather?

I think so. That's blackwingcat's work, not mine.


Now we need some new Firefox, still stuck with v12.0

You can just install the newest version (using Application Compatibility Launcher or just the portable release which is system independent). Make sure to disable hardware acceleration in Firefox' settings before updating it.


ok, I just got around to trying this. Wow it worked, I installed FF 20.0.1. Then I did ther same compatibility thingy for "install_flash_player.exe" and now I have Flash 11.7.700.169... Then I downloaded BWC's "Jre6u43W2K.exe", works too :thumbup

Also, Win2k considers "AMD 12.10 AHCI SB8xx" from your Archive the same as "ahcix86-2k3_2_1540_53" and does not appear to update. Not a problem though. Same for "nVIDIA Display 270.61 for Windows 2000", win2k prefers BWC's "nvw2k26658d" with the NV4_DISP.INF that I had modified to include GTX 550 Ti. The Sabertooth is perfect for win2k, the only thing missing is HDMI Audio.

Edited by Phenomic, 12 April 2013 - 09:26 AM.



How to remove advertisement from MSFN

#27
Phenomic

Phenomic

    Member

  • Member
  • PipPip
  • 276 posts
  • OS:none specified
  • Country: Country Flag
I'm getting ASMedia error in system log. It happens every time system suspends/resumes and there is a 30 delay going into suspend (timeout?), but resume is OK and fast.


Event Type:	Error
Event Source:	asahxp32
Event Category:	None
Event ID:	15
Date:		4/13/2013
Time:		11:18:08 AM
User:		N/A
Computer:	990FX
Description:
The device, \Device\Scsi\asahxp322, is not ready for access yet. 
Data:
0000: 0f 15 18 00 01 00 72 00   ......r.
0008: 00 00 00 00 0f 00 04 c0   .......À
0010: 03 01 00 00 a3 00 00 c0   ....£..À
0018: 01 00 00 00 00 00 00 00   ........
0020: 00 00 00 00 00 00 00 00   ........
0028: 00 00 00 00 00 00 00 00   ........
0030: 00 00 00 00 08 00 00 00   ........
0038: 07 00 00 00 05 00 00 00   ........


#28
Phenomic

Phenomic

    Member

  • Member
  • PipPip
  • 276 posts
  • OS:none specified
  • Country: Country Flag
There is also a 15-30 sec. delay when shutting down. If anybody is troubleshooting asahxp32.inf this is what I get form sysinfo:

Item	Value
Name	Asmedia 106x SATA Controller
Caption	Asmedia 106x SATA Controller
Driver	asahxp32
Status	OK
PNP Device ID	PCI\VEN_1B21&DEV_0612&SUBSYS_84B71043&REV_01\4&39632889&0&0020
Device ID	PCI\VEN_1B21&DEV_0612&SUBSYS_84B71043&REV_01\4&39632889&0&0020
Device Map	Not Available
Index	Not Available
Max Number Controlled	Not Available
IRQ Number	44
I/O Port	0xD050-0xD057
I/O Port	0xD040-0xD043
I/O Port	0xD030-0xD037
I/O Port	0xD020-0xD023
I/O Port	0xD000-0xDFFF
Driver	c:\winnt\system32\drivers\asahxp32.sys (69016, 1.3.8.000 built by: WinDDK)
      
Name	Asmedia 106x SATA Controller
Caption	Asmedia 106x SATA Controller
Driver	asahxp32
Status	OK
PNP Device ID	PCI\VEN_1B21&DEV_0612&SUBSYS_84B71043&REV_01\4&7596680&0&0028
Device ID	PCI\VEN_1B21&DEV_0612&SUBSYS_84B71043&REV_01\4&7596680&0&0028
Device Map	Not Available
Index	Not Available
Max Number Controlled	Not Available
IRQ Number	46
I/O Port	0xC050-0xC057
I/O Port	0xC040-0xC043
I/O Port	0xC030-0xC037
I/O Port	0xC020-0xC023
I/O Port	0xC000-0xCFFF
Driver	c:\winnt\system32\drivers\asahxp32.sys (69016, 1.3.8.000 built by: WinDDK)
      
Name	AMD SATA AHCI Controller
Caption	AMD SATA AHCI Controller
Driver	ahcix86
Status	OK
PNP Device ID	PCI\VEN_1002&DEV_4391&SUBSYS_84DD1043&REV_40\3&267A616A&0&88
Device ID	PCI\VEN_1002&DEV_4391&SUBSYS_84DD1043&REV_40\3&267A616A&0&88
Device Map	Not Available
Index	Not Available
Max Number Controlled	Not Available
IRQ Number	19
I/O Port	0xF040-0xF047
I/O Port	0xF030-0xF033
I/O Port	0xF020-0xF027
I/O Port	0xF010-0xF013
I/O Port	0xF000-0xF00F
Driver	c:\winnt\system32\drivers\ahcix86.sys (207664,  3.2.1540.53 built by: WinDDK)
      


#29
tomasz86

tomasz86

    www.windows2000.tk

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,510 posts
  • OS:XP Pro x86
  • Country: Country Flag

Then I downloaded BWC's "Jre6u43W2K.exe", works too :thumbup

You can just use the official Java installer ;)


the only thing missing is HDMI Audio.

What's the problem with it? Are there any drivers available? What's the hardware ID of the device?


There is also a 15-30 sec. delay when shutting down. If anybody is troubleshooting asahxp32.inf this is what I get form sysinfo:

I also use the same ASMedia driver so I can confirm that there are errors in the Event Viever. The system does shut down / suspend a little bit slowly but I haven't thought that it's because of the driver. Unfortunately I've got no skills to do anything more about it. As long as the system is stable and works properly then I'd say that it's not a serious issue.

Edited by tomasz86, 15 April 2013 - 02:21 AM.

post-47483-1123010975.png
Unofficial Service Pack 5.2 for MS Windows 2000 <- use this topic if you need help with UURollup, Update Rollup 2 and other unofficial packages

#30
Phenomic

Phenomic

    Member

  • Member
  • PipPip
  • 276 posts
  • OS:none specified
  • Country: Country Flag
I guess there are no drivers for HDMI audio(?)... I think it's only needed if you use an HDMI cable out.


I noticed the suspend delay right after I installed the ASMedia SATA driver, so that was easy. Then I looked in event viewer and there it was -- asahxp322.

#31
Phenomic

Phenomic

    Member

  • Member
  • PipPip
  • 276 posts
  • OS:none specified
  • Country: Country Flag
I re-installed without the ASMedia.

Windows2000-UURollup-v11-d20130312-x86-ENU.7z -- ok
IE6.0SP1-KB2792100-WINDOWS2000-X86-ENU.EXE -- error

Posted Image

IE6.0SP1-KB2797052-WINDOWS2000-X86-ENU.EXE -- same error

Crypto service is loaded. Both ie6 updates get to the install form but unload it immediately and pop the error msg.

Then I tried the newer Windows2000-UURollup-v11-d20130427-x86-ENU.7z ... same error with ie updates.

Firefox Setup 21.0.exe -- OK with Compatibility Launcher, Hardware accelerations is on but FF is still working.

Latest Flash 11.7.700.202 -- ok

Latest java from oracle jre-7u21-windows-i586.exe -- OK

Latest fron NVidia 314.22-desktop-winxp-32bit-english-whql.exe -- ok but only manually through device mgr.

gdi++ is awesome, without it win2k would have been unusable.

Anything else to install? :)

#32
blackwingcat

blackwingcat

    Friend of MSFN

  • Member
  • PipPipPipPipPip
  • 745 posts
  • OS:Windows 2000 Professional
  • Country: Country Flag
Did you install roots update ?
or using update.exe which has not modified.

I re-installed without the ASMedia.

Windows2000-UURollup-v11-d20130312-x86-ENU.7z -- ok
IE6.0SP1-KB2792100-WINDOWS2000-X86-ENU.EXE -- error

Posted Image

IE6.0SP1-KB2797052-WINDOWS2000-X86-ENU.EXE -- same error

Crypto service is loaded. Both ie6 updates get to the install form but unload it immediately and pop the error msg.

Then I tried the newer Windows2000-UURollup-v11-d20130427-x86-ENU.7z ... same error with ie updates.

Firefox Setup 21.0.exe -- OK with Compatibility Launcher, Hardware accelerations is on but FF is still working.

Latest Flash 11.7.700.7002 -- ok

Latest java from oracle jre-7u21-windows-i586.exe -- OK

Latest fron NVidia 314.22-desktop-winxp-32bit-english-whql.exe -- ok but only manually through device mgr.

gdi++ is awesome, without it win2k would have been unusable.

Anything else to install? :)


Edited by blackwingcat, 29 May 2013 - 08:00 PM.

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
BlackWingCat =^^=
http://blog.livedoor.jp/blackwingcat/
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

#33
Phenomic

Phenomic

    Member

  • Member
  • PipPip
  • 276 posts
  • OS:none specified
  • Country: Country Flag
I just double-clicked the IE6.0SP1xxxxx ... I thought "root" is only in Linux.:blink:

Anyway, I reinstalled and applied the two IE6.0SP1 before the UURollup and everything worked. I left out the ASMedia driver, the 30 sec. delay/timeout is too annoying. The Sabertooth 990FX R2.0 is the best mobo ever for win2000. I'm gonna try the 8-core AMD Steamroller when it comes out.


... and a correction: the latest driver from NVIDIA did not install with directX support. And I think it only installed partially because I had already installed and tweaked your "nvw2k26658d", otherwise "nVIDIA Display 270.61 for Windows 2000 " is the better solution. Thank you.


Did you install roots update ?
or using update.exe which has not modified.


I re-installed without the ASMedia.

Windows2000-UURollup-v11-d20130312-x86-ENU.7z -- ok
IE6.0SP1-KB2792100-WINDOWS2000-X86-ENU.EXE -- error

Posted Image

IE6.0SP1-KB2797052-WINDOWS2000-X86-ENU.EXE -- same error

Crypto service is loaded. Both ie6 updates get to the install form but unload it immediately and pop the error msg.

Then I tried the newer Windows2000-UURollup-v11-d20130427-x86-ENU.7z ... same error with ie updates.

Firefox Setup 21.0.exe -- OK with Compatibility Launcher, Hardware accelerations is on but FF is still working.

Latest Flash 11.7.700.7002 -- ok

Latest java from oracle jre-7u21-windows-i586.exe -- OK

Latest fron NVidia 314.22-desktop-winxp-32bit-english-whql.exe -- ok but only manually through device mgr.

gdi++ is awesome, without it win2k would have been unusable.

Anything else to install? :)


Edited by Phenomic, 30 May 2013 - 01:21 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users



How to remove advertisement from MSFN