Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account



Photo

UURollup v11 and Microsoft Silverlight Plugin

- - - - -

  • Please log in to reply
21 replies to this topic

#1
ppgrainbow

ppgrainbow

    Advanced Member

  • Member
  • PipPipPip
  • 478 posts
  • Joined 04-October 11
  • OS:Vista Ultimate x64
  • Country: Country Flag
I have a problem here. Currently I have already updated to the latest weekly version of UURollup v11 (2012-11-04) and when I try to access websites that require Microsoft Silverlight, the plugin itself crashes. :(

Here's the screenshot of what it looks like: http://twitpic.com/bcqccj/full

The same situation happens under Google Chrome and it even crashes the Opera browser.

Other plugins work fine. Microsoft Silverlight can be found in the "\Program Files\Microsoft Silverlight" directory and the current version that I'm using is version 4.1.10329.0.

Is there a way to investigate what could be causing this issue and fix it?

Thanks. :)

AVA Direct FX AM3+ specs: Zalman ZM Z9-U3 Black Mid-Tower case / ASUS M5A97 R2.0 / AMD FX-4300 3.8 GHz quad-core processor / Fractal Design Integra R2 500W PSU / Hyper 212 EVO CPU cooler / 2 x Western Digital BLACK SERIES 1 TB (WD1003FZEX) SATA III 7200 RPM / Lite-On iHas124 Black 24x DVD-RW / 8 GB Crucial Ballistix Sport PC3-12800 DDR3 (2 x 4 GB) / StarTech SATA-to-CompactFlash Adapter (35BAYCF2SAT) / EVGA GeForce 8400 GS 520 MHz 1 GB GDDR3 / Microsoft Windows Vista Ultimate SP2 x64

 



How to remove advertisement from MSFN

#2
tomasz86

tomasz86

    www.windows2000.tk

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,528 posts
  • Joined 27-November 10
  • OS:none specified
  • Country: Country Flag
Confirmed. I'll try to check it ASAP.

post-47483-1123010975.png


#3
ppgrainbow

ppgrainbow

    Advanced Member

  • Member
  • PipPipPip
  • 478 posts
  • Joined 04-October 11
  • OS:Vista Ultimate x64
  • Country: Country Flag

Confirmed. I'll try to check it ASAP.


Alrighty! I think that it would be good to investigate which DLL is causing Microsoft Silverlight to either not work correctly or crash and if you found the problem, let me know. :)

AVA Direct FX AM3+ specs: Zalman ZM Z9-U3 Black Mid-Tower case / ASUS M5A97 R2.0 / AMD FX-4300 3.8 GHz quad-core processor / Fractal Design Integra R2 500W PSU / Hyper 212 EVO CPU cooler / 2 x Western Digital BLACK SERIES 1 TB (WD1003FZEX) SATA III 7200 RPM / Lite-On iHas124 Black 24x DVD-RW / 8 GB Crucial Ballistix Sport PC3-12800 DDR3 (2 x 4 GB) / StarTech SATA-to-CompactFlash Adapter (35BAYCF2SAT) / EVGA GeForce 8400 GS 520 MHz 1 GB GDDR3 / Microsoft Windows Vista Ultimate SP2 x64

 


#4
tomasz86

tomasz86

    www.windows2000.tk

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,528 posts
  • Joined 27-November 10
  • OS:none specified
  • Country: Country Flag
I'm sorry but haven't had time yet to check the issue :(

Actually, since a few days I didn't have Internet access in VMs and I was really wondering what the reason was. Everything was working properly and then suddenly I couldn't open any websites (only in VMs as Internet worked in my real system). I even checked the problem in XP installed on an another partition and the situation was the same, i.e. there was still no Internet in the VMs (even though the host system was different).

I was suspecting that something was going on with the wireless router which I've been using here but wasn't really sure as the Internet was still working in other circumstances. Now I'm 99% sure that it was indeed the router. It just completely stopped working today. I tried to reconnect the thing, reset the settings, etc. but nothing worked. It seems to be dead. I connected the LAN cable directly to the computer and the Internet is working in the VMs again :ph34r:

I shall be able to check the Silverlight issue in the next few days.

Edited by tomasz86, 19 November 2012 - 02:30 AM.

post-47483-1123010975.png


#5
ppgrainbow

ppgrainbow

    Advanced Member

  • Member
  • PipPipPip
  • 478 posts
  • Joined 04-October 11
  • OS:Vista Ultimate x64
  • Country: Country Flag

I'm sorry but haven't had time yet to check the issue :(

Actually, since a few days I didn't have Internet access in VMs and I was really wondering what the reason was. Everything was working properly and then suddenly I couldn't open any websites (only in VMs as Internet worked in my real system). I even checked the problem in XP installed on an another partition and the situation was the same, i.e. there was still no Internet in the VMs (even though the host system was different).

I was suspecting that something was going on with the wireless router which I've been using here but wasn't really sure as the Internet was still working in other circumstances. Now I'm 99% sure that it was indeed the router. It just completely stopped working today. I tried to reconnect the thing, reset the settings, etc. but nothing worked. It seems to be dead. I connected the LAN cable directly to the computer and the Internet is working in the VMs again :ph34r:

I shall be able to check the Silverlight issue in the next few days.


I sure hope that you got the router fixed by the way. I suspect that there could a bit of a problem with UURollup v11 causing sites that use Microsoft Silverlight to crash.

AVA Direct FX AM3+ specs: Zalman ZM Z9-U3 Black Mid-Tower case / ASUS M5A97 R2.0 / AMD FX-4300 3.8 GHz quad-core processor / Fractal Design Integra R2 500W PSU / Hyper 212 EVO CPU cooler / 2 x Western Digital BLACK SERIES 1 TB (WD1003FZEX) SATA III 7200 RPM / Lite-On iHas124 Black 24x DVD-RW / 8 GB Crucial Ballistix Sport PC3-12800 DDR3 (2 x 4 GB) / StarTech SATA-to-CompactFlash Adapter (35BAYCF2SAT) / EVGA GeForce 8400 GS 520 MHz 1 GB GDDR3 / Microsoft Windows Vista Ultimate SP2 x64

 


#6
tomasz86

tomasz86

    www.windows2000.tk

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,528 posts
  • Joined 27-November 10
  • OS:none specified
  • Country: Country Flag
http://www.msfn.org/board/topic/149233-kernelex-for-win2000/page__view__findpost__p__1019176

The last version of UURollup where Silverlight works is daily v11d120911.

Edited by tomasz86, 20 November 2012 - 07:38 AM.

post-47483-1123010975.png


#7
ppgrainbow

ppgrainbow

    Advanced Member

  • Member
  • PipPipPip
  • 478 posts
  • Joined 04-October 11
  • OS:Vista Ultimate x64
  • Country: Country Flag

http://www.msfn.org/board/topic/149233-kernelex-for-win2000/page__view__findpost__p__1019176

The last version of UURollup where Silverlight works is daily v11d120911.


Thank you for telling me. I could be wrong, but I think that the problem might be due to the latest version of ntdll.dll which is version 5.0.2195.7103 (2012-10-05 20:48:18). I'm wondering if it is possible to either use a older version of ntdll.dll or investigate parts of the ntdll.dll file to determine what caused Silverlight to not work anymore either.

I don't think that Silverlight 5.x even works with this version of the Extended Kernel, but I could be wrong here.

Edit: I heard that blackwingcat got Silverlight 5.x working with the latest version of UURollup v11. If that's the case, I will need to somehow get it working to see if this will remedy the problem.

Edited by ppgrainbow, 20 November 2012 - 07:34 PM.

AVA Direct FX AM3+ specs: Zalman ZM Z9-U3 Black Mid-Tower case / ASUS M5A97 R2.0 / AMD FX-4300 3.8 GHz quad-core processor / Fractal Design Integra R2 500W PSU / Hyper 212 EVO CPU cooler / 2 x Western Digital BLACK SERIES 1 TB (WD1003FZEX) SATA III 7200 RPM / Lite-On iHas124 Black 24x DVD-RW / 8 GB Crucial Ballistix Sport PC3-12800 DDR3 (2 x 4 GB) / StarTech SATA-to-CompactFlash Adapter (35BAYCF2SAT) / EVGA GeForce 8400 GS 520 MHz 1 GB GDDR3 / Microsoft Windows Vista Ultimate SP2 x64

 


#8
tomasz86

tomasz86

    www.windows2000.tk

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,528 posts
  • Joined 27-November 10
  • OS:none specified
  • Country: Country Flag
It's not possible to downgrade ntdll.dll without downgrading a lot of other files too.

Silverlight 5.x doesn't work for me:

http://www.msfn.org/board/topic/149233-kernelex-for-win2000/page__view__findpost__p__1019293.

post-47483-1123010975.png


#9
ppgrainbow

ppgrainbow

    Advanced Member

  • Member
  • PipPipPip
  • 478 posts
  • Joined 04-October 11
  • OS:Vista Ultimate x64
  • Country: Country Flag

It's not possible to downgrade ntdll.dll without downgrading a lot of other files too.

Silverlight 5.x doesn't work for me:

http://www.msfn.org/board/topic/149233-kernelex-for-win2000/page__view__findpost__p__1019293.


I knew it. I kinda have a feeling that the final version of UURollup v11 will most likely break Silverlight support as far as I know.

According to the error details, the crash in Microsoft Silverlight caused by the latest update to UURollup v11 has the offending module name of kernel32.dll (module version 5.0.2195.7193), the exception information output are as follows:

Code: 0xe0434352
Flags: 0x00000001
Record: 0x0000000000000000
Address: 0x000000007C59CB1


So, until there is any word on how to get Silverlight fixed, I'm afraid that we're stuck, which means that we may have to use the older workable version of UURollup (with the version of the files older than 5.0.2195.7193) or uninstall Silverlight completely. :(

Edited by ppgrainbow, 21 November 2012 - 05:10 AM.

AVA Direct FX AM3+ specs: Zalman ZM Z9-U3 Black Mid-Tower case / ASUS M5A97 R2.0 / AMD FX-4300 3.8 GHz quad-core processor / Fractal Design Integra R2 500W PSU / Hyper 212 EVO CPU cooler / 2 x Western Digital BLACK SERIES 1 TB (WD1003FZEX) SATA III 7200 RPM / Lite-On iHas124 Black 24x DVD-RW / 8 GB Crucial Ballistix Sport PC3-12800 DDR3 (2 x 4 GB) / StarTech SATA-to-CompactFlash Adapter (35BAYCF2SAT) / EVGA GeForce 8400 GS 520 MHz 1 GB GDDR3 / Microsoft Windows Vista Ultimate SP2 x64

 


#10
tomasz86

tomasz86

    www.windows2000.tk

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,528 posts
  • Joined 27-November 10
  • OS:none specified
  • Country: Country Flag
At the moment, if you absolutely must use Silverlight then I recommend to uninstall the version of UURollup which you're using now and install daily v11d120911. Silverlight (both 4.x and 5.x) should work with it properly.

Actually I'm 100% sure that it's something with ntdll.dll because I did test it by comparing dailies v11d120911 and v11d120915. Unfortunately kernel32.dll and other files are also dependent on it so it's impossible to keep the old version of ntdll.dll with the new versions of the other files.

post-47483-1123010975.png


#11
ppgrainbow

ppgrainbow

    Advanced Member

  • Member
  • PipPipPip
  • 478 posts
  • Joined 04-October 11
  • OS:Vista Ultimate x64
  • Country: Country Flag

At the moment, if you absolutely must use Silverlight then I recommend to uninstall the version of UURollup which you're using now and install daily v11d120911. Silverlight (both 4.x and 5.x) should work with it properly.

Actually I'm 100% sure that it's something with ntdll.dll because I did test it by comparing dailies v11d120911 and v11d120915. Unfortunately kernel32.dll and other files are also dependent on it so it's impossible to keep the old version of ntdll.dll with the new versions of the other files.


I agree. It's something with ntdll.dll and v11d120915 and up that's causing Silverlight to crash. But what's complicated is that simply replacing older versions of the ntdll.dll would break applications, because kernel32.dll and other files from 5.0.2195.7193 depend on ntdll.dll.

As for the recommendation, I'm with you on this one. I either need to downgrade to v11d120911 or uninstall Silverlight until a update from v11d121104 is made, that is if there is one.

AVA Direct FX AM3+ specs: Zalman ZM Z9-U3 Black Mid-Tower case / ASUS M5A97 R2.0 / AMD FX-4300 3.8 GHz quad-core processor / Fractal Design Integra R2 500W PSU / Hyper 212 EVO CPU cooler / 2 x Western Digital BLACK SERIES 1 TB (WD1003FZEX) SATA III 7200 RPM / Lite-On iHas124 Black 24x DVD-RW / 8 GB Crucial Ballistix Sport PC3-12800 DDR3 (2 x 4 GB) / StarTech SATA-to-CompactFlash Adapter (35BAYCF2SAT) / EVGA GeForce 8400 GS 520 MHz 1 GB GDDR3 / Microsoft Windows Vista Ultimate SP2 x64

 


#12
tomasz86

tomasz86

    www.windows2000.tk

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,528 posts
  • Joined 27-November 10
  • OS:none specified
  • Country: Country Flag
Don't even try to replace ntdll.dll with an older version. It's not that some applications will not work. The system itself will actually NOT boot :ph34r:

post-47483-1123010975.png


#13
ppgrainbow

ppgrainbow

    Advanced Member

  • Member
  • PipPipPip
  • 478 posts
  • Joined 04-October 11
  • OS:Vista Ultimate x64
  • Country: Country Flag

Don't even try to replace ntdll.dll with an older version. It's not that some applications will not work. The system itself will actually NOT boot :ph34r:


Woah! Thank you for telling me. At the moment, it looks like that fixing the Microsoft Silverlight plugin is infeasible right now so I had to uninstall it. :(

Edited by ppgrainbow, 21 November 2012 - 02:07 PM.

AVA Direct FX AM3+ specs: Zalman ZM Z9-U3 Black Mid-Tower case / ASUS M5A97 R2.0 / AMD FX-4300 3.8 GHz quad-core processor / Fractal Design Integra R2 500W PSU / Hyper 212 EVO CPU cooler / 2 x Western Digital BLACK SERIES 1 TB (WD1003FZEX) SATA III 7200 RPM / Lite-On iHas124 Black 24x DVD-RW / 8 GB Crucial Ballistix Sport PC3-12800 DDR3 (2 x 4 GB) / StarTech SATA-to-CompactFlash Adapter (35BAYCF2SAT) / EVGA GeForce 8400 GS 520 MHz 1 GB GDDR3 / Microsoft Windows Vista Ultimate SP2 x64

 


#14
ppgrainbow

ppgrainbow

    Advanced Member

  • Member
  • PipPipPip
  • 478 posts
  • Joined 04-October 11
  • OS:Vista Ultimate x64
  • Country: Country Flag
Update: At this time, I just got word that Silverlight 4.1 and Silverlight 5.x will work with UURollup v11 20120915+ ONLY if the system locale is set to the Japanese language and in Japanese versions of Windows 2000. It will NOT work in languages other than Japanese: http://www.msfn.org/...ost__p__1019919

I think it would be good to do some investigation into the DLLs that caused Silverlight to not work in languages other than Japanese. ;p

Edited by ppgrainbow, 26 November 2012 - 07:20 PM.

AVA Direct FX AM3+ specs: Zalman ZM Z9-U3 Black Mid-Tower case / ASUS M5A97 R2.0 / AMD FX-4300 3.8 GHz quad-core processor / Fractal Design Integra R2 500W PSU / Hyper 212 EVO CPU cooler / 2 x Western Digital BLACK SERIES 1 TB (WD1003FZEX) SATA III 7200 RPM / Lite-On iHas124 Black 24x DVD-RW / 8 GB Crucial Ballistix Sport PC3-12800 DDR3 (2 x 4 GB) / StarTech SATA-to-CompactFlash Adapter (35BAYCF2SAT) / EVGA GeForce 8400 GS 520 MHz 1 GB GDDR3 / Microsoft Windows Vista Ultimate SP2 x64

 


#15
tomasz86

tomasz86

    www.windows2000.tk

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,528 posts
  • Joined 27-November 10
  • OS:none specified
  • Country: Country Flag
Let's wait for BlackWingCat's answer. I've got no idea why it only works with Japanese locale ;)

post-47483-1123010975.png


#16
ppgrainbow

ppgrainbow

    Advanced Member

  • Member
  • PipPipPip
  • 478 posts
  • Joined 04-October 11
  • OS:Vista Ultimate x64
  • Country: Country Flag

Let's wait for BlackWingCat's answer. I've got no idea why it only works with Japanese locale ;)


Me too. v11 of UURollup is already stable in this latest beta...so if there is a way to get Silverlight working on other locales with a upcoming fix to UURollup v11, we'll see what happens.

Update: blackwingcat has concluded that the reason why Microsoft Silverlight crashed in all browsers is that the plugin threw an exception and terminated with the entry point GetThreadPreferredUILanguages linked to KERNEL32.DLL. This entry point is only present on Windows Vista and higher. :(

Update 2: I can confirm that Silverlight crashes in the UURollup v11 2012-11-18 update, because it threw the GetThreadPreferredUILanguages entry point as I don't think that it didn't with UURollup v10d. I sure hope that it will get fixed in UURollup v11 2012-12-02 update. blackwingcat already fixed the issue in KernelEx v22k3.

For now, until further notice, it would be good to set the system locale to Japanese. :)

Edited by ppgrainbow, 28 November 2012 - 09:44 PM.

AVA Direct FX AM3+ specs: Zalman ZM Z9-U3 Black Mid-Tower case / ASUS M5A97 R2.0 / AMD FX-4300 3.8 GHz quad-core processor / Fractal Design Integra R2 500W PSU / Hyper 212 EVO CPU cooler / 2 x Western Digital BLACK SERIES 1 TB (WD1003FZEX) SATA III 7200 RPM / Lite-On iHas124 Black 24x DVD-RW / 8 GB Crucial Ballistix Sport PC3-12800 DDR3 (2 x 4 GB) / StarTech SATA-to-CompactFlash Adapter (35BAYCF2SAT) / EVGA GeForce 8400 GS 520 MHz 1 GB GDDR3 / Microsoft Windows Vista Ultimate SP2 x64

 


#17
tomasz86

tomasz86

    www.windows2000.tk

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,528 posts
  • Joined 27-November 10
  • OS:none specified
  • Country: Country Flag
The issue is not fixed yet because Silverlight still crashes in case of Korean & Chinese locale :angel

I'm still planning to include the fixed files in the new daily sometime this weekend.

GetThreadPreferredUILanguages is also available in blackwingcat's kernel32.dll. He added those NT6 functions some time ago.

Edited by tomasz86, 29 November 2012 - 07:05 AM.

post-47483-1123010975.png


#18
ppgrainbow

ppgrainbow

    Advanced Member

  • Member
  • PipPipPip
  • 478 posts
  • Joined 04-October 11
  • OS:Vista Ultimate x64
  • Country: Country Flag

The issue is not fixed yet because Silverlight still crashes in case of Korean & Chinese locale :angel

I'm still planning to include the fixed files in the new daily sometime this weekend.

GetThreadPreferredUILanguages is also available in blackwingcat's kernel32.dll. He added those NT6 functions some time ago.


Thanks for telling me. I really appreciate it! ^^ I can't wait to see Silverlight working again. :)

AVA Direct FX AM3+ specs: Zalman ZM Z9-U3 Black Mid-Tower case / ASUS M5A97 R2.0 / AMD FX-4300 3.8 GHz quad-core processor / Fractal Design Integra R2 500W PSU / Hyper 212 EVO CPU cooler / 2 x Western Digital BLACK SERIES 1 TB (WD1003FZEX) SATA III 7200 RPM / Lite-On iHas124 Black 24x DVD-RW / 8 GB Crucial Ballistix Sport PC3-12800 DDR3 (2 x 4 GB) / StarTech SATA-to-CompactFlash Adapter (35BAYCF2SAT) / EVGA GeForce 8400 GS 520 MHz 1 GB GDDR3 / Microsoft Windows Vista Ultimate SP2 x64

 


#19
blackwingcat

blackwingcat

    Friend of MSFN

  • Member
  • PipPipPipPipPip
  • 799 posts
  • Joined 31-May 08
  • OS:Windows 2000 Professional
  • Country: Country Flag
Can you display this sample Page ?

http://samples.msdn....ntrolling_media
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
BlackWingCat =^^=
http://blog.livedoor.jp/blackwingcat/
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

#20
ppgrainbow

ppgrainbow

    Advanced Member

  • Member
  • PipPipPip
  • 478 posts
  • Joined 04-October 11
  • OS:Vista Ultimate x64
  • Country: Country Flag

Can you display this sample Page ?

http://samples.msdn....ntrolling_media


When I try to display the sample page that you provided, I get this error message:

The sample could not be loaded.

The sref URL parameter does not match any known sample.

Please fix the URL in the address bar or select another sample.


But other than that, the latest version of Microsoft Silverlight works on other websites that I go to. :)

AVA Direct FX AM3+ specs: Zalman ZM Z9-U3 Black Mid-Tower case / ASUS M5A97 R2.0 / AMD FX-4300 3.8 GHz quad-core processor / Fractal Design Integra R2 500W PSU / Hyper 212 EVO CPU cooler / 2 x Western Digital BLACK SERIES 1 TB (WD1003FZEX) SATA III 7200 RPM / Lite-On iHas124 Black 24x DVD-RW / 8 GB Crucial Ballistix Sport PC3-12800 DDR3 (2 x 4 GB) / StarTech SATA-to-CompactFlash Adapter (35BAYCF2SAT) / EVGA GeForce 8400 GS 520 MHz 1 GB GDDR3 / Microsoft Windows Vista Ultimate SP2 x64

 


#21
blackwingcat

blackwingcat

    Friend of MSFN

  • Member
  • PipPipPipPipPip
  • 799 posts
  • Joined 31-May 08
  • OS:Windows 2000 Professional
  • Country: Country Flag


Can you display this sample Page ?

http://samples.msdn....ntrolling_media


When I try to display the sample page that you provided, I get this error message:

The sample could not be loaded.

The sref URL parameter does not match any known sample.

Please fix the URL in the address bar or select another sample.


But other than that, the latest version of Microsoft Silverlight works on other websites that I go to. :)

Yes, I see.
Do you know what the problem comes from ?
I want to resolve it.
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
BlackWingCat =^^=
http://blog.livedoor.jp/blackwingcat/
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

#22
tomasz86

tomasz86

    www.windows2000.tk

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,528 posts
  • Joined 27-November 10
  • OS:none specified
  • Country: Country Flag
I also still have the same problem with Silverlight which is that it doesn't work when system locale is set to Korean.

post-47483-1123010975.png





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users