Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account



Photo

Winpeshl.ini help

- - - - -

  • Please log in to reply
6 replies to this topic

#1
madpro

madpro
  • Member
  • 4 posts
  • Joined 17-May 11
  • OS:Windows 7 x86
I have a batch file that kicks off diskpart to ready a drive for installation, then it goes on to copy a wim from one network location to another, than applies that wim

This process works manually, so I can boot winpe, then I change drive to D: and kick of the batch file from here, diskpart runs, then closes and the wim copies over and is applied to the HDD, on reboot it boots to windows

I want to automate this process using winpeshl.ini, so so far I have

created winpeshl.ini and copied it to windows\system32 on the boot.wim
copied the batch file and diskpart text file to same folder

Now what happens is diskpart runs ok but then the process falls over at the stage where I am maping the network location, it says it cant start the workstation service

Can anyone assist please?


How to remove advertisement from MSFN

#2
Tripredacus

Tripredacus

    K-Mart-ian Legend

  • Super Moderator
  • 9,923 posts
  • Joined 28-April 06
  • OS:Server 2012
  • Country: Country Flag

Donator

I'd recommend doing your automation testing with startnet.cmd, and after you get all your commands down, switch it over to winpeshl.ini. The syntax is different for winpeshl.ini. Can you post the contents of it? (obfusicate things like server names, usernames, passwords). Also what version of WinPE are you using and what packages did you add during the build process?
MSFN RULES | GimageX HTA for PE 3-5 | lol probloms
msfn2_zpsc37c7153.jpg

#3
madpro

madpro
  • Member
  • 4 posts
  • Joined 17-May 11
  • OS:Windows 7 x86
Hi Tripredacus

I am using PE 3.0 and I havent added any packages, it is just a basic PE used to boot a machine and copy over a wim from a network location

bat file

diskpart /s d:\*.txt
net use p: \\share address
p:
copy *.wim m:

txt file

select disk 0
clean
create partition primary size=512
select partition 1
format fs=ntfs label=system quick
assign letter=c
active
create partition primary
select partition 2
format fs=ntfs label=win7 quick
assign letter=m
exit

winpeshl.ini

[LaunchApp]
AppPath = %SYSTEMDRIVE%\windows\system32\*.bat

So I need the txt file to prepare the hard drive for the image, then copy the wim from one location to another and apply it to the HDD

#4
Tripredacus

Tripredacus

    K-Mart-ian Legend

  • Super Moderator
  • 9,923 posts
  • Joined 28-April 06
  • OS:Server 2012
  • Country: Country Flag

Donator

Map your drive before running diskpart.
MSFN RULES | GimageX HTA for PE 3-5 | lol probloms
msfn2_zpsc37c7153.jpg

#5
madpro

madpro
  • Member
  • 4 posts
  • Joined 17-May 11
  • OS:Windows 7 x86
I tried mapping the drive first, but get an error about workstation service not being started

I added this to the batch file but get another error saying the servbice cant be started

I assume it is because winpe hasnt fully loaded when the mapping is trying to run

The reason I say this is cause if the batch and txt file are just at the root of the winpe folder and I dont use winpeshl, when winpe has loaded it is at an x prompt, I can then do D: and run the batch file from there and it all works fine

#6
Tripredacus

Tripredacus

    K-Mart-ian Legend

  • Super Moderator
  • 9,923 posts
  • Joined 28-April 06
  • OS:Server 2012
  • Country: Country Flag

Donator

Try using a startnet.cmd (blank out your winpeshl.ini for this test) and have this at first:

wpeinit
wpeutil initializenetwork
ping 127.0.0.1 -n 16 -w 1000>null
net use z: \\7SERVER\images password /user:kdineen

I personally do not use winpeshl.ini for any boot images that connect to the internet. Note, the InitializeNetwork command may or may not be required. The ping is in place because not all NICs are immediately usable after being enumerated.
MSFN RULES | GimageX HTA for PE 3-5 | lol probloms
msfn2_zpsc37c7153.jpg

#7
madpro

madpro
  • Member
  • 4 posts
  • Joined 17-May 11
  • OS:Windows 7 x86
Thanks Tripredacus

I'll try that and let you know :thumbup




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users