Sign in to follow this  
Followers 0
coolman

System Restore doesn't work on Windows 98 SE

8 posts in this topic

I followed all the steps in this post:

But whenever I open System Restore, it gives me the following message:

"The SFPDLL.DLL file is linked to missing export WINTRUST.DLL:CryptCATAdminAcquireContext."

Help?

Edited by coolman
0

Share this post


Link to post
Share on other sites

The Win98se version of WINTRUST.DLL doesn't contain a function named CryptCATAdminAcquireContext. You either shouldn't be using the WinMe version of SFPDLL.DLL (unlikely), or you also need the WinMe version of WINTRUST.DLL. That file probably also has dependencies....

Try this MDGx page and link for the version of WINTRUST.DLL and other files you probably need:

0

Share this post


Link to post
Share on other sites

Over the years I've found this line to be even simpler: From DOS boot: Scanreg /restore

Often by returning the registry to a previous day or even a couple of days a proper boot takes place, et voila, no need for complicated system restore.

At the very least it's worth trying first i'd say.

0

Share this post


Link to post
Share on other sites

I followed all the steps in this post:

But whenever I open System Restore, it gives me the following message:

"The SFPDLL.DLL file is linked to missing export WINTRUST.DLL:CryptCATAdminAcquireContext."

Help?

Looks to me like your system is outdated. Yes you will need specific system files. I don't have a list, but because I use SP3, my system has all latest files, so I have no issues as far as that goes. System Restore working on Windows 98 Second Edition

The Win98se version of WINTRUST.DLL doesn't contain a function named CryptCATAdminAcquireContext. You either shouldn't be using the WinMe version of SFPDLL.DLL (unlikely), or you also need the WinMe version of WINTRUST.DLL. That file probably also has dependencies....

Try this MDGx page and link for the version of WINTRUST.DLL and other files you probably need:

The WinME version of CRYPTME.EXE will break a Win98 system. This is why Win98 have its own package. System Restore working on Windows 98 Second Edition
0

Share this post


Link to post
Share on other sites

I installed SP3 but I still get the message.

If I can remember correctly, I believe you need MDAC 2.8 SP1 and WMI 1.5 installed. :ph34r:
0

Share this post


Link to post
Share on other sites

I installed SP3 but I still get the message.

If I can remember correctly, I believe you need MDAC 2.8 SP1 and WMI 1.5 installed. :ph34r:

It works but it says "Restoration Was Unsuccessful" whenever I try to restore.

0

Share this post


Link to post
Share on other sites

I installed SP3 but I still get the message.

If I can remember correctly, I believe you need MDAC 2.8 SP1 and WMI 1.5 installed. :ph34r:

It works but it says "Restoration Was Unsuccessful" whenever I try to restore.

I know. This is the bug I'm trying to fix. Sometimes it worked and sometimes it don't. It also depends on whats running in the background. Just be patient, I'm working on a solution. Thank you for testing.
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.