Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account



Photo

Need help with unattend.xml


  • Please log in to reply
2 replies to this topic

#1
Scrumps

Scrumps
  • Member
  • 2 posts
  • Joined 12-February 12
  • OS:none specified
  • Country: Country Flag
I have been trying to create an unattend.xml file to deploy with a standard (non-sysprep'ed) iso image of Windows 7 SP1 Professional. I have been using WSIM to this, and using the catalog file of my Windows 7 image that was extracted to the D: drive which is specifically for PXE/Windows Deployment Services.
This worked once, but my deployment server for my house has somehow broken, and the snapshot I made isn't resolving the problem. I have tried following numerous different guides, but none of them seem to work correctly.

I don't want to automate the entire install process, as I want to be select the drive that is being used. But I want everything else to be automated, so after I choose the drive, it automatically boots into my account after I finish. After customizing specific things, I validate the XML and it does not return an error, so I am really confused. Could someone assist me and tell me what I am doing wrong and link me to the proper way to do it please? Just overly frustrated at the moment, because I have tried rebuilding the image, three times, and because I deployed my main desktop thinking that nothing was broken with it, I am now without my main machine, and am working off a sketchy laptop that BSOD's at least once a day.

I took out the product key, and encrypted password (and non-encrypted password).

I really appreciate any help that anyone could give me. Thank you.

Attached Files


Edited by Scrumps, 23 November 2012 - 09:51 PM.



How to remove advertisement from MSFN

#2
maxXPsoft

maxXPsoft

    MSFN Master

  • Developer
  • 2,922 posts
  • Joined 14-November 03
  • OS:Windows 7 x64
  • Country: Country Flag
Are you really wanting to use Audit Mode?
Then you have to create a User in auditsystem to use in audituser

Example AutoUnattend.xml here that does not contain Installto so you will be prompted for disk
http://www.msfn.org/...post__p__892782
Place the AutoUnattend.xml on floppy or usb stick and you can change if errors without having to reburn

Edited by maxXPsoft, 24 November 2012 - 03:59 AM.

Jump2Reg - Registry: - Aug 8, 2015 - Version 4.0.0 - 98, ME, NT, 2K, XP, VISTA, Seven, Windows 8, Windows 10 32 or 64 bit
jump2reg291.png

 

Download ++> Windows 7 + 8 Unattended DVD + App Installer + Services Disabler + Load All Button + XML Creator
XP Unattended CD/DVD creator - Version 4.1.7
Sample xml + Setupcomplete + Add Right click .wim Windows 7 or Windows 8/8.1


#3
Scrumps

Scrumps
  • Member
  • 2 posts
  • Joined 12-February 12
  • OS:none specified
  • Country: Country Flag
Is the ImageInstall section under amd64_Microsoft-Windows-Setup_neutral necessary if I am installing it over a WDS setup that already has the determined version to install?

Isn't the PXE/Boot.wim the windowsPE part?

I took the xml example you gave and edited a bit, but some things are not working correctly for me.

1) Display Name is not properly set
2) OEM Information is not being set properly.
3) Any packages that have been modified aren't being set (specifically removing IE, disabling anytime upgrade, and the Windows Gadget Platform).
4) From the looks of it the owner information isn't being set properly either.

What would the best place be for a local user addition be? I am really setting this up not for sysprep'ing, but just for an easier way to install Windows on all of my machines, so I figure that audit modes don't need to be used for me to create a user in this situation. Either way, sorta clueless about this.

And now I am at a loss. I tested this through Windows Deployment Server using Server 2012. It worked fine with my test machine which was a VM (sans the problems above), so I went a head and installed it on the actual machine, and nothing worked. It didn't pull any of the information in the xml file. :|

Attached Files


Edited by Scrumps, 25 November 2012 - 03:07 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users