Sign in to follow this  
Followers 0
XPerties

FTP uploader????

25 posts in this topic

I have a few friends who I met on here and on the message boards for XP. There looking to download build 2600 but they cant get a good connection.I was wondering if theres a EASY ftp program I can use for them to download directly from me. I have getright. Would that work. Your help would be greatly appreciated. Thanks in advance!

Regards, Chris

0

Share this post


Link to post
Share on other sites

You will need FTP Server software, such as BulletProof FTP Server or Serv-U (BulletProof is better IMO)

Set up a user account for each friend you have, and share the drectory which has your 2600 rars/iso files. They can login to your FTP Server through your IP address and a user/pass. They can do it through their FTP Client (CuteFTP) or through a download manager (GetRight, Flashget) if they know the full path.

0

Share this post


Link to post
Share on other sites

Thanks Aaronxp, works great.!

-Regards, Chris

0

Share this post


Link to post
Share on other sites

I want to set up an FTP but i have my PC conected to a lynksys router which is then connected to my cable modem.

I can set the FTP up using my local IP but it cannot be accessed from outside the network, if i try to set it up using my public IP i get a message saying port 21 allredy in use.

Im using bulletproof FTP, how can i make this work....?

Regards,

BAH

0

Share this post


Link to post
Share on other sites

In BulletProof FTP Server, go to the following drop-down menus: Setup > Main > General. Change the port number to something like 2600, and then get someone to test and login into your FTP using the IP address and port number. See what happens.

0

Share this post


Link to post
Share on other sites

why not try both?

Anyway, bulletproof should tell you what IP its using when you put the FTP online

0

Share this post


Link to post
Share on other sites

Aaron,

If i use my internal IP FTP cant be accessed from the outside, if i use my WAN IP i get an error no matter what port i use....

Regards,

BAH

0

Share this post


Link to post
Share on other sites

If you want to run a server on a computer connected to your ICS machine then you can run something like a port mapper to redirect requests on the ICS machine to the computer running the server.

You can get AnalogX's Port Mapper for free and redirect ports 20 and 21 to an internal IP and it should allow you to run the server from another computer on your LAN.

ht*p://www.analogx.com (check the Network section)

0

Share this post


Link to post
Share on other sites

What port are you using...?

is there a username and password..?

0

Share this post


Link to post
Share on other sites

I cannot access your FTP NikNt, an error occurs. You are probably able to access your own FTP because its on the PC you're using.

0

Share this post


Link to post
Share on other sites

BAH, my setup is like yours, a Netgear router, and a NTL cable modem.

What you need to do is setup port forwarding on your Linksys router, I am not entirely sure on what steps you take to do this, but on mine I have done this: Under "PORT FORWARDING" also known as SUA, I have forwarded port 27015 to my computer IP: 192.168.0.2. I also did 50000 through to 51000 to my computer too for a valid range to allow passive connections.

Now in BPFTP it should show your internal IP as the IP for the server:

30/09/2001 12:36:12 - FTP Server On-line : IP(s) 192.168.0.2, on port 27015

This will automatically forward to a WAN IP if you have setup things correctly for the router and the server program, you also need to set your WAN IP for BPFTP, which I see you have done. Also under Multi IP Settings you may want to set 50000 to 51000 for passive connections, and set the passive mode IP too.

I think this should make it work, as it works for me! :)

aMb

0

Share this post


Link to post
Share on other sites

Thanks AMB sorted this last night by setting up the forwarding, all works now im just loading it with s/ware

Regards,

BAH

0

Share this post


Link to post
Share on other sites

Sorry for confusing you yesterday. I sort it out today. The firewall was blocking access. Stupid isn't it?

Thank

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.