Welcome to MSFN

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Sign in to follow this  
Followers 0
huguia

Windows 98 Registry error!

5 posts in this topic

I have this P3, 256 mb RAM, NVIDIA TNT2 with Windows 98 SE. I have installed Unofficial Service Pack 3 and it runs really well. However, after some reboots, it says, Windows Registry Error, it reboots and the computer gets crazy, some programs stop working etc.

I have reinstalled windows 6 times and at the last one, i went to msconfig and diabled scanregw.

However, i rebooted it and it boot to an MSDOS window and restored a backup of the registry. it is now crazy again!

Help me! I'm losing my temper!

0

Share this post


Link to post
Share on other sites

If your HDD has a large on-board cache, or it is older and slower, then when you shutdown Windows the system may be powering down before the registry is fully flushed (written) from the HDD cache back to the platters.

You can try using Regedit to set

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\CacheWriteDelay

to 2000 (decimal) or 4000 if already present. Delay is in milliseconds.

0

Share this post


Link to post
Share on other sites

If your HDD has a large on-board cache, or it is older and slower, then when you shutdown Windows the system may be powering down before the registry is fully flushed (written) from the HDD cache back to the platters.

You can try using Regedit to set

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\CacheWriteDelay

to 2000 (decimal) or 4000 if already present. Delay is in milliseconds.

Yes! It's an old Seagate Barracuda, 6GB noisy as hell!

Should i put the delay bigger than that or that is ok?

EDIT: I can't find that folder in the registry :(

Edited by huguia
0

Share this post


Link to post
Share on other sites
You can try using Regedit to set

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\CacheWriteDelay

to 2000 (decimal) or 4000 if already present. Delay is in milliseconds.

I can't find that folder in the registry
Really? Not there??? REALLY?

Read this and go from there. ;)

0

Share this post


Link to post
Share on other sites

Yes! It's an old Seagate Barracuda, 6GB noisy as hell!

Yeah, older drives are noisier than modern drives but "noisy as hell!" ?

Sounds to me as though your hard drive is failing. At least you ought to check it for bad sectors.

Do you have another hard drive you can try?

Then again is the overall age of your hardware. Old motherboards may work OK from a cold start but can become unstable after they have been powered up for a while and get warm.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.