Welcome to MSFN

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Sign in to follow this  
Followers 0
DeltaForceLeader

Windows 7 folder sharing issues

5 posts in this topic

I have an external Western Digital My Book drive connected to a Windows 7 Ultimate PC that I am using as a file server for my network. Due to the personal content on the drive I have the drive secured using the WD SmartWare software. However, this has caused a side effect. Every time I shut down or restart the server it "forgets" all of the shared folders. Windows remembers all of the shared folders on the other external drives that are unsecured so I know it is not a problem with Windows itself. What I have decided to do is set up a batch file to restore all of the shared folders and permissions that I can execute after a reboot. Unfortunately, I am having trouble getting the commands to work properly. This is the command I am using:

NET SHARE {share name}={path} /GRANT:{username},FULL

When I enter this command I get the following "syntax" message:

The syntax of this command is:

NET SHARE

sharename

sharename=drive:path [/GRANT:user,[READ | CHANGE | FULL]]

[/uSERS:number | /UNLIMITED]

[/REMARK:"text"]

[/CACHE:Manual | Documents| Programs | BranchCache | None]

sharename [/uSERS:number | /UNLIMITED]

[/REMARK:"text"]

[/CACHE:Manual | Documents | Programs | BranchCache | None]

{sharename | devicename | drive:path} /DELETE

sharename \\computername /DELETE

I have tried this command and it works:

NET SHARE {share name}={path}

Therefore, the problem is obviously with the user information. I would appreciate any help with this issue.

P.S. I have tried entering the user as both a username and domain/username combo.

0

Share this post


Link to post
Share on other sites

NET SHARE {share name}={path} /GRANT:{username},FULL

When I enter this command I get the following "syntax" message:

There must be an error in how you are typing it. I just tested this command it and it works fine using an elevated command prompt:

net share intel=c:\intel /GRANT:test,FULL

0

Share this post


Link to post
Share on other sites

There must be an error in how you are typing it. I just tested this command it and it works fine using an elevated command prompt:

net share intel=c:\intel /GRANT:test,FULL

Thank you! I forgot to use an elevated command prompt. That is why the command wouldn't work.

0

Share this post


Link to post
Share on other sites

That's great. I did some research on that software and found just about nothing about sharing the drive (other than the backup) and didn't look forward to troubleshooting a software compatibility problem.

:thumbup

0

Share this post


Link to post
Share on other sites

That's great. I did some research on that software and found just about nothing about sharing the drive (other than the backup) and didn't look forward to troubleshooting a software compatibility problem.

:thumbup

Yeah, the problem is that since the drive is encrypted until unlocked with a password, Windows cannot read it at start-up and therefore deletes the shares from its list. If I couldn't get the batch file working (which I have fully tested and is working thanks to you) my only other option would be to permanently unlock the drive. Thanks, again! :hello:

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.