• Announcements

    • xper

      MSFN Sponsorship and AdBlockers!   07/10/2016

      Dear members, MSFN is made available via subscriptions, donations and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, become a site sponsor and ads will be disabled automatically and by subscribing you get other sponsor benefits.
Sign in to follow this  
Followers 0
talalplc

Strange problem with Autounattend

9 posts in this topic

I am coming through very wear behavior with my Autounattend:

I have english/Arabic mui ultimate w7 32bit with language integrated in both install.wim and boot.wim index2

Every thing is OK

but........

It seems when ever I add windows pe setting pass the very first welcome language select page + repair page + upgrade page not showing anymore regardless setting in Autounattend!!!

it will jump directly to second language select page !!! on the other hand ; when I delete WINDOWSPE pass the above pages are displayed but the spesialize and oobe passes are ignored ,

I rerpeat again : I have no problem regarding language integration or installation .

some body saied that there is conflict between Autounattend and these pages.

please help me.

here is my Autounattend.xml attached

0

Share this post


Link to post
Share on other sites

Don't forget to remove the key inside the file when this one is attached !

You need to add the pass="windowsPE" (example):


<settings pass="windowsPE">
<component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<SetupUILanguage>
<UILanguage>en-US</UILanguage>
</SetupUILanguage>
<InputLocale>1809:00001809</InputLocale>
<UserLocale>en-IE</UserLocale>
<UILanguage>en-US</UILanguage>
<SystemLocale>en-IE</SystemLocale>
</component>

And adding also inside pass="oobeSystem":


<settings pass="oobeSystem">
<component name="Microsoft-Windows-International-Core" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<UILanguage>en-US</UILanguage>
<UserLocale>en-IE</UserLocale>
<SystemLocale>en-IE</SystemLocale>
<InputLocale>1809:00001809</InputLocale>
</component>

Integration for the language pack also inside boot.wim (index:1).

You can check your file with WSIM.

Edited by myselfidem
0

Share this post


Link to post
Share on other sites

I removed your attachment. The ProductKey you had in the WinPE pass was not an install key. This is the install key for Windows 7 Ultimate:

D4F6K-QK3RD-TMVMJ-BBMRX-3MBMV

0

Share this post


Link to post
Share on other sites

Thank you both for your kindness and fast response

however....you don't seems to understand my issue :unsure:

pls reread my topic and focus on the BOLD statments

Dear myselfidem

I have zero issue regarding language integration or selection or installation !

and I dont use recovery environment that why i didnt integrate boot.wim index:1

I know you want to help me but please read my topic again it says everything

the brief: I want to see the very first welcome language select page (which says: my language is english and لغتي هي العربية ) and I have to delete the WindowsPE setting pass completly to see it !!! I want to kill my self just to know the relation between them :(

Dear Tripredacus

the key I am using is OK and my ultimate seems to like it :rolleyes:

anyway I well not insert it in my autounattended in the future.

thank you

Edited by talalplc
0

Share this post


Link to post
Share on other sites

It seems you need to check the lang.ini file for the available languages for the silent installation!

Lang.ini file is inside: %Distribution_Folder%\sources\lang.ini

Understanding Multilingual Deployments

If you deploy Windows using Windows Setup and you have added or removed language packs from the distribution share, you must recreate the Lang.ini file. Windows Setup uses the Lang.ini file to identify the language packs inside the image and within the Windows distribution share. The Lang.ini file is also used to identify the language that will be displayed during Windows Setup. Regenerating the Lang.ini file is also necessary if you plan to create recovery media for images that contain multiple languages.

Languages and International Servicing Command-Line Options

Dism.exe with /Gen-LangINI to create a new lang.ini file.

Walkthrough: Add Multilingual Support to Windows Setup

Edited by myselfidem
0

Share this post


Link to post
Share on other sites

thank you very much

I well check and report back.

but if there is any kind of problem why every thing is perfect when I delete WindowsPE setting pass?? (or delete the answer file completly)

Any way I well try tomorrow

thank you again

0

Share this post


Link to post
Share on other sites

My friend

I could not wait till tomorrow

I test it and every thing is OK

I have two entries in lang.ini in booth distribution and boot.wim\sources

I have allready the page which ask me to choose between two languages in windows setup.....it is OK

the problem i dont get the first setup language selection page which says : my language is english or لغتي هي العربية

when I delete the windowpe setting pass from my answer file it is ok and fully functional

so it is not integration Issue!!

this drive me creazy!

0

Share this post


Link to post
Share on other sites

note : i am not defining any language settings in my pe pass as you noticed in my answer file so there is no logic

this topic explain exactly what I am talking about

myselfidem !!!

i know this is hard and that is why I asked for your help first place and i wish you can help me out

Edited by talalplc
0

Share this post


Link to post
Share on other sites

Change inside your Autounattend.xml the settings pass="windowsPE" to:


<settings pass="windowsPE">
<component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<SetupUILanguage>
<WillShowUI>Always</WillShowUI>
</SetupUILanguage>
</component>

Some help:

http://www.msfn.org/...iple-languages/

*Edit:

It seems when ever I add windows pe setting pass the very first welcome language select page + repair page + upgrade page not showing anymore regardless setting in Autounattend!!!

Using Autounattend.xml file we can't have the first page to use + repair page + (etc)! We need to use Windows without Autounattend.xml file!

Edited by myselfidem
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.