Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account


Photo

[Solved] Normal.dot in Office 2003 is Read Only

- - - - -

  • Please log in to reply
6 replies to this topic

#1
mitchsc

mitchsc

    Junior

  • Member
  • Pip
  • 73 posts
  • Joined 21-April 11
  • OS:Windows 7 x64
  • Country: Country Flag
Windows 7 SP1 64 bit. + Office 2003

I used to be able to change default settings in Word using the conventional method, such as Format > Font > select desired settings > Default Yes.

Several months ago, Word inexplicably reverted to the factory default formats, and I could no longer change them as above. Since then I've had to format each new document individually.

Finally did some research into this, and located the Normal.dot file, thinking I would just set my defaults there.

Upon opening Normal.dot, I found it to be Read-Only, so of course it would not allow me to save any changes.

I've tried everything I read about. Deleted Normal.dot, and let Word create a new one. Accessed it in Safe Mode, Deleted to Recycle bin and restored. Opened the file properties to ensure the Read-Only wasn't checked. But it keeps coming back as Read-Only.

I also accessed the Templates folder from 2 different pathways: Start > Computer > OS (C:) > Documents and Settings > Username > AppData > Roaming > Microsoft > Templates
AND: Start > Computer > OS (C:) > Documents and Settings > Username > Application Data > Microsoft > Templates

An odd Caveat. During one attempt to delete and restore from Recycle bin, it came up ONCE without being Read-Only. I was able to change the Font default, but before I could configure any other settings, it reverted back to Read-Only.

This has been driving me nuts all day, and I can't find much on this Read-Only topic. Can someone please tell me how to get rid of this Read-Only situation.

Thanks very much...

PS: I'm setting up a new PC, also Win 7 64 bit + Office 2003. Just checked it's Normal.dot file. Also Read-Only. I must be missing something here. No where in my reading did it allude to this file ever being Read-Only.

Edited by mitchsc, 12 January 2013 - 06:40 PM.



How to remove advertisement from MSFN

#2
Sp0iLedBrAt

Sp0iLedBrAt

    MSFN Addict

  • MSFN Sponsor
  • 1,727 posts
  • Joined 19-March 09
  • OS:XP Pro x86
  • Country: Country Flag
I'm having a similar problem where Normal.dot occasionally gets corrupted and throws an error 0xc5, so I added a batch script to delete it at Logon/Log off.
I've never tried it, but you could try installing it in Compatibility mode for Windows XP and see what happens.

Cheers

#3
mitchsc

mitchsc

    Junior

  • Member
  • Pip
  • 73 posts
  • Joined 21-April 11
  • OS:Windows 7 x64
  • Country: Country Flag
Thanks Spoiled. Unfortunately, your suggestion is "above my pay grade". Any idea why Normal.dot would be read only? That's not "normal" is it?

BTW, I didn't get an email when you replied to my post. Isn't this the correct notification setting: Notification method for replies to topic...

Thanks again.

#4
Sp0iLedBrAt

Sp0iLedBrAt

    MSFN Addict

  • MSFN Sponsor
  • 1,727 posts
  • Joined 19-March 09
  • OS:XP Pro x86
  • Country: Country Flag

Unfortunately, your suggestion is "above my pay grade"


Not really.
1. Insert the Office CD, open it, right-click Setup.exe and choose Properties.
2. Select the Compatibility tab, tick the option to run in Compatibility Mode and choose the OS.
3. Apply/OK.
4. Double-click Setup.exe to run Office Setup.

Like I said, I haven't tried it yet. If you are willing to test, please report back.


BTW, I didn't get an email when you replied to my post. Isn't this the correct notification setting: Notification method for replies to topic...

Attached File  notif.JPG   22.56KB   5 downloads

Cheers

#5
mitchsc

mitchsc

    Junior

  • Member
  • Pip
  • 73 posts
  • Joined 21-April 11
  • OS:Windows 7 x64
  • Country: Country Flag
Got it. Thanks.

Sorry, but if you don't mind, I have one more question.

Before I got too deep into this, I thought I'd try deleting or renaming Normal.dot and letting Word create a new one (as I've read it does when a new Word document is opened) to see if it's still Read-Only. When I do so, it does not create a new Normal.dot. The Templates folder just remains empty, but Word still works. Everything I've read just says to open a new Word doc to create the new template. Am I missing any steps here?

#6
Sp0iLedBrAt

Sp0iLedBrAt

    MSFN Addict

  • MSFN Sponsor
  • 1,727 posts
  • Joined 19-March 09
  • OS:XP Pro x86
  • Country: Country Flag

Start > Computer > OS (C:) > Documents and Settings Users > Username > AppData > Roaming > Microsoft > Templates

This should be the correct path in Windows 7.

Am I missing any steps here?

No, you are not. As I said, I delete Normal.dot (through a batch script) to restore functionality in Word. How Word works without a template, I can't really say. The only thing I can think of is that it must be created somewhere. Re-check the folder and also check if the folder is also Read-Only..

If no file corruption occurs, I guess you could also add a small script that removes the Read-Only attribute from Normal.dot at logon, something along the lines of
attrib -R C:\Users\Username\AppData\Roaming\Microsoft\Templates\Normal.dot
In case you want to copy this, there should be only two blank spaces:
- between attrib and -R;
- between -R and C
To test it, next time you notice Normal.dot is Read-Only, copy this, paste it into a Command Prompt window and press Enter. Then check to see if Read-Only is removed from Normal.dot properties.


Cheers

#7
mitchsc

mitchsc

    Junior

  • Member
  • Pip
  • 73 posts
  • Joined 21-April 11
  • OS:Windows 7 x64
  • Country: Country Flag
Wow!!! SB, you are a genius! At this point I was beginning to think I would never get this figured out. It was the Pathway! The one you gave me led to a Normal.dot file that was NOT Read-Only. Problem Solved!

Two curious things:

1) There are 2 other pathways (that I got from articles and other forums) that also lead to a Templates Folder containing Normal.dot, but these are Read-Only. Somehow, they are even linked. If I deleted one, they all disappeared. FYI: The 2 pathways I was using were: OS (C:) > Documents and Settings > <username> > AppData > Roaming > Microsoft > Templates and OS (C:) > Documents and Settings > <username> > Application Data > Microsoft > Templates

Someone also suggested the following, but it doesn't show the full pathway including "Users". "The location of the Template folder varies in different Windows versions, so the quickest way to find it is to enter this string in the search or run box in the Start Menu: %appdata%\Microsoft\Templates"

2) I can now change the default settings directly in Normal.dot (thanks to you), but still cannot within a regular Word document by hitting the default button after a format change. ???

All in all, I am thrilled!

Can't thank you enough for sticking with me on this. I just hope it doesn't arbitrarily revert to Read-Only in the future.

Cheers to you SB...




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users



How to remove advertisement from MSFN