Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account


Photo

Help with Net Framework

- - - - -

  • Please log in to reply
11 replies to this topic

#1
kwheeler7

kwheeler7

    Newbie

  • Member
  • 12 posts
I have been using Nlite for a while and have not had any problems with it. I now am trying to add all the Net Framework add-ons to my slipstream but I keep coming up with Net errors when installing after slipstreaming.

I have been doing steps 1-4 with no problems. When I add the Net Framework as in step 5, I come up with the errors.
1. I extract my Windows XP Pro SP3 to a folder called Program
2. I use the Windows Media Player 11 slipstreamer to add WMP11 to the same dedicated folder.
3. Download the updates from http://xdot.tk/updates.html and put them in an folder called Updates
4. I add IE8-WindowsXP-x86-ENU.OnePiece add-on to the the same folder as number 3.
5. I add OnePiece_Microsoft.NET_Framework_v1.1.4322.2500_True_AddOn_ENU_7, OnePiece_Microsoft.NET_Framework_v3.5.30729.3678.4_True_AddOn_ENU and OnePiece_Microsoft.NET_Framework_v4.0.30319.298_True_AddOn_ENU_D907AD63A2E505D6B9A3F2201CA9EE79 to a folder called framework.
6. When slipstreaming I place the items in step 3, 4 & 5 in the hotfix section of Nlite.

I hope someone can help me with this. Thanks


How to remove advertisement from MSFN

#2
Kelsenellenelvian

Kelsenellenelvian

    WPI Guru

  • Developer
  • 8,791 posts
  • OS:Windows 7 x64
  • Country: Country Flag
Our crystal balls are at the shop.

We need the most basic of information to be able to help you AT ALL...

OS you ran nLite in while making your install disk
Was a av\malware running.
What were the EXACT .net errors.
Was your XP SP3 genuine and NOT modified at all?

#3
-X-

-X-

    Member

  • Patrons
  • 2,406 posts
  • OS:XP Pro x86
  • Country: Country Flag

Donator

Also, please attach your last session.ini.

Download all Windows XP Post SP3 High-Priority Updates with a simple double click @ xdot.tk post-12166-0-42859000-1399044129.png ]
               If someone helps you fix a problem, please report back so they and others can benefit from the solution. Thanks!


#4
kwheeler7

kwheeler7

    Newbie

  • Member
  • 12 posts
Sorry for not giving enough information. This is the information you requested.

OS you ran nLite in while making your install disk
I ran Nlite on my W7 x64 PC in VMware Workstation in a Windows XP Pro X86 virtual machine.

Was a av\malware running.
No av\malware was running.

Was your XP SP3 genuine and NOT modified at all?
It is a clean copy of Dell OEM Windows Xp pro SP3. It also happened doing the same thing with a clean copy of HP OEM Windows Xp pro SP3 I was setting up for another PC.

What were the EXACT .net errors.
The installation went perfectly until the final boot into Windows. These are the errors I got in the order they came up.

Error 1 Advanced Inf Install: Error creating process <c:\Program Files\Windows Media Player\WMPenc.exe/RegServer>. Reason the system cannot find the file specofied.

Error 2 rundll32.exe-Unable to locate component: This application has failed to start because Framedyn.dll was not found. reinstalling the application may fix the problem.

Error 3 RUNDLL: Error loading srclient.dll. The specified module could not be found.

Error 2 & 3 come up each time I start the PC.

Other things I noticed that were not correct.
1. I had disabled Tour but it still came up.
2. Internet explorer was not in the start menu or on the desktop. I got it running by going into "Set Program access and Defaults".
3. When I right clicked on the taskbar I could not enable the Quick Launch toolbar.
4. I tried to go into "Add and Remove Window Components to check if the Framework had installed and I could not access it. I got the following error message.
Windows XP Setup
Setup was unable to open file netfx40.inf. Contact your System Administrator. The specific error code is 0xe0000100 at line 0.

Last session.ini attached

Attached Files



#5
Kelsenellenelvian

Kelsenellenelvian

    WPI Guru

  • Developer
  • 8,791 posts
  • OS:Windows 7 x64
  • Country: Country Flag
Here are the main issues I see your having:

Explorer-Launch folder windows in a separate process <-- this tweak causes a semi-known exploitation to be opened you shouldn't use it.

WMP11 Cannot be added simply by throwing the hot fixes and installer in, it needs extra work. If you used WMP slippy you need to add the fixes in through it too.
(This may be the root cause of your issues as error 1 is directly due to this and error 2&3 are caused typically by a failed integration.)

It is much easier to find and fix errors when we have the most basic of needed information.

Edited by Kelsenellenelvian, 13 January 2013 - 03:07 PM.


#6
kwheeler7

kwheeler7

    Newbie

  • Member
  • 12 posts
OK. I will do it again tomorrow without checking "Launch folder windows in a separate process" .

I did use the WMP11 slipstreamer and added the updates through that before I even started Nlite but looking at the Last Session.ini it looks like they are in there also. I will double check it before trying again.

#7
-X-

-X-

    Member

  • Patrons
  • 2,406 posts
  • OS:XP Pro x86
  • Country: Country Flag

Donator

You need to remove the following. They are meant for WMP9.

C:\Ken\N-Lite Files\XP 2 Add-ins\3 Hotfixes\UDC-01.08.13\UDC-01.08.13\WindowsXP-WindowsMedia-KB952069-v2-x86-ENU.cab
C:\Ken\N-Lite Files\XP 2 Add-ins\3 Hotfixes\UDC-01.08.13\UDC-01.08.13\WindowsXP-WindowsMedia-KB954155-x86-ENU.cab
C:\Ken\N-Lite Files\XP 2 Add-ins\3 Hotfixes\UDC-01.08.13\UDC-01.08.13\WindowsXP-WindowsMedia-KB973540-x86-ENU.cab
C:\Ken\N-Lite Files\XP 2 Add-ins\3 Hotfixes\UDC-01.08.13\UDC-01.08.13\WindowsXP-WindowsMedia-KB975558-x86-ENU-fix.cab
C:\Ken\N-Lite Files\XP 2 Add-ins\3 Hotfixes\UDC-01.08.13\UDC-01.08.13\WindowsXP-WindowsMedia-KB978695-x86-ENU.cab
C:\Ken\N-Lite Files\XP 2 Add-ins\3 Hotfixes\UDC-01.08.13\UDC-01.08.13\WindowsXP-WindowsMedia-KB2378111-x86-ENU.cab


Instead you should use these(the original files minus one that isn't needed when slipstreaming 11) with WMP11Slipstreamer.

WindowsXP-WindowsMedia-KB954155-x86-ENU.exe
WindowsXP-WindowsMedia-KB973540-x86-ENU.exe
WindowsXP-WindowsMedia-KB975558-x86-ENU.exe
WindowsXP-WindowsMedia-KB978695-x86-ENU.exe
WindowsXP-WindowsMedia-KB2378111-x86-ENU.exe

Edited by -X-, 13 January 2013 - 11:37 PM.

Download all Windows XP Post SP3 High-Priority Updates with a simple double click @ xdot.tk post-12166-0-42859000-1399044129.png ]
               If someone helps you fix a problem, please report back so they and others can benefit from the solution. Thanks!


#8
-X-

-X-

    Member

  • Patrons
  • 2,406 posts
  • OS:XP Pro x86
  • Country: Country Flag

Donator

New release today for IE. Add it to your hotfix list.

http://technet.micro...lletin/ms13-008
http://www.microsoft...47-6bd4ecaa9b8a

Download all Windows XP Post SP3 High-Priority Updates with a simple double click @ xdot.tk post-12166-0-42859000-1399044129.png ]
               If someone helps you fix a problem, please report back so they and others can benefit from the solution. Thanks!


#9
kwheeler7

kwheeler7

    Newbie

  • Member
  • 12 posts
Thanks everybody for all the help. I worked on this all day yesterday and tried every combination to get this to work I could think of. I tried different 2 different OEM installations and even made my own with a clean VL copy and I could not get it to work. Today I re-downloaded the 3 net framework files and found when downloading they did not overwrite my original downloads which led me to believe my originals were corrupted. I did the install with the new packages and it went perfect. Thanks again for all your help.

#10
kwheeler7

kwheeler7

    Newbie

  • Member
  • 12 posts
I lost my link to the One Piece Net Framework downloads. Can you point me to it?

#11
-X-

-X-

    Member

  • Patrons
  • 2,406 posts
  • OS:XP Pro x86
  • Country: Country Flag

Donator

http://www.ryanvm.ne...opic.php?t=8316

Download all Windows XP Post SP3 High-Priority Updates with a simple double click @ xdot.tk post-12166-0-42859000-1399044129.png ]
               If someone helps you fix a problem, please report back so they and others can benefit from the solution. Thanks!


#12
kwheeler7

kwheeler7

    Newbie

  • Member
  • 12 posts
Thanks, I bookmarked it so I won't forget it again.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users



How to remove advertisement from MSFN