Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 



bigmuscle

Aero Glass for Win8 RC4

Recommended Posts

Yes in 1.3.1 I fixed that bug, but in 1.3, AGTweaker was writing to "UseNativeBlur " (with a space on the right) instead of "UseNativeBlur" (the correct registry key)

So the "UseNativeBlur " key is a leftover from 1.3 and can be safely deleted.

Share this post


Link to post
Share on other sites

ColorizationBlurBalanceInactive + ColorizationAfterglowBalanceInactive, both influence the level of the transparency.

Share this post


Link to post
Share on other sites

I have NVIDIA Geforce GTS 450 Card and I use Aero0.91(RC0).I found the screen turn black when I log on.Only the mouse cursor displayed on the screen.Then I set DeviceFeatureLevel to 0x9300 and set UseNativeBlur to 1 in Windows Safe Mode.Then Windows and aero glass works great ! Internet Explorer also works fine(No full transparency bug in Native Blur Mode ! )Can't wait for the final version ! Thank you , bigmuscle!

Share this post


Link to post
Share on other sites

There must be something else, because there is no native blur mode in RC0 (UseNativeBlur setting is completely ignored).

Share this post


Link to post
Share on other sites

ColorizationBlurBalanceInactive + ColorizationAfterglowBalanceInactive, both influence the level of the transparency.

I tried those but ColorizationColorBalanceInactive is the only key that allowed me adjust the inactive frame so that the black captions are readable...

Is there a way to get a white blurry outline around the window caption only? Or is that part of the theme?

Share this post


Link to post
Share on other sites

shell32.dll version is 6.2.9200.16547

I tried different DeviceFeatureLevel setting, anything higher than or equal to DX10 will result in black screen.

Share this post


Link to post
Share on other sites

ColorizationBlurBalanceInactive + ColorizationAfterglowBalanceInactive, both influence the level of the transparency.

I tried those but ColorizationColorBalanceInactive is the only key that allowed me adjust the inactive frame so that the black captions are readable...

Is there a way to get a white blurry outline around the window caption only? Or is that part of the theme?

ColorizationAfterglowBalanceInactive influences it too (but minimally) but you should ensure that the sum of both won't be higher than 100 else it can result in weird things. Caption glow effect is a theme thing.

shell32.dll version is 6.2.9200.16547

I tried different DeviceFeatureLevel setting, anything higher than or equal to DX10 will result in black screen.

DeviceFeatureLevel depends on your graphic card. If your graphic card does not support selected feature level, you will end up with the black screen. If you set DeviceFeatureLevel lower than default, you just switch your graphic card to backward-compatibility mode which can result in unexpected behavior (someone reported here that Metro application does not have to work correctly), degraded performance and other things. The final version will not have this setting at all, so I would like to fix all related issues as soon as possible.

Share this post


Link to post
Share on other sites

shell32.dll 6.2.9200.16547

GPU GTX670M DirectX 11 Shader 5.0

I tried to reproduce the bugs, here are the debug files.

First time applied => glass only on window borders => restarted manually => clicked the user picture to log => black screen => forced restart and returned to desktop holding ctrl key

Second time applied => instantly black screen => forced restart and returned to desktop holding ctrl key

Third time applied, glass only on window borders => black screen after 4 or 5 seconds => forced restart and returned to desktop holding ctrl key

first_time_applied.txt

second_time_applied.txt

third_time_applied.txt

Edited by Tusticles

Share this post


Link to post
Share on other sites

no crashlog.txt generated? What happens when you hold ctrl during black screen (so you don't force restart), does it work or not?

Share this post


Link to post
Share on other sites

no crashlog.txt generated? What happens when you hold ctrl during black screen (so you don't force restart), does it work or not?

Wow, I held down the button for 40 seconds or so and nothing happened then I started to tap the key and returned to desktop miraculously.

This time a crash log was created.

fourth_time_applied.txt

crash_fourth_time_applied.txt

Share this post


Link to post
Share on other sites

Ok, if the crashlog is the reason than it could help. I know how to reproduce it. However, it is weird that it happens on startup :-/

Share this post


Link to post
Share on other sites

Ok, if the crashlog is the reason than it could help. I know how to reproduce it. However, it is weird that it happens on startup :-/

Tried again and got black screen instantly after applying, this time ctrl key didn't worked.

forced restart and returned to desktop holding ctrl key

fifth_time_applied.txt

Share this post


Link to post
Share on other sites

Here is the temporary fix for a crash http://leteckaposta.cz/670122308

Could you test it so we can confirm whether it is cause of the black screen?

Transparency applied only on windows borders, no blur on taskbar and startmenu, then I restarted explorer and again, black screen.

forced restarted and returned to desktop holding ctrl key

crashfix_debug.txt

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

×