Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 



bigmuscle

Aero Glass for Win8 RC4

Recommended Posts

do you use startisback or something like that?

Share this post


Link to post
Share on other sites

do you use startisback or something like that?

Yes, but I don't see why would that be a problem, 0.9 worked fine.

Btw I tried again and the crashfix you uploaded does the same thing, black screen when is applied, sometimes the black screen occurs after a few seconds, sometimes it stays active and I have time to restart explorer, after restarting explorer again our friend, the black screen.

here is another log...

crashfix_debug2.txt

Edited by Tusticles

Share this post


Link to post
Share on other sites

Did 0.9 really work or you just had native blur enabled ?

Share this post


Link to post
Share on other sites

Did 0.9 really work or you just had native blur enabled ?

Yes, it worked/is working, no native blur enabled, I don't even have the key in registry.

Edited by Tusticles

Share this post


Link to post
Share on other sites

Did more test. Here is the debug log. my GPU is GTX580,

1). Auto DeviceFeatureLevel, hold CTRL key to boot, taskbar blur is missing in this case, other thing is working normally.

debug-hold_ctrl.txt

2). Right after 1), Drag a windows and make it touch the low part of the taskbar. Black screen appear.

debug-hold_ctrl+drag.txt

3) Boot without holding Ctrl key, auto DeviceFeature level

debug-No_ctrl.txt

Note: Logs for 1 and 3 are capture after deleting the old log. log 2 is captured directly after log 1.

Edited by lolchampion

Share this post


Link to post
Share on other sites

What happens when you add registry settings HKCU\Software\Microsoft\Windows\DWM: callBlurShapes (DWORD set to 0x1) ?

Share this post


Link to post
Share on other sites

What happens when you add registry settings HKCU\Software\Microsoft\Windows\DWM: callBlurShapes (DWORD set to 0x1) ?

with rc0 or rc0 crashfix?

Share this post


Link to post
Share on other sites

It makes no difference. "crashfix" just fixes crash from your crashlog.txt.

Share this post


Link to post
Share on other sites

It makes no difference. "crashfix" just fixes crash from your crashlog.txt.

Yes, tried this registry setting with rc0 crashfix and it worked, auto device future level, blur was not applied on taskbar and startmenu but restarting explorer will fix it, no crash when restarting explorer :)

debug_crashfix_callBlurShapes.txt

Edited by Tusticles

Share this post


Link to post
Share on other sites

It makes no difference. "crashfix" just fixes crash from your crashlog.txt.

Yes, tried this registry setting with rc0 crashfix and it worked, auto device future level, blur was not applied on taskbar and startmenu but restarting explorer will fix it, no crash when restarting explorer :)

Same result here. Add the registry setting and reboot. Everything is working now with auto DeviceFeatureLevel, taskbar have its blur back too.

Edited by lolchampion

Share this post


Link to post
Share on other sites

Fine, now I have to find the real reason of the black screen. I will create debug version which makes more detailed log as this settings will go away in next version.

Share this post


Link to post
Share on other sites

Ok, tried rc0 with callBlurShapes, black screen after applying then held ctrl button for a long time and it returned to desktop, ah, and glass was still active.

see debug_rc0_callBlurShapes.txt

--edit--

tried again rc0, this time when pressed the apply button in AGTweaker it worked then pressed apply button again and black screen occured.

see debug_rc0_callBlurShapes2.txt

--edit--

Man, I have no idea what have you done but 0.9 is optimized, Is smooth on all p-states :D :D :D, let's hope it stays like this.

debug_rc0_callBlurShapes.txt

debug_rc0_callBlurShapes2.txt

Edited by Tusticles

Share this post


Link to post
Share on other sites

Ok, so please, use default settings (no additional key in registry, no specific device feature level) and install this version

http://leteckaposta.cz/723577425

When blackscreen appears, hold F11 for approx. one second and it starts generating file threads.log. It can take a while, because it will download public debug symbols from Microsoft servers (which are several MBs). Then it will automatically kill the process (which will result in dwm.exe restart, so it will be probably stuck with another black screen, so hold CTRL after pressing F11. I hope this will work and it will help to fix the problem :-)

And of course, then send me threads.log file.

Share this post


Link to post
Share on other sites

Ok, so please, use default settings (no additional key in registry, no specific device feature level) and install this version

http://leteckaposta.cz/723577425

When blackscreen appears, hold F11 for approx. one second and it starts generating file threads.log. It can take a while, because it will download public debug symbols from Microsoft servers (which are several MBs). Then it will automatically kill the process (which will result in dwm.exe restart, so it will be probably stuck with another black screen, so hold CTRL after pressing F11. I hope this will work and it will help to fix the problem :-)

And of course, then send me threads.log file.

Done. Here is the log.

threads.txt

debug.txt

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

×