Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 



bigmuscle

Aero Glass for Win8 RC4

Recommended Posts

bitaljus    0

when i read your comp conf. i realized that it maybe a nvidia driver bug. what driver version are you running. i am with latest nvidia beta drivers 320.00 on my NVIDIA Geforce GTX 460 SE

Share this post


Link to post
Share on other sites

@ Tusticles

does the ASUS G75VW support Optimus? If yes, force DWM.exe to run with the Intel HD GPU (included in the CPU). I also do this for my Dell Laptop with Intel HD 4000 and Radeon HD 7700M.

Share this post


Link to post
Share on other sites
Tusticles    21

when i read your comp conf. i realized that it maybe a nvidia driver bug. what driver version are you running. i am with latest nvidia beta drivers 320.00 on my NVIDIA Geforce GTX 460 SE

Tried with all versions, 314.22, 320.00, no changes...

@ Tusticles

does the ASUS G75VW support Optimus? If yes, force DWM.exe to run with the Intel HD GPU (included in the CPU). I also do this for my Dell Laptop with Intel HD 4000 and Radeon HD 7700M.

No, this model doesn't support Optimus.

Edited by Tusticles

Share this post


Link to post
Share on other sites
bitaljus    0

i tried with switching to my CPU's GPU Intel Core i3-2100(HD Graphics 2000), removed the nvidia drivers and installed the intel driver from windows update and no more black screens(no on login, no on window drag over the taskbar).

Edited by bitaljus

Share this post


Link to post
Share on other sites
Rayn19    0

The RC0 is much more stable than the BETA3 on my Intel HD 3000, the performance is much better.

No artifacts seen till now and no crash log.

I tried to run it on nVidia 9500GT but it fails to load properly on startup. When I log in, I am greeted with a black screen with only my mouse pointer.

When I tried holding CTRL while logging in, the AERO Glass is still loaded to explorer, but the taskbar remains unaffected.

I even tried the crashfix for v0.91, still have the same problem.

I have also checked the uDWM.dll versions on both systems, both have 6.2.9200.16420 in system32 folder.

I have attached both systems debug.log and/or crash.log, the system with nVidia card has dual monitors btw.

Intel HD 3000: debug.log (no crash log)

nVidia 9500GT: debug.log | crash.log

nVidia 9500GT(w/ crashfix): debug.log (no crash log)

Looking at the posts by Tusticles, the problem is related to nVidia cards. It runs well under intel HD (integrated graphics).

Share this post


Link to post
Share on other sites
DosProbie    97

I imagine BM is going to have to list compatiable video cards at some point or with final release, So maybe we should all List what cards we are using when posting issues for now on.. I am also very curious if Nvidia is definitely a problem card then has anyone also had a problem with aero glass using a AMD Radeon card?huh.gif

Edited by DosProbie

Share this post


Link to post
Share on other sites
bigmuscle    530

Yes, this seems to be related with nVidia driver, because (according to minidumps and crashlogs), the dwm process is stuck in nvwgf2umx.dll file waiting for something. I just don't understand what the problem is because it does not touch my code at all (and neither one of running threads does).

Share this post


Link to post
Share on other sites

The Game PanzerCorps exits very often, so I activated silent exit monitoring (new feature since Win7) and found that C:\Windows\System32\svchost.exe killed the game with error code -805306369 which means CDERR_DIALOGFAILURE.

Can this be causes by the popup of your Dll? I can't image that a service tries to display a dialog.

Share this post


Link to post
Share on other sites
bigmuscle    530

The message box is created with the flag MB_SERVICE_NOTIFICATION but I don't see reason why message box should kill some process.

Share this post


Link to post
Share on other sites
bigmuscle    530

So try this: http://leteckaposta.cz/302887755

When you press F11, it will generate approx. 170 MB file minidump.dmp. Send it to me.

After you generate minidump. create registry value HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\DWM: NoInternalHooks (DWORD 0x1) and try what happens.

Done.

Applied, black screen, pressed f11, I waited several minutes then I did a force restart and returned to desktop holding ctrl key

Then added that key with this value 0x00000001, re-applied dwmglass, no black screen but transparency was not applied,

Ok, if you can 100% confirm that setting NoInternalHooks to 0x1 does not bring black screen (and it was not just random) then it is time to try this version http://leteckaposta.cz/111719826

It adds this registry settings: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\DWM: HookFlag (DWORD) which can control what NoInternalHooks disabled completely. Valid values are 1, 2, 4, 8 + their combinations (summations = anything between 1..15), maximum value = 1+2+4+8 = 15 (0xF) which enables everything, 0 disables almost everything (like NoInternalHooks did). I hope this helps me to find which function is the problem.

Share this post


Link to post
Share on other sites
bigmuscle    530

So if you put the value correctly (as decimal and not hexa) and value 10 (0xa) makes everything work correctly (transparency with blur but with glitches) then it seems there is some incompatibility between nVidia driver and glass safety zones (which is a new thing added to RC0 to get rid of artifacts but it is DWM native code completely) and I'm afraid that I won't be able to do anything about this except of adding the registry settings to switch to old technique (extend glass zone on my own but with occasional glitches). Could you just post debug.log from this latest build?

edit: from minidump, I found DWM fails with MILERR_NO_HARDWARE_DEVICE error.

Edited by bigmuscle

Share this post


Link to post
Share on other sites
Tusticles    21

Yes, this seems to be related with nVidia driver, because (according to minidumps and crashlogs), the dwm process is stuck in nvwgf2umx.dll file waiting for something. I just don't understand what the problem is because it does not touch my code at all (and neither one of running threads does).

Did you downloaded the minidump I posted? It shows me 0 downloads.

Share this post


Link to post
Share on other sites

the errorcode I see is triggered if a wrong handle is used:

http://msdn.microsoft.com/en-us/library/windows/desktop/ms646916%28v=vs.85%29.aspx

I waited for the messagebox to pop up, didn't click it, but moved it to the side of the monitor and played the game now without any issues. I hope we can buy the final soon, to "fix" this :)

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

×