bigmuscle

Aero Glass for Win8 RC4

2,631 posts in this topic

Oh after reading more about the 90% colour intensity issue, I tried setting the D3D on and setting the colour intensity to about 90%. It has part of the window border not only non transparent. But I can see that D3D mode indeed works at some level. I guess needs a bit of tweaking but yes works partly.

Edit: Maybe I should mention that I have an EVGA branded nVidia GTX 570. It could be relevant. Its a fully DX11 device.

post-374132-0-57629400-1362011160_thumb.

Edited by drakenabarion
0

Share this post


Link to post
Share on other sites

Changing the DeviceFeatureLevel to 9300 does enable Glass on version 0.4, but Direct3D mode is very glichy. Notice on the supplied screenshots that blur only occurs on part of the window. Direct2D mode works fine though.

post-373381-0-28891600-1362011801_thumb.

Edited by WindowsOS
0

Share this post


Link to post
Share on other sites

Oh after reading more about the 90% colour intensity issue, I tried setting the D3D on and setting the colour intensity to about 90%. It has part of the window border not only non transparent.

Is that partial effect only there immediately after running the app - i.e. already open windows are transparent where they were overlapped by another window but opaque on the rest of the border - and does the entire border become properly transparent after you drag another window over it or minimise then re-open it - and if you open a new window, is that correctly transparent?

If so, it's always done that for me and the author is aware of it. I'm guessing it's just a simple thing to sort once the author gets the main functions sorted - probably just needs a forced redraw of the screen or windows (plus, of course, if it's eventually run at start-up, that shouldn't even be a problem)

0

Share this post


Link to post
Share on other sites

I downloaded the newest preview but I don't get the registry edit for setting the DeviceFeatureLevel to 9100. Any Help?

0

Share this post


Link to post
Share on other sites

Yes it works but there is considerable amount of lag when minimizing windows.

In 0.4 or in that private build?

In all versions dude, all versions have lag, I don't care if you fix it or not, but just give me an explanation. I told you, to fix the lag I have to make the GPU gaming profile fixed, but who want 50+C GPU temp in idle/desktop mode... This tells me that your pretty app is hunger for GPU resources, I understand, debug version, alpha, etc. but I still want some answers. Thank you.

Sounds more like your drivers aren't properly adjusting power states for the workload. Even if his implementation required 10x the resources and workload of MS's it should not produce a noticeable effect with a GTX 670 - it should be more than powerful enough to run dozens of fullscreen sheets of solid glass on top of each other without a hiccup. The problem is very likely on your end (drivers or profiles you made) since very few others seem to have the issue on what I would imagine to be less powerful hardware, unless everyone in this thread has a GTX680. I had no problem running his glass implementation from 0.3 on my 6950 and it showed almost no GPU utilization and near idle temperatures. And your GTX 670 should be faster than my 6950.

0

Share this post


Link to post
Share on other sites

Nope - tried every variation I can and still no colour for inactive borders in D3D. I'm probably doing something really silly and obviously wrong but I can't spot it - DOH!

Can anyone else confirm that they got inactive borders coloured under D3D?

What did you do exactly? Do you have any custom theme installed? I have not found any usable way to identify each window (including its current state), so inactive windows are identified by its colour which seems to be hardcoded to RGB 235,235,235. This colour is replaced with that one which you specify in HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\DWM:ColorizationColorInactive as e.g. 0xffff0000 (for red colour) It should work even in Direct2D mode. However remember, that in Direct3D mode, this colour is modified by ColorizationColorBalanceInactive settings.

0

Share this post


Link to post
Share on other sites

No custom themes or patches - no patches or hacks of any sort anywhere on the 'puter.

I get the inactive colouring when UseDirect2DRendering is set to 1 (works perfectly and looks good) - but they remain grey when UD2DR is set to 0. (In case it's relevent - I have to set DFL at 9100 to get it working - and I'm using this on a laptop with integrated Intel 4500HD graphics - Direct X 11 - DxDiag Version: 6.02.9200.16384)

I'm thinking I've completely misunderstood something so can you perhaps show a screen grab of your DWM registry entries for both .user and currentuser - so I can compare or duplicate them?

0

Share this post


Link to post
Share on other sites

It is probably because, in D3D mode, you need to set also ColorizationColorBalanceInactive and other settings (as Blur/Balance and AfterGlow/Balance). If you don't set color balance, it uses default value of 12%, thus resulting used color will be ColorizationColorInactive * 0.12. Plus when GlassTransparency > 0 then it will be overlaid by the color ARGB (GlassTransparency, 235, 235, 235).

Maybe I could state that I know that current setting options are not optimal. GlassTransparency shouldn't be available in D3D mode at all. All current default values comes from Win8 Release Preview which uses a bit different texture for drawing window border - Win8 RTM draws only a thin line, the rest is fully transparent (alpha is zero), Win8 RP draws a thin line plus a bit of a color with alpha of 14 for actives and 77 for inactives (if I remember the values correctly).

Edited by bigmuscle
0

Share this post


Link to post
Share on other sites

So what's the right/best thing for us to do if we want to help test this?

0

Share this post


Link to post
Share on other sites

Oh after reading more about the 90% colour intensity issue, I tried setting the D3D on and setting the colour intensity to about 90%. It has part of the window border not only non transparent.

Is that partial effect only there immediately after running the app - i.e. already open windows are transparent where they were overlapped by another window but opaque on the rest of the border - and does the entire border become properly transparent after you drag another window over it or minimise then re-open it - and if you open a new window, is that correctly transparent?

If so, it's always done that for me and the author is aware of it. I'm guessing it's just a simple thing to sort once the author gets the main functions sorted - probably just needs a forced redraw of the screen or windows (plus, of course, if it's eventually run at start-up, that shouldn't even be a problem)

No, its all new windows for me. Even if I close all windows and open a new one that has no window behind it. The Opaque section is also like a percentage of the window and resizes as the window is resized. But I am sure with all the feedback, I'm sure it wont be long befoer things are tweaked. :)

0

Share this post


Link to post
Share on other sites

pengipete: I must admit that I have not figure out the best settings yet. Normally, it is true that BlurBalance + ColorBalance + AfterGlowBalance = 100. But as I recognized in Win8 RP, this is not valid for inactive borders where it is > 100 which is weird.

drakenabarion: does it happen for all windows or just when the window is near the screen edge? What is your screen resolution? Do you have one or more displays?

0

Share this post


Link to post
Share on other sites

pengipete: I must admit that I have not figure out the best settings yet. Normally, it is true that BlurBalance + ColorBalance + AfterGlowBalance = 100. But as I recognized in Win8 RP, this is not valid for inactive borders where it is > 100 which is weird.

drakenabarion: does it happen for all windows or just when the window is near the screen edge? What is your screen resolution? Do you have one or more displays?

I have 2 x 1920x1080 displays.

I think I was wrong about the opaque part being a percent of the window. It varies in size depending on the size of the window. With the command prompt, if I move the window left or right on either screen, the amount of opaque is none on the right hand side of the screen and the more I move the window to the left from about 40% of the screen the opaque part moved across the window from left to right of the window. However, with a windows explorer window more than twice the size of the command prompt window, the opaque section is much larger. I think I will probably need to capture that on a video somehow, because its difficult to explain. Or maybe just a series of screenshots. (Give me a few minutes :) )

Edit: Here is a Dropbox link to some screenshots. It shows Regedit and the last two screenshots show when it moves from one monitor to the other..

https://www.dropbox.com/sh/9kms3l9ehz425ce/pxOSvbWVvG

Edited by drakenabarion
0

Share this post


Link to post
Share on other sites

I think that multiple displays can be the cause. Is it somehow possible that you test it with one monitor only?

0

Share this post


Link to post
Share on other sites

I think that multiple displays can be the cause. Is it somehow possible that you test it with one monitor only?

I will try it out in a little bit. This second I am about to begin my monthly internal dusting. Spray cans ready! :D

(I'll edit this post once I got to try it out in a bit).

Edit: Yes, works fine on a single display. Transparency is linked to colour intensity in that case.

I think that multiple displays can be the cause. Is it somehow possible that you test it with one monitor only?

Direct3D mode does work on single monitor only.

Well, in many ways, Transparency works in multi monitor. Just not correctly.

(Oh you gotta love edit posts for chronology maintenance. This might look like time travel :P)

Edited by drakenabarion
0

Share this post


Link to post
Share on other sites

I think that multiple displays can be the cause. Is it somehow possible that you test it with one monitor only?

Direct3D mode does work on single monitor only.

0

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.