bigmuscle

Aero Glass for Win8 RC4

2,631 posts in this topic

BigMuscle...

I think you are missing the point entirely.

You are asking people to BETA TEST your app - so you NEED them to mess around and see if there's anything they can do that will break it. If they are all running it with your default settings, they are not beta testing - they're just using it. The point is that your app is reading and using values which may or may not exist in the registry and if they don't exist, it runs at your "safe defaults". If those "safe defaults" are all you ever plan on using, there is no further need for beta testing - but if you are still trying to work out what works best or looking to develop futher, you need people to fiddle about. You have specified that those registry values exist and have even ASKED people to test them on more than one occasion - so I'm just trying to tell you that it's not possible to correctly beta-test an application when you can't test all of the possible variations and settings.

A prime example - the black screen that many people are reporting is usually avoided by using 9100 - but unless you have people willing to try the other values, you'll never know WHY that is causing what appears to be a more-or-less random and unpredictable problem. If you are leaving that at 9100, you should remove the setting from the registry rather than now saying that no-one should change it.

If changing a registry value that your app uses causes or highlights a problem, that's not a failure on the part of the beta-tester. Unless they are sticking in values that the operating system can't even handle, then the application needs to be able to deal with them. It may be okay for now to say something like "x is never more than 200" - but all it takes if for some external app or even Microsoft to make a small change and that value may suddenly be set to 201.

If all you want is for people to run your app and tell you that it doesn't simply crash when run, you shouldn't be listing the registry values it uses. If you list them - and even ask people to try changing them - you shouldn't be critical of those who try to help by testing every value and setting. It's also a bit unfair to assume that just because someone is not 100% clear on how a handful of regsistry values interact with your application (or DWM in general) that they are totally ignorant and shouldn't touch the registry.

0

Share this post


Link to post
Share on other sites

Sorry, but you are probably in the wrong thread. This small piece of software never entered in betatesting state, it neither entered in the alphatesting stage. That's why I always highlight that each version is experimental preview only. It's purpose is not to test anything, it's purpose is not to hunt for bugs etc. and I have never said that (the only testing request was about GlassTransparency and BlurDeviation settings, not others!). The only purpose of this version was to show "hey, blur effect is possible and it may look like this!" and to show which direction it will take, and that's why the preview dialog will stay there. The registry setting is there only for a) HKCU for preview only - to show possible future features, B) HKLM if anyone experiences some serious problems... and yes, you are right, there is absolutely no reason to have any registry settings because believe it or not, the hardcoded values work really at its best (just because they are not hardcoded by me, but by DWM itself).

Also, the black screen problem has nothing to do with DeviceFeatureLevel, it is totally different problem. It is just limitation of the loader which is not possible to fix it (without "hardcoding" my library into system) and I already explained it.

I am not critical about changing registry settings. I am just critical that you change registry using some 3rd party application (which changes totally different keys) and then complain that my utility has a bug because it does not create key XYZ and thus the settings does not work.

DosProbie: as I have already said, the registry settings are not highlighted in the first topic just because it is temporary thing only. Settings such as DeviceFeatureLevel will be removed when I successfully fix the issue and it will use native level (i.e. 9100 for D3D 9.1 video card, a000 for D3D 10.0 video card, b000 for D3D 11.0 videocard etc.). It is only my good will that I added the settings to enable preview on unsupported videocards. Just a small example, there is tons of registry settings in Windows itself, keys nor values do not exist in the registry by default and you don't find any list of them - just because you are not intended to change them. There is also hidden MinFeatureLevel and MaxFeatureLevel directly in Direct3D library ;-)

0

Share this post


Link to post
Share on other sites

I'm not sure if what I'm saying even matters, but if a person has a DX11 video card then it should work with DX11 registry setting. DX11 setting works the best on my system, and my system acts like the transparency was there from MS. I have no bugs or any other problems that I have seen as of yet.

0

Share this post


Link to post
Share on other sites

I didn't "complaint that your program has a bug" - I reported something that wasn't working correctly on my pc and explained that I had found the reason for it.

The reason I mentioned AGTweaker is that a number of people reading this thread are likely to be using it and and if they are having problems with Aero Glass, it seemed sensible to tell them that the latest versions of both applications are not quite working in synch - so if someone tells you that "it's working perfectly at 9300 on my XYZ graphics card, that might not be true because they are actually running the default 9100 setting. That was nothing to do with "complaining" - it was to try to warn you that there could be bugs or problems you will never find because a lot of people are running at default settings without realising it - such as the 9100 value - and you've said several times that you'll be changing those in the final version. That makes it possible that people will be telling you that it works with such and such settings when, in reality, they are using totally different ones from what they think they are using.

I was just trying to help - reporting something that could result in you getting inaccurate feedback and maybe trusting something that has never actually been tested.

0

Share this post


Link to post
Share on other sites

It looks like device failed to be created in some cases. Could you try playing with DeviceFeatureLevel? Maybe, your card does not accept level 0x9100 correctly.

I changed the value of DeviceFeatureLevel to all of these (0x9200, 0x9300, 0xa000, 0xa100) and it didn't change anything.

Can you confirm the location of the entry? it was in HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\DWM

By the way, version 0.3 works nicely for that computer and without that entry in the registry

My graphic card is an ATI Radeon HD 4850

Here's another debug file with the test I did.

Thanks

debug.txt

Edited by puerto
0

Share this post


Link to post
Share on other sites

Didn't work here. flashes black then goes back to the desktop with no aero.....is there anyway to uninstall this or roll back whatever it changes???? thank you for the hard work and I look forward to trying version 0.6 when it's released. thanks you

0

Share this post


Link to post
Share on other sites

i hope there is a 32-bit release for the next version :yes:

0

Share this post


Link to post
Share on other sites

I changed the value of DeviceFeatureLevel to all of these (0x9200, 0x9300, 0xa000, 0xa100) and it didn't change anything.

Can you confirm the location of the entry? it was in HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\DWM

Nope, the low-level settings is under HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\DWM

Didn't work here. flashes black then goes back to the desktop with no aero.....is there anyway to uninstall this or roll back whatever it changes???? thank you for the hard work and I look forward to trying version 0.6 when it's released. thanks you

This application does not change anything so there is nothing to uninstall.

i hope there is a 32-bit release for the next version :yes:

I will provide it as soon as possible, however I can't ensure that it will work (just because I have x64 systems only).

0

Share this post


Link to post
Share on other sites

I changed the value of DeviceFeatureLevel to all of these (0x9200, 0x9300, 0xa000, 0xa100) and it didn't change anything.

Can you confirm the location of the entry? it was in HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\DWM

Nope, the low-level settings is under HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\DWM

Didn't work here. flashes black then goes back to the desktop with no aero.....is there anyway to uninstall this or roll back whatever it changes???? thank you for the hard work and I look forward to trying version 0.6 when it's released. thanks you

This application does not change anything so there is nothing to uninstall.

i hope there is a 32-bit release for the next version :yes:

I will provide it as soon as possible, however I can't ensure that it will work (just because I have x64 systems only).

Use Virtual Machine For 32-Bit :)

0

Share this post


Link to post
Share on other sites

I changed the value of DeviceFeatureLevel to all of these (0x9200, 0x9300, 0xa000, 0xa100) and it didn't change anything.

Can you confirm the location of the entry? it was in HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\DWM

Nope, the low-level settings is under HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\DWM

Didn't work here. flashes black then goes back to the desktop with no aero.....is there anyway to uninstall this or roll back whatever it changes???? thank you for the hard work and I look forward to trying version 0.6 when it's released. thanks you

This application does not change anything so there is nothing to uninstall.

i hope there is a 32-bit release for the next version :yes:

I will provide it as soon as possible, however I can't ensure that it will work (just because I have x64 systems only).

Use Virtual Machine For 32-Bit :)

What do you mean by use virtual machine for 32-bit?

0

Share this post


Link to post
Share on other sites

I changed the value of DeviceFeatureLevel to all of these (0x9200, 0x9300, 0xa000, 0xa100) and it didn't change anything.

Can you confirm the location of the entry? it was in HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\DWM

Nope, the low-level settings is under HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\DWM

I added the key where you mentioned and it worked with values 0xa000 and 0xa100.

I thought it was HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\DWM because version 0.3's settings for GlassTransparency and BlurDeviation were at that location.

Thank you very much for your help and for bringing back transparency and blur to my computer :thumbup

Let me know if my debug file could be of help..

0

Share this post


Link to post
Share on other sites

I changed the value of DeviceFeatureLevel to all of these (0x9200, 0x9300, 0xa000, 0xa100) and it didn't change anything.

Can you confirm the location of the entry? it was in HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\DWM

Nope, the low-level settings is under HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\DWM

Didn't work here. flashes black then goes back to the desktop with no aero.....is there anyway to uninstall this or roll back whatever it changes???? thank you for the hard work and I look forward to trying version 0.6 when it's released. thanks you

This application does not change anything so there is nothing to uninstall.

i hope there is a 32-bit release for the next version :yes:

I will provide it as soon as possible, however I can't ensure that it will work (just because I have x64 systems only).

Use Virtual Machine For 32-Bit :)

What do you mean by use virtual machine for 32-bit?

Develop using Virtual Machine for Windows 32-bit

0

Share this post


Link to post
Share on other sites

The link isn't working right now and I've tried on and off over the past half hour: http://prdownload.berlios.de/glass8/DWMHook05.7z

Chrome just says:

This web page is not available

Google Chrome could not load the web page because prdownload.berlios.de took too long to respond. The website may be down

Could you provide another link please? Perhaps DropBox / GoogleDrive would be more reliable, or good as a mirror.

Thanks! Your project sounds awesome.

PS - is it possible to get back the rounded window corners in Windows 8?

0

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.