• Announcements

    • xper

      MSFN Sponsorship and AdBlockers!   07/10/2016

      Dear members, MSFN is made available via subscriptions, donations and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, become a site sponsor and ads will be disabled automatically and by subscribing you get other sponsor benefits.
bigmuscle

Aero Glass for Win8 RC4

2,631 posts in this topic

After update to RC0, i got a black screen after enter desktop after boot.

Sometime I am lucky enough to enter desktop(By holding CTRL while switch from metro to desktop), The glass in windows border are working correctly, but the blur in task bar is gone. If i drag a windows and make taskbar overlay with it, a black screen appear.

Do you have 32-bit version? If yes, then it is possible because several versions of 32-bit system DLLs contains different optimizations which can totally break everything. If this is true, please send me your shell32.dll (via PM) + there should be crashlog.txt in the same folder as you extracted dwmglass.dll.

I am using 64-bit version. After i managed to boot back into desktop, I cannot found crashlog.txt, only debug.log exist.

Applied RC0 and it worked, then deleted all files and re-applied RC0 and I have a black screen...

dwmcore.dll 6.2.9200.16433

There is something wrong with device future level, I have this setting to Auto but there is a problem with dx11 and dx11.1, with dx11 it's working but a after a while the screen turns black, dx11.1 will make the screen black instantly after applying, crash log is empty.

--edit--

Tried again, now the glass was applied with auto device feature level but taskbar and startisback have no blur so I tried to restart explorer, in the previous versions this fixed the issue but after restarting explorer, surprise, black screen, then re-applied dwmglass after a force restart , but the screen turned black again after a few minutes... This is happening with any directx, from 9 to 11. Version 0.9 is working fine, no black screen. blur is applied correctly to start menu and taskbar.

I have the same problem. At least you responded to this guy...

Edited by Tusticles
0

Share this post


Link to post
Share on other sites

Newest version still doesn't seem to be changing inactive colors, no matter which color I select the inactive frames are light blue. The transparency is also unchanging for the inactive window no matter the color intensity, which makes reading the window captions impossible if the inactive window is over a dark background...

Example: click

Because your have invalid colorization settings for inactive frames. Just post a screenshot of your registry key HKCU\Software\Microsoft\Windows\DWM and we will see where the problem is ;-)

Here is is: click

One thing I see there is the duplicate UseNativeBlur entry (removed the one with 0x1)

What will happen if I delete the ColorizationColorInactive entry?

Of course, that's it. You have set your inactive color to RGB(99, 150, 191) which is some shade of blue. I don't even know why you have double UseNativeBlur, this has no sense.

Edited by bigmuscle
0

Share this post


Link to post
Share on other sites

So, to anyone having problem to open desktop with 64-bit build, what is your version of shell32.dll ? Also post your debug.log (better, delete the file first and then restart your PC to have clean log)

0

Share this post


Link to post
Share on other sites

A friend of mine has no blur on the taskbar? Can someone help?

Edited by fireboyche
0

Share this post


Link to post
Share on other sites

Newest version still doesn't seem to be changing inactive colors, no matter which color I select the inactive frames are light blue. The transparency is also unchanging for the inactive window no matter the color intensity, which makes reading the window captions impossible if the inactive window is over a dark background...

Example: click

Because your have invalid colorization settings for inactive frames. Just post a screenshot of your registry key HKCU\Software\Microsoft\Windows\DWM and we will see where the problem is ;-)

Here is is: click

One thing I see there is the duplicate UseNativeBlur entry (removed the one with 0x1)

What will happen if I delete the ColorizationColorInactive entry?

Of course, that's it. You have set your inactive color to RGB(99, 150, 191) which is some shade of blue. I don't even know why you have double UseNativeBlur, this has no sense.

AGT might be to blame for that, I didn't edit the registry until now ^^

Is there a way to adjust the inactive frame transparency as well? I'd like to make them less transparent.

0

Share this post


Link to post
Share on other sites

Yes in 1.3.1 I fixed that bug, but in 1.3, AGTweaker was writing to "UseNativeBlur " (with a space on the right) instead of "UseNativeBlur" (the correct registry key)

So the "UseNativeBlur " key is a leftover from 1.3 and can be safely deleted.

0

Share this post


Link to post
Share on other sites

ColorizationBlurBalanceInactive + ColorizationAfterglowBalanceInactive, both influence the level of the transparency.

0

Share this post


Link to post
Share on other sites

I have NVIDIA Geforce GTS 450 Card and I use Aero0.91(RC0).I found the screen turn black when I log on.Only the mouse cursor displayed on the screen.Then I set DeviceFeatureLevel to 0x9300 and set UseNativeBlur to 1 in Windows Safe Mode.Then Windows and aero glass works great ! Internet Explorer also works fine(No full transparency bug in Native Blur Mode ! )Can't wait for the final version ! Thank you , bigmuscle!

0

Share this post


Link to post
Share on other sites

There must be something else, because there is no native blur mode in RC0 (UseNativeBlur setting is completely ignored).

0

Share this post


Link to post
Share on other sites

ColorizationBlurBalanceInactive + ColorizationAfterglowBalanceInactive, both influence the level of the transparency.

I tried those but ColorizationColorBalanceInactive is the only key that allowed me adjust the inactive frame so that the black captions are readable...

Is there a way to get a white blurry outline around the window caption only? Or is that part of the theme?

0

Share this post


Link to post
Share on other sites

shell32.dll version is 6.2.9200.16547

I tried different DeviceFeatureLevel setting, anything higher than or equal to DX10 will result in black screen.

0

Share this post


Link to post
Share on other sites

ColorizationBlurBalanceInactive + ColorizationAfterglowBalanceInactive, both influence the level of the transparency.

I tried those but ColorizationColorBalanceInactive is the only key that allowed me adjust the inactive frame so that the black captions are readable...

Is there a way to get a white blurry outline around the window caption only? Or is that part of the theme?

ColorizationAfterglowBalanceInactive influences it too (but minimally) but you should ensure that the sum of both won't be higher than 100 else it can result in weird things. Caption glow effect is a theme thing.

shell32.dll version is 6.2.9200.16547

I tried different DeviceFeatureLevel setting, anything higher than or equal to DX10 will result in black screen.

DeviceFeatureLevel depends on your graphic card. If your graphic card does not support selected feature level, you will end up with the black screen. If you set DeviceFeatureLevel lower than default, you just switch your graphic card to backward-compatibility mode which can result in unexpected behavior (someone reported here that Metro application does not have to work correctly), degraded performance and other things. The final version will not have this setting at all, so I would like to fix all related issues as soon as possible.

0

Share this post


Link to post
Share on other sites

QQ%E5%9B%BE%E7%89%8720130511202158.jpg

How this place becomes transparent

0

Share this post


Link to post
Share on other sites

shell32.dll 6.2.9200.16547

GPU GTX670M DirectX 11 Shader 5.0

I tried to reproduce the bugs, here are the debug files.

First time applied => glass only on window borders => restarted manually => clicked the user picture to log => black screen => forced restart and returned to desktop holding ctrl key

Second time applied => instantly black screen => forced restart and returned to desktop holding ctrl key

Third time applied, glass only on window borders => black screen after 4 or 5 seconds => forced restart and returned to desktop holding ctrl key

first_time_applied.txt

second_time_applied.txt

third_time_applied.txt

Edited by Tusticles
0

Share this post


Link to post
Share on other sites

no crashlog.txt generated? What happens when you hold ctrl during black screen (so you don't force restart), does it work or not?

0

Share this post


Link to post
Share on other sites

no crashlog.txt generated? What happens when you hold ctrl during black screen (so you don't force restart), does it work or not?

Wow, I held down the button for 40 seconds or so and nothing happened then I started to tap the key and returned to desktop miraculously.

This time a crash log was created.

fourth_time_applied.txt

crash_fourth_time_applied.txt

0

Share this post


Link to post
Share on other sites

Ok, if the crashlog is the reason than it could help. I know how to reproduce it. However, it is weird that it happens on startup :-/

0

Share this post


Link to post
Share on other sites

Ok, if the crashlog is the reason than it could help. I know how to reproduce it. However, it is weird that it happens on startup :-/

Tried again and got black screen instantly after applying, this time ctrl key didn't worked.

forced restart and returned to desktop holding ctrl key

fifth_time_applied.txt

0

Share this post


Link to post
Share on other sites

Here is the temporary fix for a crash http://leteckaposta.cz/670122308

Could you test it so we can confirm whether it is cause of the black screen?

0

Share this post


Link to post
Share on other sites

Here is the temporary fix for a crash http://leteckaposta.cz/670122308

Could you test it so we can confirm whether it is cause of the black screen?

Transparency applied only on windows borders, no blur on taskbar and startmenu, then I restarted explorer and again, black screen.

forced restarted and returned to desktop holding ctrl key

crashfix_debug.txt

0

Share this post


Link to post
Share on other sites

do you use startisback or something like that?

0

Share this post


Link to post
Share on other sites

do you use startisback or something like that?

Yes, but I don't see why would that be a problem, 0.9 worked fine.

Btw I tried again and the crashfix you uploaded does the same thing, black screen when is applied, sometimes the black screen occurs after a few seconds, sometimes it stays active and I have time to restart explorer, after restarting explorer again our friend, the black screen.

here is another log...

crashfix_debug2.txt

Edited by Tusticles
0

Share this post


Link to post
Share on other sites

Did 0.9 really work or you just had native blur enabled ?

0

Share this post


Link to post
Share on other sites

Did 0.9 really work or you just had native blur enabled ?

Yes, it worked/is working, no native blur enabled, I don't even have the key in registry.

Edited by Tusticles
0

Share this post


Link to post
Share on other sites

Did more test. Here is the debug log. my GPU is GTX580,

1). Auto DeviceFeatureLevel, hold CTRL key to boot, taskbar blur is missing in this case, other thing is working normally.

debug-hold_ctrl.txt

2). Right after 1), Drag a windows and make it touch the low part of the taskbar. Black screen appear.

debug-hold_ctrl+drag.txt

3) Boot without holding Ctrl key, auto DeviceFeature level

debug-No_ctrl.txt

Note: Logs for 1 and 3 are capture after deleting the old log. log 2 is captured directly after log 1.

Edited by lolchampion
0

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.