• Announcements

    • xper

      MSFN Sponsorship and AdBlockers!   07/10/2016

      Dear members, MSFN is made available via subscriptions, donations and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, become a site sponsor and ads will be disabled automatically and by subscribing you get other sponsor benefits.
bigmuscle

Aero Glass for Win8 RC4

2,631 posts in this topic

Just tested the temp crashfix, the result is same as RC0.

0

Share this post


Link to post
Share on other sites

What happens when you add registry settings HKCU\Software\Microsoft\Windows\DWM: callBlurShapes (DWORD set to 0x1) ?

0

Share this post


Link to post
Share on other sites

What happens when you add registry settings HKCU\Software\Microsoft\Windows\DWM: callBlurShapes (DWORD set to 0x1) ?

with rc0 or rc0 crashfix?

0

Share this post


Link to post
Share on other sites

It makes no difference. "crashfix" just fixes crash from your crashlog.txt.

0

Share this post


Link to post
Share on other sites

It makes no difference. "crashfix" just fixes crash from your crashlog.txt.

Yes, tried this registry setting with rc0 crashfix and it worked, auto device future level, blur was not applied on taskbar and startmenu but restarting explorer will fix it, no crash when restarting explorer :)

debug_crashfix_callBlurShapes.txt

Edited by Tusticles
0

Share this post


Link to post
Share on other sites

It makes no difference. "crashfix" just fixes crash from your crashlog.txt.

Yes, tried this registry setting with rc0 crashfix and it worked, auto device future level, blur was not applied on taskbar and startmenu but restarting explorer will fix it, no crash when restarting explorer :)

Same result here. Add the registry setting and reboot. Everything is working now with auto DeviceFeatureLevel, taskbar have its blur back too.

Edited by lolchampion
0

Share this post


Link to post
Share on other sites

Fine, now I have to find the real reason of the black screen. I will create debug version which makes more detailed log as this settings will go away in next version.

0

Share this post


Link to post
Share on other sites

Ok, tried rc0 with callBlurShapes, black screen after applying then held ctrl button for a long time and it returned to desktop, ah, and glass was still active.

see debug_rc0_callBlurShapes.txt

--edit--

tried again rc0, this time when pressed the apply button in AGTweaker it worked then pressed apply button again and black screen occured.

see debug_rc0_callBlurShapes2.txt

--edit--

Man, I have no idea what have you done but 0.9 is optimized, Is smooth on all p-states :D :D :D, let's hope it stays like this.

debug_rc0_callBlurShapes.txt

debug_rc0_callBlurShapes2.txt

Edited by Tusticles
0

Share this post


Link to post
Share on other sites

Ok, so please, use default settings (no additional key in registry, no specific device feature level) and install this version

http://leteckaposta.cz/723577425

When blackscreen appears, hold F11 for approx. one second and it starts generating file threads.log. It can take a while, because it will download public debug symbols from Microsoft servers (which are several MBs). Then it will automatically kill the process (which will result in dwm.exe restart, so it will be probably stuck with another black screen, so hold CTRL after pressing F11. I hope this will work and it will help to fix the problem :-)

And of course, then send me threads.log file.

0

Share this post


Link to post
Share on other sites

Ok, so please, use default settings (no additional key in registry, no specific device feature level) and install this version

http://leteckaposta.cz/723577425

When blackscreen appears, hold F11 for approx. one second and it starts generating file threads.log. It can take a while, because it will download public debug symbols from Microsoft servers (which are several MBs). Then it will automatically kill the process (which will result in dwm.exe restart, so it will be probably stuck with another black screen, so hold CTRL after pressing F11. I hope this will work and it will help to fix the problem :-)

And of course, then send me threads.log file.

Done. Here is the log.

threads.txt

debug.txt

0

Share this post


Link to post
Share on other sites

i have a problem with 0.91(RC0). when i drag a window and it starts to enter taskbar space i get a black screen. even on autohide taskbar when it is 1 pixel when window crosses it - instant black screen. with v0.9(beta3) i don't have this problem. sorry for bad English.

0

Share this post


Link to post
Share on other sites

Cannot guarantee 100% success, but if you're having issues with a DLL try running Windows update, and after installing all the updates and rebooting, run "sfc /scannow" without quotes from an elevated command prompt. A really useful command and non of the all in one tools ever seem to run it (System Mechanic, Advanced System Care, etc.). Running that command checks system files (including DLLs) for corruption. It will replace them with correct versions. Try that and reboot afterwards. Then, you could always redownload some Windows updates and try reinstalling them again.

Edited by MikeRL
0

Share this post


Link to post
Share on other sites

i have a problem with 0.91(RC0). when i drag a window and it starts to enter taskbar space i get a black screen. even on autohide taskbar when it is 1 pixel when window crosses it - instant black screen. with v0.9(beta3) i don't have this problem. sorry for bad English.

Read the previous pages, lol.

Btw, bigmuscle, tried what you gave me, a thread file was created but ctrl button didn't worked so I manually restarted. I'll try again.

Edited by Tusticles
0

Share this post


Link to post
Share on other sites

thread.log is just the one important...

However, I must admit that I don't understand it at all. Nody has a problem except of Tusticles and two guys who registered here right now. Debug logs say that everything is correct, also threads.log from lolchampion does not show that it should be stuck up somewhere in my code. So there is probably some secret magic, some special combination how to reproduce this problem. Do you have something special in your computer? Any special settings, any special theme etc... ?

0

Share this post


Link to post
Share on other sites

My system is a fulled patched windows 8 x64 pro with media center, no custom theme and no start button is installed.

0

Share this post


Link to post
Share on other sites

thread.log is just the one important...

However, I must admit that I don't understand it at all. Nody has a problem except of Tusticles and two guys who registered here right now. Debug logs say that everything is correct, also threads.log from lolchampion does not show that it should be stuck up somewhere in my code. So there is probably some secret magic, some special combination how to reproduce this problem. Do you have something special in your computer? Any special settings, any special theme etc... ?

Tried and again tried to do what you said, applied the debug version, to get the black screen I had to move a window over the taskbar, screen turned black, pressed f11 and saw the mouse pointer flickering so I presume it started to download required files for debugging. You said dwm process will be restarted automatically after a while but the screen remained black for more than 30 minutes then I decided to restart manually....

I hope thee debug files will tell you something

dbghelp_debug.txt

dbghelp_threads.txt

0

Share this post


Link to post
Share on other sites

It seems to be stuck in video driver. I tried a few changes, could you test it? http://leteckaposta.cz/uploaded/329367334

Also add following registry settings: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\DWM: NoFillPath (DWORD 0x1), then restart dwm process.

0

Share this post


Link to post
Share on other sites

It seems to be stuck in video driver. I tried a few changes, could you test it? http://leteckaposta.cz/uploaded/329367334

Also add following registry settings: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\DWM: NoFillPath (DWORD 0x1), then restart dwm process.

Applied, black screen, pressed f11, waited a few minutes, tried ctrl, didn't worked, forced restart and returned to desktop holding ctrl key...

debug_nofillpath.txt

threads_nofillpath.txt

0

Share this post


Link to post
Share on other sites

here is mine log's with NoFillPath (DWORD 0x1) and the latest debug dll from your post.

debug.txt

threads.txt

Edited by bitaljus
0

Share this post


Link to post
Share on other sites

So try this: http://leteckaposta.cz/302887755

When you press F11, it will generate approx. 170 MB file minidump.dmp. Send it to me.

After you generate minidump. create registry value HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\DWM: NoInternalHooks (DWORD 0x1) and try what happens.

0

Share this post


Link to post
Share on other sites

everything starts fine with RC0, the inactive window glitch is gone.

but when I launch Firefox, the screen went black and left with the cursor... this is tested with FF19, 20 and nightly with the same result.

what information should I provide to help analyzing this issue?

0

Share this post


Link to post
Share on other sites

No Issues!! Working Great.. Thanks for all your work thumbup.gif

0

Share this post


Link to post
Share on other sites

So try this: http://leteckaposta.cz/302887755

When you press F11, it will generate approx. 170 MB file minidump.dmp. Send it to me.

After you generate minidump. create registry value HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\DWM: NoInternalHooks (DWORD 0x1) and try what happens.

Done.

Applied, black screen, pressed f11, I waited several minutes then I did a force restart and returned to desktop holding ctrl key

Then added that key with this value 0x00000001, re-applied dwmglass, no black screen but transparency was not applied,

here is the dmp file before adding that reg value to registry http://www.mediafire.com/?7xm3delamv4a0k7

Edited by Tusticles
0

Share this post


Link to post
Share on other sites

I tried the release candidate on my secondary Windows 8 pc, and it couldn't work more perfectly. It feels like I am using Windows 8 RP! Thank you, Bigmuscle.

It's amazing how far along this utility has gotten since the preview releases. I have been watching the conversation between you and poor unlucky Tusticles, and it's actually a bit scary. This thing must be integrated very deeply. Be sure to keep the kill-key in the final version.

Tusticles has always had problems with this related to performance. I am curious at what his computer configuration is.

So I take it once that the Tusticles problem is fixed, it goes on to version 1?

0

Share this post


Link to post
Share on other sites

I tried the release candidate on my secondary Windows 8 pc, and it couldn't work more perfectly. It feels like I am using Windows 8 RP! Thank you, Bigmuscle.

It's amazing how far along this utility has gotten since the preview releases. I have been watching the conversation between you and poor unlucky Tusticles, and it's actually a bit scary. This thing must be integrated very deeply. Be sure to keep the kill-key in the final version.

Tusticles has always had problems with this related to performance. I am curious at what his computer configuration is.

So I take it once that the Tusticles problem is fixed, it goes on to version 1?

Wtf, you know I always had problems related to performance but you don't know what configuration I have, I posted the specs a lot of times, it wasn't me who had problems, it was dwmglass, in RC0 the performance is improved a lot but there is the problem with the black screen. Ah and btw, I'm not the only one who had/have problems, there are some guys here with the same problem and many who downloaded the application but they didn't posted any debug files...

ASUS G75VW

Processor: Intel Core i7 3610QM

Graphic: NVIDIA GeForce GTX 670M with 3GB GDDR5 VRAM

Memory: 12 GB DDR3 1600

Storage: 750GB 7200 SSH

Edited by Tusticles
0

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.