bigmuscle

Aero Glass for Win8 RC4

2,631 posts in this topic

For me v0.8 didn't work, even if I had changed debug files; as I see I have some wrong dll files -just full transparency and no blur, or no transparency. With AGTweaker and dx9.3 blur works, but first window has no transparency, also I can't change blur. In the v0.7 and D2D it works, but when I changed any settings in Windows, taskbar becomes fully transparent - windows were still blured and coloured. It may be caused by using stardock Start8 I think. Applying settings in AGTweaker makes it working until next turning on the PC (I know AGT isn't yours but otherway if I change any windows setting I have to restart the PC to make your program work as it should. If you want I can attach my crash list. By the way - do You plan adding shadows? Win7 Aero has it.

Anyway great work!

Edited by Rumcayz
0

Share this post


Link to post
Share on other sites

By the way - do You plan adding shadows? Win7 Aero has it.

I'll save BigMuscle the trouble of answering... Drop shadows come from the theme resource list. Windows is currently compositing fully transparent drop shadows for you. Nice of them, eh?

You can add drop shadows yourself by having Aero Glass for Win8 load alternate desktop element resources from a PNG file, the path to which you specify by the HKEY_CURRENT_USER\Software\Microsoft\Windows\DWM : CustomThemeResource REG_SZ value.

Win8Desktop.png

Click here to download the alternate theme resource PNG file I've modified.

-Noel

Edited by NoelC
0

Share this post


Link to post
Share on other sites

I think I'm having the same issues as other people. Taskbar has the default semi-transparency that is default with windows and the window borders are pretty much fully transparent and not customizable.

I am using SiB.

Might go back to 0.7.

0

Share this post


Link to post
Share on other sites

I think I'm having the same issues as other people. Taskbar has the default semi-transparency that is default with windows and the window borders are pretty much fully transparent and not customizable.

I am using SiB.

Might go back to 0.7.

Had you been using the Direct2D setting before?

Have you tried adjusting the Intensity and other settings in the desktop personalization dialog?

Perhaps you could post your debug.log before switching back? BigMuscle could possibly make use of the additional info about what's going wrong.

-Noel

Edited by NoelC
0

Share this post


Link to post
Share on other sites

I think I'm having the same issues as other people. Taskbar has the default semi-transparency that is default with windows and the window borders are pretty much fully transparent and not customizable.

I am using SiB.

Might go back to 0.7.

Had you been using the Direct2D setting before?

Have you tried adjusting the Intensity and other settings in the desktop personalization dialog?

Perhaps you could post your debug.log before switching back? BigMuscle could possibly make use of the additional info about what's going wrong.

-Noel

I've been using D2D and D3D, I think I was using D3D right before changing though.

I haven't tried playing with the personalization settings, though I have it set to automatically match the color and it changes every 2 minutes with the background, so I think it would have done that already.

Just tried it now and the only thing that happened is the effect was disabled when intensity was maximum.

debug log: https://dl.dropboxusercontent.com/u/20887877/debug.log

0

Share this post


Link to post
Share on other sites

I think I'm having the same issues as other people. Taskbar has the default semi-transparency that is default with windows and the window borders are pretty much fully transparent and not customizable.

I am using SiB.

Might go back to 0.7.

Had you been using the Direct2D setting before?

Have you tried adjusting the Intensity and other settings in the desktop personalization dialog?

Perhaps you could post your debug.log before switching back? BigMuscle could possibly make use of the additional info about what's going wrong.

-Noel

I've been using D2D and D3D, I think I was using D3D right before changing though.

Only difference when changing intensity is the effect goes back to the windows default when intensity is maximum.

debug log: https://dl.dropboxusercontent.com/u/20887877/debug.log (I've been using this software for a while. :thumbup )

Edited by hello2u
0

Share this post


Link to post
Share on other sites

I think I'm having the same issues as other people. Taskbar has the default semi-transparency that is default with windows and the window borders are pretty much fully transparent and not customizable.

I am using SiB.

Might go back to 0.7.

For taskbar, make sure "Disable translucency" is not ticked in SIB Options -> "Appearance"

Disable DWMGlass, go to SIB Options - > "Advanced" and tick "Disable program for current user" then Sign Out -> Sign In, now enable DWMGlass, the taskbar should be fixed. SIB can be re-enabled from Control Panel, after re-enabling SIB, Sign Out -> Sign In again.

0

Share this post


Link to post
Share on other sites

So.. Win8 x32 Pro & MC with Aero Glass v0.8.

It seems to be working, no more error messages:

11111111111.png

but:

1) no glass in the taskbar on the second screen

2) black screen on reboot problem: when you press "reboot" it shows reboot screen, but then it turns to black with cursor on it (I had it for 5 minutes while windows updates installation)

3) "This is demo version" popup stops glass from working, after pressing "OK" it works again

4) got the crash log, but don't know when it generates (no error messages)

5) no difference between standard and native rendering - is it even works?

Crash & debug logs

AGTweaker v1.2.2 doesn't work well - after "Apply" button:

22222222222.png

v1.2.1 worked fine though

0

Share this post


Link to post
Share on other sites
Does explorer creates one control which is extended over both monitors or does it create two controls? Could you try WinID application and get information about both taskbars?

Taskbar 1 : http://img10.imageshack.us/img10/1621/taskbar1.png

Taskbar 2 : http://img543.imageshack.us/img543/5879/taskbar2.png

It seems to be two different controls.

Thank you. Just one small thing which I probably shoould mention before. Your images are from the list of the runnings apps which is child of the taskbar. The proper info for the taskbar can be retrieved when you move mouse to the leftest part of the taskbar. WinID should provide "No parent window" in brown text in the middle and Shell_TrayWnd for Class item.

1) no glass in the taskbar on the second screen

Yeah, Already reported, I will fix it soon.

2) black screen on reboot problem: when you press "reboot" it shows reboot screen, but then it turns to black with cursor on it (I had it for 5 minutes while windows updates installation)

I am not sure about this

4) got the crash log, but don't know when it generates (no error messages)

I'm aware of this crash (callstack according to your attached file), I know why it happens but I have not able to find correct solution yet :-(

5) no difference between standard and native rendering - is it even works?

As stated in changelog, it requires to have compatible DLLs and works for x64 only. I will make all 0.8 features work in 32-bit soon.

0

Share this post


Link to post
Share on other sites

I think I'm having the same issues as other people. Taskbar has the default semi-transparency that is default with windows and the window borders are pretty much fully transparent and not customizable.

I am using SiB.

Might go back to 0.7.

Just reminding to anyone whole has the same problem = windows are fully transparent without blur effect. Could you try this version to confirm that it will be fixed in next version http://leteckaposta.cz/306250185

0

Share this post


Link to post
Share on other sites

2) black screen on reboot problem: when you press "reboot" it shows reboot screen, but then it turns to black with cursor on it (I had it for 5 minutes while windows updates installation)

I am not sure about this

I have a black screen on every reboot, usually for 5-10 seconds.

Without glass dll loaded there is no such problem :}

P.S. looks like a black screen appears after the user logout is complete.

Edited by deltebews
0

Share this post


Link to post
Share on other sites

Forgot about the debug version, kinda skimmed over those posts.

Downloading now, it's going quite slowly (my internet is 100mbps here, so it's probably the hosting site).

I'll update this post with the results, thanks!

Update: Looks like I'll need a restart to change versions. I have a backup running currently so I'll make a new post when I get it installed.

Edited by hello2u
0

Share this post


Link to post
Share on other sites

To fully finish 32-bit version, could someone pack and share for me following files from C:\Windows\System32\... dwmcore.dll, udwm.dll, themecpl.dll and shell32.dll? (32bit only!!!) Rather via PM not to corrupt license of those files. Thanks!

0

Share this post


Link to post
Share on other sites

To fully finish 32-bit version, could someone pack and share for me following files from C:\Windows\System32\... dwmcore.dll, udwm.dll, themecpl.dll and shell32.dll? (32bit only!!!) Rather via PM not to corrupt license of those files. Thanks!

I sent it to you.

0

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.