• Announcements

    • xper

      MSFN Sponsorship and AdBlockers!   07/10/2016

      Dear members, MSFN is made available via subscriptions, donations and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, become a site sponsor and ads will be disabled automatically and by subscribing you get other sponsor benefits.
bigmuscle

Aero Glass for Win8 RC4

2,631 posts in this topic

It shows the frame of the minimal taskmanger with nothing in it, as soon as the fade in animation completes, it closes.

can you make some pictures or videos? I have no idea what you mean.

Btw, the Windg issue is still there. strange that it worked with the other dump I opened 2 hours ago :unsure:

0

Share this post


Link to post
Share on other sites

Windows Theme service uses Crypto API for verifying theme signature. If it does not match (any custom theme) then the theme is not loaded by the system. Just a simple trick to always return true from this function :whistle:

Ah, got it. Thanks. :)

-Noel

0

Share this post


Link to post
Share on other sites

does this mean I can use custom themes without patching uxtheme dlls? Is this feature working with the RC3?

0

Share this post


Link to post
Share on other sites

ok I ended up with black screen. I reset but there is still black screen. Frankly I was afraid. I used shift+ F8 menu to bring back. Thats enough for me :) Thank you anyway sir :)

Sorry mate, maybe I should not try to help in future, the installer had options for x86 or x64, maybe you selected the wrong one, who knows, just wait for the final version.

No its not about you sir. I did downloaded to x64 version however I encountered with a unknown problem which ended up with black screen. Still dont know what the real problem is. I decided not to mess with it :) There is nothing related with you sir :) You did what a responsive user should do :)

0

Share this post


Link to post
Share on other sites

It shows the frame of the minimal taskmanger with nothing in it, as soon as the fade in animation completes, it closes.

can you make some pictures or videos? I have no idea what you mean.

Btw, the Windg issue is still there. strange that it worked with the other dump I opened 2 hours ago :unsure:

http://screencast.com/t/WCop2WWbZISK

0

Share this post


Link to post
Share on other sites

does this mean I can use custom themes without patching uxtheme dlls? Is this feature working with the RC3?

Uninstalled uxstyle and yes, I can apply custom themes when using RC3 :D

0

Share this post


Link to post
Share on other sites

does this mean I can use custom themes without patching uxtheme dlls? Is this feature working with the RC3?

Uninstalled uxstyle and yes, I can apply custom themes when using RC3 :D

Yep I uninstalled it as well now, just hope nothing breaks Aero Glass and we end up with a black screen on boot.

0

Share this post


Link to post
Share on other sites

Another debug log, shader optimization is enabled on this one and I didn't notice any glitches.

click

0

Share this post


Link to post
Share on other sites

If you have any non-working application (e.g. WinDBG etc.), could you provide exact step how to reproduce it after clean installation of that application? I will try to install it to see what's wrong. But currently I don't see any reason why changes in DWM should influence any application.

And please, verify that it does not happen when DWMGlass.dll is not loaded.

Btw, don't rely on custom themes much now, it has not been properly tested and I don't intend to modify it more before 1.0 release. For example, I don't know what happens when something in uxinit.dll is changed to break this function, i.e. control panel loads theme correctly but verifying on Windows startup fails - will it automatically switch to default Windows theme or what?

Edited by bigmuscle
0

Share this post


Link to post
Share on other sites

BigMuscle, perhaps you should consider making overriding the theme signature verification logic optional in your final release. I for one would be happy just using just the button, etc. graphic resource override capability.

I think that hooks that circumvent system protections at run time might not be well-received by folks concerned with security and using their computers for serious things. I know, it's kind of a gray area - i.e., where do you draw the line for how much you choose to override, since overriding the theme resources is practically necessary.

-Noel

0

Share this post


Link to post
Share on other sites

Uninstalled uxstyle and yes, I can apply custom themes when using RC3 :D

I also tested it in a VM and it works :)

:thumbup

0

Share this post


Link to post
Share on other sites

I'm getting this a couple times a day:

i4jqeQx.png

0

Share this post


Link to post
Share on other sites

I'm getting this a couple times a day:

i4jqeQx.png

I'm having the same problem.

0

Share this post


Link to post
Share on other sites

I'm getting this a couple times a day:

Have you loaded an alternate theme? I haven't, and am not seeing that message.

If you look back in the thread just a bit you'll see that BigMuscle has advised to avoid doing so, as it's not a mature feature.

-Noel

0

Share this post


Link to post
Share on other sites

There is an alternative WindowBlinds 8

One's free, the other isn't. And just for the blur effect isn't worth the price.

0

Share this post


Link to post
Share on other sites

Have you loaded an alternate theme? I haven't, and am not seeing that message.

If you look back in the thread just a bit you'll see that BigMuscle has advised to avoid doing so, as it's not a mature feature.

-Noel

I am using the Release Preview theme. Screenshot of the error: https://www.dropbox.com/s/y44ye887lqzptnj/Aero%20Glass%20Snip19.PNG It should work correctly since the theme is official and signed by Microsoft.

Edited by WindowsOS
0

Share this post


Link to post
Share on other sites

There is an alternative WindowBlinds 8

One's free, the other isn't. And just for the blur effect isn't worth the price.

WindowBlinds doesn't even support blur anyway, it's not AeroGlass. All it does is make the frame completely transparent.

0

Share this post


Link to post
Share on other sites

I am using the Release Preview theme. Screenshot of the error: https://www.dropbox.com/s/y44ye887lqzptnj/Aero%20Glass%20Snip19.PNG It should work correctly since the theme is official and signed by Microsoft.

I too had that error when using RP theme.

Here's the debug log, with custom themes.

Intel HD 3000 -> w/ Shader Render Optimization enabled.

nVidia 9500GT -> w/ Shader Render Optimization disabled.

0

Share this post


Link to post
Share on other sites

Yes, I have tried it and I must admit that I don't like it. It has a bit weird frame edges which looks like the shadow is a bit offset resulting in a small gap. ORelio looks better but it looks much "Sevenish" to me and the window frames style does not match the taskbar style. Also the thing that caption glow effect for shell windows is stored in different image resource makes me think about a bit different approach - to hook uxtheme functions to allow using unsigned msstyle themes and provide complete theme.

Thanks for the feedback. I just fixed that "offset shadow" thing, and now it looks cleaner. I wonder if you'd be willing to take a moment to try it again...

Same link, updated file.

http://Noel.ProDigit...ernateTheme.png

Nothing is set in stone, and I'm willing to tweak it until you like it.

Here's what it looks like now...

LatestTheme1.png

-Noel

Can somene explain me how can I create the VS on the screenshot with the first picture in this post? Or better, give me a download link for the VS?

Thank you in advance! :)

0

Share this post


Link to post
Share on other sites

Can somene explain me how can I create the VS on the screenshot with the first picture in this post? Or better, give me a download link for the VS?

Thank you in advance! :)

Make a new String Value in HKEY_CURRENT_USER\Software\Microsoft\Windows\DWM , named, CustomThemeResource containing the path to the custom theme resource file and restart (or change between themes).

dwm-customtheme.jpg.

Edited by Rayn19
0

Share this post


Link to post
Share on other sites

I'm getting this a couple times a day:

i4jqeQx.png

I'm not even sure where this message box comes from. When does it appear? Only when changing theme, or randomly during a day?

0

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.