bigmuscle

Aero Glass for Win8 RC4

2,631 posts in this topic

Please, do not report any glitches if you use AGTweaker. The settings which it alters are not supported by my AeroGlass and it even does not respect DWM colorization rules/ranges, thus it can result in completely wrong behaviour.

Okay. I am now re-reporting these glitches which can be reproduced without AGTweaker:

- "Autodetect" feature level gives me the bugged complete transparency. Anything above 9.3 does the same. Anything in the 11 series causes crash-loops I can only avert using the Ctrl method.

- Windows Mobility Center still displays inappropriate transparency. I cannot speculate whose code is at fault; it could be Microsoft's (also arguably to blame for the lack of Aero in the first place, but I digress), yours, or Intel's (driver)...or a healthy combination of them.

I also want to stress that I only used AGTweaker in the first place because opacity was wrong by default (background windows appeared way too dark, and using AGTweaker to adjust opacity resolved this issue).

0

Share this post


Link to post
Share on other sites

What is wrong about Mobility Center? It works as expected here.

wmc.png

0

Share this post


Link to post
Share on other sites

Working good so far :D

Q9XpgK3.jpg

Only bug I have encountered so far is if you frag a window behind the taskbar, you get garbage that shows when you move the window around.

0

Share this post


Link to post
Share on other sites

Database weirded out and posted twice. Delete please, thanks =)

Edited by ElvenSpellmaker
0

Share this post


Link to post
Share on other sites

Thanks Rayn19, I downloaded version 0.85 and I get the following dialogues:

Shell32.png

ThemeCPL.png

And my current debug log: https://dl.dropboxusercontent.com/u/28476963/AeroGlass/debug.log

I'm running Windows 8 Professional with Media Centre x64 and the version 0.5 loads fine.

(This laptop came with Windows 7 Home Premium x86 back when I bought it so I assume it's not a secure boot issue?)

Edited by ElvenSpellmaker
0

Share this post


Link to post
Share on other sites

I'm getting a jump list glitch that does not occur in Windows 7:

yI0QxkT.jpg

Is there any chance of this getting fixed? Or is it a fundamental issue with Windows 8? Also, I'm working on a Windows 8 theme utilizing your glass utility, do you have a rough estimate of when we can be expecting a usable beta?

Thank you!

0

Share this post


Link to post
Share on other sites

Thanks Rayn19, I downloaded version 0.85 and I get the following dialogues:

Shell32.png

ThemeCPL.png

And my current debug log: https://dl.dropboxusercontent.com/u/28476963/AeroGlass/debug.log

I'm running Windows 8 Professional with Media Centre x64 and the version 0.5 loads fine.

(This laptop came with Windows 7 Home Premium x86 back when I bought it so I assume it's not a secure boot issue?)

Try lowering the the color intensity, while using v0.85.

pers-color-intensity.jpg

0

Share this post


Link to post
Share on other sites

I'm getting a jump list glitch that does not occur in Windows 7:

yI0QxkT.jpg

Is there any chance of this getting fixed? Or is it a fundamental issue with Windows 8? Also, I'm working on a Windows 8 theme utilizing your glass utility, do you have a rough estimate of when we can be expecting a usable beta?

Thank you!

I see this as the bug in the theme and not in the aeroglass utility.

0

Share this post


Link to post
Share on other sites

Hi Rayn19,

I moved the slider and as soon as I did the transparency burst into life, even when I put it back high again, is this a bug in the 0.8(5) versions?

I still get the messages when I go to the Screen Resolution page and I don't know if it will continue to work on a reboot.

(Also is there any way to change the inactive colour, because I can barely distinguish them from each other [much like Windows 7].)

0

Share this post


Link to post
Share on other sites

There is no 0.85 version, you probably mean that debug build which was intended for testing surface render target only. The other things in it are completely broken so it is normal that you get message boxes about incompatibility.

And yes, inactive colour can be changed in HKCU\SOFTWARE\Microsoft\Windows\DWM using DWORD values ColorizationColorInactive, ColorizationColorBalanceInactive, ColorizationBlurBalanceInactive, ColorizationAfterglowInactive and ColorizationAfterglowBalanceInactive .

0

Share this post


Link to post
Share on other sites

I'm getting a jump list glitch that does not occur in Windows 7:

yI0QxkT.jpg

Is there any chance of this getting fixed? Or is it a fundamental issue with Windows 8? Also, I'm working on a Windows 8 theme utilizing your glass utility, do you have a rough estimate of when we can be expecting a usable beta?

Thank you!

I see this as the bug in the theme and not in the aeroglass utility.

It's ported directly from my Windows 7 theme which does not have this issue so I don't think the issue is with my theme. Others are having a similar issue albeit with a hack workaround: http://vistastylebuilder.com/forum/index.php?topic=1832.msg10279#msg10279

Thanks

0

Share this post


Link to post
Share on other sites

I'm getting a jump list glitch that does not occur in Windows 7:

yI0QxkT.jpg

Is there any chance of this getting fixed? Or is it a fundamental issue with Windows 8? Also, I'm working on a Windows 8 theme utilizing your glass utility, do you have a rough estimate of when we can be expecting a usable beta?

Thank you!

I see this as the bug in the theme and not in the aeroglass utility.

It's ported directly from my Windows 7 theme which does not have this issue so I don't think the issue is with my theme. Others are having a similar issue albeit with a hack workaround: http://vistastylebuilder.com/forum/index.php?topic=1832.msg10279#msg10279

Thanks

Not sure what your problem is as you did not really explain it, if your referring to the non transparent top part of the jump list then I can say that I have not had this problem at all with aero glass from Big Muscle I have used D3D and D2D and both render fine with the themes that support it, just because it was ported directly from Windows 7 does not mean there might not be some problems, send me a link for the theme to test and I can tell you straight away if the problem is with the theme or not.

0

Share this post


Link to post
Share on other sites

I'm getting a jump list glitch that does not occur in Windows 7:

yI0QxkT.jpg

Is there any chance of this getting fixed? Or is it a fundamental issue with Windows 8? Also, I'm working on a Windows 8 theme utilizing your glass utility, do you have a rough estimate of when we can be expecting a usable beta?

Thank you!

I see this as the bug in the theme and not in the aeroglass utility.

It's ported directly from my Windows 7 theme which does not have this issue so I don't think the issue is with my theme. Others are having a similar issue albeit with a hack workaround: http://vistastylebuilder.com/forum/index.php?topic=1832.msg10279#msg10279

Thanks

Sorry double post, seems there was a database error

Join the club with the database error causing double posts. I wonder if the admins of the forum know about this?

0

Share this post


Link to post
Share on other sites

Sorry double post, seems there was a database error

Join the club with the database error causing double posts. I wonder if the admins of the forum know about this?

We sure do know and are working to solve it for some time already...

0

Share this post


Link to post
Share on other sites

I'm getting a jump list glitch that does not occur in Windows 7:

yI0QxkT.jpg

Is there any chance of this getting fixed? Or is it a fundamental issue with Windows 8? Also, I'm working on a Windows 8 theme utilizing your glass utility, do you have a rough estimate of when we can be expecting a usable beta?

Thank you!

I see this as the bug in the theme and not in the aeroglass utility.

It's ported directly from my Windows 7 theme which does not have this issue so I don't think the issue is with my theme. Others are having a similar issue albeit with a hack workaround: http://vistastylebui...g10279#msg10279

Thanks

Not sure what your problem is as you did not really explain it, if your referring to the non transparent top part of the jump list then I can say that I have not had this problem at all with aero glass from Big Muscle I have used D3D and D2D and both render fine with the themes that support it, just because it was ported directly from Windows 7 does not mean there might not be some problems, send me a link for the theme to test and I can tell you straight away if the problem is with the theme or not.

screenshotworkingjumpli.png

Works fine here on default theme (I also turned on "thin edges" and custom theme resource "default", but works even if you don't).

Edited by Gabe
0

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.