Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account


Photo

Word Docs Switch to Read-Only After Several Saves in Word 2003

- - - - -

  • Please log in to reply
22 replies to this topic

#1
mitchsc

mitchsc

    Junior

  • Member
  • Pip
  • 73 posts
  • OS:Windows 7 x64
  • Country: Country Flag
This is driving me crazy! Word documents switch to Read-Only after several saves in Word 2003. Seems more prevalent in large documents. It gets to the point where it switches after only 2 or 3 saves.

I have to copy the entire document to the clipboard, close and reopen the document, paste back everything with it's changes, then save.

There is a lot written on this topic, but nothing has worked for me. Microsoft recommends turning off "Allow Background Saves", but that hasn't worked for me or many others.

Interestingly, I ran across some obscure comment about opening and saving the document in Safe Mode. I tried it, and to my amazement, the problem disappeared for 5 days. Have done this twice now with same results. Is this a clue?

Any ideas about a more permanent solution?

Thank you...


How to remove advertisement from MSFN

#2
submix8c

submix8c

    Inconceivable!

  • Patrons
  • 4,186 posts
  • OS:none specified
  • Country: Country Flag
Silly questions
- Is It Registered/Activated or is it still in Evaluation-Mode?
- Is the Document in question being opened from a Local Location or a Network-Share or Mapped-Drive?
- What are your Tools->Options settings in the "Save" and "Security" Tabs? (see my attached)
- Did it "crash" at anytime? (Temporary Files remain behind)
- Did you install Word Viewer AFTER Word? (shouldn't matter?)

Word-XP (2002) and Word-2003 are functionally the same.

I see you're on Windows 7. This is Vista but ALSO mentions Network Shares (and lag time) -
http://www.vistax64....iles-vista.html

You also mention "prevalent in large documents". Lag-time during saves? If they are that large, maybe you should save, exit, reopen occasionally.

A tip here (add-ins and a test for the problem) -
http://help.wugnet.c...ict1130249.html

And here (ref. my screenshots) -
http://doesitcompute...d-only-not.html
Attached File  ___Word Security Options.jpg   31.29KB   1 downloads Attached File  ___Word Save Options.jpg   32.55KB   1 downloads
edit - Notice the "background save"? Lag time on large docs?...

Edited by submix8c, 24 January 2013 - 12:54 PM.

Someday the tyrants will be unthroned... Jason "Jay" Chasteen; RIP, bro!

Posted Image


#3
mitchsc

mitchsc

    Junior

  • Member
  • Pip
  • 73 posts
  • OS:Windows 7 x64
  • Country: Country Flag
WOW!

Thank you for all the reference material. I'll have to read thru all this carefully, which may take some time. Will report back.

I can answer your questions now though.
- Registered and activated
- Local location / internal HDD
- No Crash. I use CCleaner every day to clear out temp files.
- I don't even know what Word Viewer is, so I don't think I have it.
- Security and Save settings: (not sure how to insert my screenshots) Security Tab: same as yours + "Make hidden markup visible when opening or saving". Save Tab: It has always been same as yours until today. I just unchecked "Allow background saves" (Per Microsoft for this Read-Only problem)

Thank you so much!!!

#4
mitchsc

mitchsc

    Junior

  • Member
  • Pip
  • 73 posts
  • OS:Windows 7 x64
  • Country: Country Flag
I'm back SubMix, and have read all the reference material your provided. Interesting!

I went through all the testing and settings, and none of them made any difference. Also, I have no add-ins.

This is what I can say with absolute certainty:
1) I did not have this problem with XP and Word 2003
2) It does not occur is Safe Mode (I did 50 saves)
3) After saving a Word doc in Safe mode, the problem can go from every 2-3 saves, to 3-5 days before it happens again.

I suppose I could just work in Safe Mode... ;)

Thank you so much for giving me all these things to try. Any other thoughts?

#5
mitchsc

mitchsc

    Junior

  • Member
  • Pip
  • 73 posts
  • OS:Windows 7 x64
  • Country: Country Flag
Update and Possible Solution!

Since this problem never occurred in XP (just started in Windows 7), it occurred to me that Using Compatibility Mode set for XP SP3 may create a friendlier environment for Word .

For anyone interested, Procedure:
- Right click on Word 2003 shortcut
- Compatibility tab
- Check: Run Program in Compatibility Mode for: Windows XP SP3
- Apply > OK.

It has been over 48 hours since any of my Word documents switched themselves to Read-Only. This is unprecedented for my system. I can usually only do several saves before Read-Only kicks in.

I'm cautiously optimistic, but was so encouraged, I just had to post this update.

Keeping my fingers crossed....

Thanks again.

#6
submix8c

submix8c

    Inconceivable!

  • Patrons
  • 4,186 posts
  • OS:none specified
  • Country: Country Flag
Huh! Never occurred to me BUT another tip (searching on "compatibility mode" + Win7 + word2003)
http://social.techne...82-995704dc9691

Do not forget to download and install the Microsoft Office 2003 Service Pack 3 (http://www.microsoft...tails.aspx?id=8) to get the full Windows 7 compatibility.

Do you have it installed? If not, install it and turn off Compatibility Mode for funsies (test case). If it's all good then there's the real solution, otherwise back to "compatibility".

Someday the tyrants will be unthroned... Jason "Jay" Chasteen; RIP, bro!

Posted Image


#7
mitchsc

mitchsc

    Junior

  • Member
  • Pip
  • 73 posts
  • OS:Windows 7 x64
  • Country: Country Flag
Update:

Sorry for the delay. This Read-Only problem is now so intermittent that I had to give it some time, and try a few different combinations. This is what I have learned.

1) Running Word 2003 (no Service Pack) in XP SP-3 Compatibility Mode greatly improved the problem, but did not eliminate it.

2) Running Word 2003 SP-3 (not in Compatibility Mode) "may" have SOLVED the problem. Still need to give this one some time, but it's looking good.

3) Running Word 2003 SP-3 in XP SP-3 Compatibility Mode made no difference over bullet #2 above.

As an aside, I did notice that running Word 2003 in XP SP-3 Compatibility Mode "seemed" to cause a several second delay when jumping between open Word documents. Quite annoying,

So as of now, Compatibility mode is off, and I'm running Word SP-3. So far so very very good, but not 110% certain I have a solution.

Thank you SO MUCH submix for this suggestion!!! It is clearly the best yet, and hopefully the end of this Read-Only problem for me. You may have just saved me thousands in therapy costs.

Cheers...

#8
mitchsc

mitchsc

    Junior

  • Member
  • Pip
  • 73 posts
  • OS:Windows 7 x64
  • Country: Country Flag
So much for my 110% certainty. I just got a Read-Only "flip" on a Word 2003 SP-3 document.

Things are much better than before the SP-3 update, however.

Now I'll try putting Word back in Compatibility Mode for XP SP-3, and see what happens.

Stay tuned...

#9
submix8c

submix8c

    Inconceivable!

  • Patrons
  • 4,186 posts
  • OS:none specified
  • Country: Country Flag
Please bear in mind that there are other updates beyond SP3 that may-or-maynot be relevant.

Use ("Step up to") Microsoft Update vs Windows Update to find them using "Custom" vs "Express". Once you find the KB# you can search for it to (maybe) get the Full Download.

Someday the tyrants will be unthroned... Jason "Jay" Chasteen; RIP, bro!

Posted Image


#10
mitchsc

mitchsc

    Junior

  • Member
  • Pip
  • 73 posts
  • OS:Windows 7 x64
  • Country: Country Flag
I actually did that last week. There are 4 updates beyond SP-3. 2 of them relate to Office 2003, but nothing to do with this issue (KB2543854 and KB907417). The other 2 are Outlook updates (KB2760582 and KB2760754). KB907417 actually increases the possibility of crashes in Office 2003. So I did not include these in the update.

Again, I really must thank you for sticking with me on this. I really appreciate all the time you've spent. The only thing left that I can think of, is the Compatibility Mode.

Just an observation (that I think I may have already mentioned somewhere in all of this): I can't remember the Read-Only flip occurring in anything but large Word documents. The 1st one that happened over and over was 40 pages. Today, in a different document, it was 37 pages. It's possible that it's happened in smaller documents, but I can't say for sure at this point.

Microsoft recommends doing 2 things to fix this problem. They didn't work for me (or others) in the past, but that was before my update to SP-3. 1) Unchecking “Allow Background Saves” 2) Unchecking “Save Auto-Recover info”

Your thoughts on any of this?

#11
dencorso

dencorso

    Adiuvat plus qui nihil obstat

  • Super Moderator
  • 5,780 posts
  • OS:98SE
  • Country: Country Flag

Donator

Microsoft recommends doing 2 things to fix this problem. They didn't work for me (or others) in the past, but that was before my update to SP-3. 1) Unchecking “Allow Background Saves” 2) Unchecking “Save Auto-Recover info”

I'd start by trying (2) for one week (or until a read-only file appears, if sooner that one week). Then I'd add (1), and wait for another week (or until a read-only file appears, if sooner that one week). Then I'd remove (2), while leaving (1), for still another week (or until a read-only file appears, if sooner that one week). All this without Compatibility Mode. Just my 2¢. :)

Microsoft recommends doing 2 things to fix this problem.

Would you please point me to the KB articles?

#12
mitchsc

mitchsc

    Junior

  • Member
  • Pip
  • 73 posts
  • OS:Windows 7 x64
  • Country: Country Flag
Thanks for the suggestions. I'll try that sequence.

I cannot find any articles from Microsoft suggesting 1) Unchecking “Allow Background Saves” 2) Unchecking “Save Auto-Recover info” to solve the Read-Only problem. It may not have been KB articles. I seem to remember at least 2 forums where this was suggested by a Microsoft support engineer.

I know that people's personal experience and suggestions may not always be accurate, but here are 2 forums where several people have indicated these 2 changes to solve the Read-Only problem have worked for them.

http://help.lockergn...pict951118.html

(LOL: Now I can't find the 2nd forum, but you get the idea)

#13
GrofLuigi

GrofLuigi

    GroupPolicy Tattoo Artist

  • Member
  • PipPipPipPipPipPip
  • 1,352 posts
  • OS:none specified
  • Country: Country Flag
May be mentined before, but the first steps for troubleshooting Word are:

- deleting normal.dot (it will be recreated, you lose few settings)
- disabling addins
- checking the paths for templates, etc. in Options

GL

#14
mitchsc

mitchsc

    Junior

  • Member
  • Pip
  • 73 posts
  • OS:Windows 7 x64
  • Country: Country Flag
Thank you GL. Not mentioned previously.

I shall give it a try...

I have no add-ins.

Can you elaborate on "Checking the paths for template"?

Regarding Normal.dot
I cannot change my default formats the conventional way. I have to do it within the Normal.dot template. Is that any indication of a problem with that Template that could be related to the Read-Only issue? This is another Word issue that many people seem to have.
I know that deleting Normal.dot should create a new one upon reopening Word. Deleting this template won't affect any saved preexisting documents will it?

MSC

#15
dencorso

dencorso

    Adiuvat plus qui nihil obstat

  • Super Moderator
  • 5,780 posts
  • OS:98SE
  • Country: Country Flag

Donator

Instead of simply deleting it, copy Normal.dot to a completely unrelated folder... let's say: Create a folder in My Documents called "february". Make a copy of your current Normal.dot in that new folder. Then rename the copy of Normal.dot inside "february" to Normal_dot.ori. Now go back to the original location of Normal.dot and delete it. If anything goes wrong you can use the safety copy you created in the "february" folder to undo your changes.

#16
GrofLuigi

GrofLuigi

    GroupPolicy Tattoo Artist

  • Member
  • PipPipPipPipPipPip
  • 1,352 posts
  • OS:none specified
  • Country: Country Flag
Checking paths:

Posted Image

They are usually truncated, so you click 'modify' and navigate around to see where it is, but don't actually change the path. Afterwards, maybe, check with Windows Explorer or file manager what's going on there (permissions, read-only, etc.)

Also check addins:

Posted Image

Also, if you're not sure, don't change anything, just check if there is something out of ordinary there. Maybe post a screenshot.

GL

#17
GrofLuigi

GrofLuigi

    GroupPolicy Tattoo Artist

  • Member
  • PipPipPipPipPipPip
  • 1,352 posts
  • OS:none specified
  • Country: Country Flag

Deleting this template won't affect any saved preexisting documents will it?


No, it won't.

GL

#18
mitchsc

mitchsc

    Junior

  • Member
  • Pip
  • 73 posts
  • OS:Windows 7 x64
  • Country: Country Flag
Thank you all...

#19
mitchsc

mitchsc

    Junior

  • Member
  • Pip
  • 73 posts
  • OS:Windows 7 x64
  • Country: Country Flag
Hello all. It's been several weeks, and I have gone thru all possible recommendations to solve the Read-Only problem. The bad news: Nothing has completely "solved" the problem. The good news: updating Office 2003 to SP3 helped dramatically.

I've noticed that the larger the document, and the more Word docs I have open at the same time, the more likely the Read-Only problem will occur.

Here is some unexpected information that may be useful to others. Putting Word 2003 in Compatibility Mode - XP SP3, causes a bizarre problem. With multiple Word documents open at the same time, Saves gradually take longer and longer. I measured up to 6 seconds per save. Rebooting resets the delay. It seems to accumulate over 30-60 minutes of use. I would not recommend putting Word 2003 in Compatibility Mode - XP SP3. It had no positive effect whatsoever on the Read-Only problem.

Well, I seem to have run out of options to solve the Read-Only problem, so I guess I'll have to live with it until someone discovers a solution. Based on the forums I've read, this problem has been going on for years with every version of Word and Windows. People have been quite upset with Microsoft for not addressing it.

Thanks to all for your support and kind assistance...

MSC

#20
submix8c

submix8c

    Inconceivable!

  • Patrons
  • 4,186 posts
  • OS:none specified
  • Country: Country Flag
Using the setting I gave/use, I will have MANY "temporary" files in the folder in which a given DOC is opened in after a period of time and that's with JUST a relatively small file, making changes or NOT.

Bottom line, you are trying to do TOO MANY changes with TOO MANY files opened simultaneously. You're creating your own problem. ;)

Someday the tyrants will be unthroned... Jason "Jay" Chasteen; RIP, bro!

Posted Image


#21
mitchsc

mitchsc

    Junior

  • Member
  • Pip
  • 73 posts
  • OS:Windows 7 x64
  • Country: Country Flag
I see. I wasn't aware of that. So, if I understand you correctly, you're suggesting that I would be better off keeping open Word docs to a minimum, and closing them between uses to delete temp files?

There is one file I use constantly, all day long, and rarely close it during a given day. This is also the large file I was referring to. Perhaps opening, and closing it as needed would solve the Read-Only problem for me.

Thank you. This is excellent news!

#22
submix8c

submix8c

    Inconceivable!

  • Patrons
  • 4,186 posts
  • OS:none specified
  • Country: Country Flag
Very well could be. To demonstrate to yourself, create a dummy DOC file somewhere, key some text, copy/past the text, leave it opened for a few, copy/paste some more, then go to the Folder where you saved the DOC.

Take a look at this -
http://www.techtalkz...-wrl-files.html

When I first open a DOC there is a "beginning" file that has "~$" replacing the first two characters as a TEMP file.

Someday the tyrants will be unthroned... Jason "Jay" Chasteen; RIP, bro!

Posted Image


#23
mitchsc

mitchsc

    Junior

  • Member
  • Pip
  • 73 posts
  • OS:Windows 7 x64
  • Country: Country Flag
I shall check it out. Thanks...




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users



How to remove advertisement from MSFN