Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 



Sign in to follow this  
budgy

Preventing windows 7 entering in suspend while running WPI

Recommended Posts

budgy    0

Hi all, on my setup, windows 7 goes to suspend before WPI finishes installing all software packages, are there any builtin way in WPI to stop windows from suspend? or maybe some utility recommended? I prefer a way that not modify the system power options.

Regards.

Share this post


Link to post
Share on other sites

myselfidem    5

It seems for some reason your screensaver is activated during setup programs with WPI!

Do you use a tweak or a batch file for this setting after windows installation is done?

Share this post


Link to post
Share on other sites
budgy    0

It seems for some reason your screensaver is activated during setup programs with WPI!

Do you use a tweak or a batch file for this setting after windows installation is done?

WPI is launched from firstlogoncommands so the desktop is fully loaded, so the standard powersaving configuration is applied.

Its a standard W7 SP1 version, by default Win7 blank screen after 10 minutes and suspend after 30 minutes, some programs like filezilla disable suspend when doing transfers, I need a way to disable suspend while WPI is running.

Share this post


Link to post
Share on other sites
budgy    0
Archivo Log de instalación con WPI

Proceso de instalación iniciado en: sábado, 09 de febrero de 2013 11:53:44

Información de WPI:

Versión=8.6.3

Lanzador utilizado=true

Versión de Internet Explorer=8.0

Conexión a Internet=true

Sistema Operativo

Versión del Sistema Operativo=6.1

Sistema Operativo=Win7

Actual Build del Sistema Operativo=7601

Edición ID=Ultimate Edition

ServicePack=1

Arquitectura

Arquitectura=GenuineIntel

Cadena de Arquitectura=Intel® Core2 Duo CPU E8400 @ 3.00GHz

ID de Arquitectura=x86 Family 6 Model 23 Stepping 10

Número de Procesadores=1

MHz=2992

Tipo de Arquitectura=x86

Bits de Arquitectura=32

Archivo de Configuración=D:\WPI\UserFiles\config.js

Archivo de Opciones=D:\WPI\UserFiles\useroptions.js

Archivo de red=D:\WPI\UserFiles\networkoptions.js

Archivo del Tema=D:\WPI\UserFiles\themeoptions.js

Archivo de opciones de Windows=D:\WPI\UserFiles\windowoptions.js

// Window tab

Resolution=800

MainWindowWidth=800

MainWindowHeight=600

MainWindowX=-1

MainWindowY=-1

InstallerWindowX=500

InstallerWindowY=40

// General tab

NumCols=4

// ---

Timer=true

Seconds=60

StartBeepAtSecs=220

// ---

Language='es'

// ---

DefaultInstallPath='default'

CustomInstallPath=['']

// ---

AbortInstallIfFailure=false

ExecuteCommandIfFailure=['']

ContinueWhereFailed=false

// Features tab

ShowDownloadOutput=false

DisableInstallCombobox=false

ShowExtraButtons=true

DoNotShowIfCD=true

USSFSilentMode=false

VerifyInstallHDD=false

AllowCheckForInternet=false

LoadDesktopBeforeInstall=true

ReOpenAfterInstall=false

DisableCatCheckBoxes=false

SortWithinCats=false

DisableOnDepsNotMet=true

AlwaysUseScrollBar=true

DontSplitCats=true

InstallByCategory=true

ReallyForce=false

DisableIfDoGray=false

InstallFonts=false

ShowCommandInInstaller=true

ShowInstallerImages=false

AlwaysShowOutputWindow=true

EjectCDWhenDone=true

DoNotShowIfUSB=true

DisableHotKeys=false

MaintainAutoLogonCount=false

// Tools tab

MonitorResolution=0

MonitorDepth=0

MonitorRefresh=0

// ---

ExecuteBeforeEnabled=false

ExecuteBeforebit64=false

ExecuteBefore=['']

ExecuteAfterEnabled=true

ExecuteAfterbit64=false

ExecuteAfter=['winver.exe']

// ---

RestartComputer=false

RestartType=0

RestartSeconds=30

DoNotLoadDesktop=true

// ---

LogInstallation=true

LogPath=['"%systemRoot%\WPI.log"'];

TimeStampLogFile=true

// Audio tab

PlayAudioInInstaller=false

InstallAudio=['']

Volume=85

Shuffle=false

CopyAudioFolder=false

CopyAudioPath=['%systemdrive%\WPI_Audio']

DeleteAudioFolder=false

// Sounds tab

SndWPIStartCB=true

SndWPIStart=['"%wpipath%\Audio\SoundsScheme\Alert.wav"'];

SndInstallStartCB=false

SndInstallStart=['"%wpipath%\Audio\SoundsScheme\AtBeginning.wav"'];

SndInstallSuccessCB=false

SndInstallSuccess=['"%wpipath%\Audio\SoundsScheme\Yes.wav"'];

SndInstallFailCB=false

SndInstallFail=['"%wpipath%\Audio\SoundsScheme\No.wav"'];

SndInstallFinishCB=false

SndInstallFinish=['"%wpipath%\Audio\Galaga.mid"'];

// Style tab

Theme='Windows'

Skin='SkyBlue'

BgPicture=''

// ---

LayoutStyle=1

// ---

ShowToolTips=true

Variables globales:

%OSLANG%=ESN

%WPIPATH%=D:\WPI

%ROOT%=D:

%CDROM%=D:

%USB%=

%DOSPATH%=

%SYSTEMDRIVE%=C:

%WINDIR%=C:\Windows

%PROGRAMFILES%=C:\Program Files

%TEMP%=C:\Users\YO\AppData\Local\Temp

%SYSDIR%=C:\Windows\System32

%ALLUSERSPROFILE%=C:\ProgramData

%USERPROFILE%=C:\Users\YO

%APPDATA%=C:\Users\YO\AppData\Roaming

%COMMONPROGRAMFILES%=C:\Program Files\Common Files

I think there arent any problems in WPI, but the machine suspends before finished installing a large software collection.

Regards.

Share this post


Link to post
Share on other sites
myselfidem    5

Do you see some error codes inside WPI_Log.txt ?

Do you see history.js on your HDD ?

Change: StartBeepAtSecs=220 (to 10 for example)!

Edited by myselfidem

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×