rosawodsii

Windows 7 won't release Readyboost memory on flash drive

3 posts in this topic

I have a 16GB Datastick Pro flash drive that I hadn't been using, so decided to put it to work using Readyboost. I didn't see much improvement, so wanted to revert to using it for storage only. I opened Properties, told it not to use the device for Readyboost, hit Apply--and now the flash drive shows only 389 MB of free memory. It says it's not being using for Readyboost, but I can't use it for much of anything anymore on my laptop. Interestingly, on my desktop, which has XP, it sees it as an empty drive and I can copy files onto it with no problem However, the files I need to copy are on my laptop, not my desktop.

I was thinking of just reformatting it, but thought I'd see if anyone has another solution first.

In case there's no other solution, I will format the drive, but right now the FS properties say NTFS, and I've found information online that says flash drives should be reformatted to Fat32, so is Windows 7 not reading the stick correctly? And if I do have to format, would it be NTFS or Fat32? I've also read about "exFat", but don't see an option for that.

0

Share this post


Link to post
Share on other sites

I've never done that, since ReadyBoost ate all my USB drives (3) I've used on various computers. If you are using this key on multiple computers, I think FAT32 would give you the least amount of headaches.

0

Share this post


Link to post
Share on other sites

Last night I formated the drive to NTFS, which is what was on it to begin with. I now have full use of the drive, and you can be sure I won't be using ReadyBoost again. :)

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.