Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account



Photo

Deploying IE 10 for Windows 7


  • Please log in to reply
32 replies to this topic

#1
gotenks98

gotenks98

    Member

  • Member
  • PipPip
  • 162 posts
  • Joined 02-June 05
I just wanted to know has anyone successfully deployed windows 7 with IE 10 using MDT 2012 just using the cabs or msu files, not doing it post install. For IE 9 I can do this pretty easily but I just cant quite figure out why it does not want to install during the apply patches part of my task sequence.


How to remove advertisement from MSFN

#2
myselfidem

myselfidem

    Member

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,559 posts
  • Joined 06-January 10
  • OS:Windows 7 x64
  • Country: Country Flag
I do not use MDT!

But we need to install first prerequisite updates for Internet Explorer 10 :

Download Internet Explorer 10

http://support.micro...b/2770065/en-us

A platform update is available for Windows 7 SP1 and Windows Server 2008 R2 SP1

HTH

*Edit: How to know the updates needed?

1 - Download IE10 for your language

2 - Create a folder as C:\IE10

3 - Extract all files using Start | Run : C:\IE10-Windows6.1-x86-en-us.exe /X:C:\IE10

4 - You will find the file: SETUPDOWNLOADLIST.TXT with all information about updates needed

; The following are prerequisites for installing IE
[Prerequisites]
WIN7_SP1=KB2670838 KB2639308 KB2533623 KB2731771 KB2729094 KB2786081


Spoiler

Edited by myselfidem, 03 March 2013 - 03:09 AM.

For Windows 7 OS: SetProductKey.rar (fr-FR/en-US. Integrate keys).

#3
myselfidem

myselfidem

    Member

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,559 posts
  • Joined 06-January 10
  • OS:Windows 7 x64
  • Country: Country Flag
And to integrate IE10 on my Windows 7 SP1 image I use this command (adapt to your needs!):

Example for IE10 French!

IE10.cmd
@echo off & Color 1F
title Installation Internet Explorer 10
echo.
rem   Extraction de la version IE10 pour Windows 7 x86 choisie
rem   C:\IE10-Windows6.1-x86-fr-fr.exe /X:C:\IE10
rem   Créer un dossier temporaire: C:\work
rem   Sélectionner l'index correspondant à l'image 
echo.
"C:\Program Files\Windows AIK\Tools\x86\Servicing\Dism.exe" /Mount-Wim /Wimfile:"C:\Win7_SP1\sources\install.wim" /index:1 /MountDir:"C:\work"
ping /n 3 127.0.0.1 >nul
echo.
rem Installation des mises à jour requises
echo.
"C:\Program Files\Windows AIK\Tools\x86\Servicing\Dism.exe" /Image:"C:\work" /Add-Package /PackagePath:"C:\IE10\Windows6.1-KB2533623-x86.msu"
ping /n 3 127.0.0.1 >nul
echo.
"C:\Program Files\Windows AIK\Tools\x86\Servicing\Dism.exe" /Image:"C:\work" /Add-Package /PackagePath:"C:\IE10\Windows6.1-KB2670838-x86.msu"
ping /n 3 127.0.0.1 >nul
echo.
"C:\Program Files\Windows AIK\Tools\x86\Servicing\Dism.exe" /Image:"C:\work" /Add-Package /PackagePath:"C:\IE10\Windows6.1-KB2726535-x86.msu"
ping /n 3 127.0.0.1 >nul
echo.
"C:\Program Files\Windows AIK\Tools\x86\Servicing\Dism.exe" /Image:"C:\work" /Add-Package /PackagePath:"C:\IE10\Windows6.1-KB2729094-v2-x86.msu"
ping /n 3 127.0.0.1 >nul
echo.
"C:\Program Files\Windows AIK\Tools\x86\Servicing\Dism.exe" /Image:"C:\work" /Add-Package /PackagePath:"C:\IE10\Windows6.1-KB2731771-x86.msu"
ping /n 3 127.0.0.1 >nul
echo.
"C:\Program Files\Windows AIK\Tools\x86\Servicing\Dism.exe" /Image:"C:\work" /Add-Package /PackagePath:"C:\IE10\Windows6.1-KB2786081-x86.msu"
ping /n 3 127.0.0.1 >nul
echo.
rem Installation des fichiers pour IE10 qui ont été décompressés
echo.
"C:\Program Files\Windows AIK\Tools\x86\Servicing\Dism.exe" /Image:"C:\work" /Add-Package /PackagePath:"C:\IE10\IE10\IE-Win7.CAB"
ping /n 3 127.0.0.1 >nul
echo.
"C:\Program Files\Windows AIK\Tools\x86\Servicing\Dism.exe" /Image:"C:\work" /Add-Package /PackagePath:"C:\IE10\IE10\IE-Spelling-NEU.MSU"
ping /n 3 127.0.0.1 >nul
echo.
"C:\Program Files\Windows AIK\Tools\x86\Servicing\Dism.exe" /Image:"C:\work" /Add-Package /PackagePath:"C:\IE10\IE10\IE-Hyphenation-NEU.MSU"
ping /n 3 127.0.0.1 >nul
echo.
"C:\Program Files\Windows AIK\Tools\x86\Servicing\Dism.exe" /Image:"C:\work" /Add-Package /PackagePath:"C:\IE10\IE10\IE-Spelling-FRA.MSU"
ping /n 3 127.0.0.1 >nul
echo.
"C:\Program Files\Windows AIK\Tools\x86\Servicing\Dism.exe" /Image:"C:\work" /Add-Package /PackagePath:"C:\IE10\IE10\IE-Hyphenation-FRA.MSU"
ping /n 3 127.0.0.1 >nul
echo.
"C:\Program Files\Windows AIK\Tools\x86\Servicing\Dism.exe" /Image:"C:\work" /Add-Package /PackagePath:"C:\IE10\IE10\ielangpack-FRA.CAB"
ping /n 3 127.0.0.1 >nul
echo.
"C:\Program Files\Windows AIK\Tools\x86\Servicing\Dism.exe" /Unmount-Wim /MountDir:"C:\work" /Commit
echo.
pause 

Image IE10 integrated

Edited by myselfidem, 11 March 2013 - 12:58 PM.

For Windows 7 OS: SetProductKey.rar (fr-FR/en-US. Integrate keys).

#4
gotenks98

gotenks98

    Member

  • Member
  • PipPip
  • 162 posts
  • Joined 02-June 05
Thanks, I will give this a try when I return to work. This whole thing has been a pain trying to get it to work.

#5
myselfidem

myselfidem

    Member

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,559 posts
  • Joined 06-January 10
  • OS:Windows 7 x64
  • Country: Country Flag
You can try and adapt this batch file to suit your needs!

WAIK for Windows 7 must be installed on your computer!

Remember to download the prerequisite updates matching your Windows 7 Edition (x86 or x64)!

Example for Windows 7 SP1 x86 to integrate IE10 (en-us):

Windows6.1-KB2533623-x86.msu
Windows6.1-KB2670838-x86.msu
Windows6.1-KB2726535-x86.msu
Windows6.1-KB2729094-v2-x86.msu
Windows6.1-KB2731771-x86.msu
Windows6.1-KB2786081-x86.msu

Extracted files from IE10-Windows6.1-x86-en-us.exe:

IE-Win7.CAB
IE-Spelling-NEU.MSU
IE-Hyphenation-NEU.MSU

HTH

Edited by myselfidem, 11 March 2013 - 12:58 PM.

For Windows 7 OS: SetProductKey.rar (fr-FR/en-US. Integrate keys).

#6
bphlpt

bphlpt

    MSFN Addict

  • Member
  • PipPipPipPipPipPipPip
  • 1,828 posts
  • Joined 12-May 07
  • OS:none specified
  • Country: Country Flag
I wonder why the MSFN members who are MS employees that usually promote the use of MDT for deployment have not posted a solution to the OP's problem?

Cheers and Regards

Posted Image


#7
maxXPsoft

maxXPsoft

    MSFN Master

  • Developer
  • 2,889 posts
  • Joined 14-November 03
  • OS:Windows 7 x64
  • Country: Country Flag
well didn't know if Windows6.1-KB2786081-x64.msu would work since requires WGA but it seemed to. Guess I'd have to try an install
I had those seem to install but then it gets offered on WU after install until I go accept WGA

like this
Package D:\zPackage\Windows6.1-KB2533552-x86.msu may have failed due pending updates to servicing components
Download ++> Windows 7 + 8 Unattended DVD + App Installer + Services Disabler + Load All Button + XML Creator
Jump2Reg - Registry: - Oct 4, 2013 - Version 3.0.4 - 98, ME, NT, 2K, XP, VISTA, Seven, Windows 8+ and 32 or 64 bit

XP Unattended CD/DVD creator - Version 4.1.7
Sample xml + Setupcomplete + Add Right click .wim Windows 7 or Windows 8/8.1

#8
gotenks98

gotenks98

    Member

  • Member
  • PipPip
  • 162 posts
  • Joined 02-June 05
This whole thing has been a pain. I have tried suggestions in this thread as well as the other thread. It always errors out with windows could not configure one or more components. This is with just integrating it and installing normally and also integrating it and deploying with MDT. It just does not work. If I try to just deploy all of it the pre-reqs will install but no IE 10 but it does not error out. I tried using the pre-reqs in the document that's extracted and the pre-reqs listed online.

#9
maxXPsoft

maxXPsoft

    MSFN Master

  • Developer
  • 2,889 posts
  • Joined 14-November 03
  • OS:Windows 7 x64
  • Country: Country Flag
Installs for me this way on a running Win 7 via runoncex method so you could do a post install

REG ADD %KEY%\1001 /VE /D "Internet Explorer 10.0.9200.x x64" /f
REG ADD %KEY%\1001 /V 101 /D "CMD /C Start /Wait D:\APPS\IE10_X64\Windows6.1-KB2670838-x64.msu /quiet /norestart" /f
REG ADD %KEY%\1001 /V 102 /D "CMD /C Start /Wait D:\APPS\IE10_X64\Windows6.1-KB2533623-x64.msu /quiet /norestart" /f
REG ADD %KEY%\1001 /V 103 /D "CMD /C Start /Wait D:\APPS\IE10_X64\Windows6.1-KB2731771-x64.msu /quiet /norestart" /f
REG ADD %KEY%\1001 /V 104 /D "CMD /C Start /Wait D:\APPS\IE10_X64\Windows6.1-KB2729094-v2-x64.msu /quiet /norestart" /f
REG ADD %KEY%\1001 /V 105 /D "CMD /C Start /Wait D:\APPS\IE10_X64\Windows6.1-KB2786081-x64.msu /quiet /norestart" /f
REG ADD %KEY%\1001 /V 106 /D "CMD /C Start /Wait D:\APPS\IE10_X64\IE10-Windows6.1-x64-en-us.exe /passive /update-no /closeprograms /norestart" /f
REG ADD %KEY%\1001 /V 107 /D "CMD /C DEL \"%USERPROFILE%\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\Launch Internet Explorer Browser.lnk\"" /f
REG ADD %KEY%\1001 /V 108 /D "REGEDIT /S D:\APPS\IE10_X64\Disable_IE10_Auto_Update.reg" /f

Edited by maxXPsoft, 01 March 2013 - 06:30 PM.

Download ++> Windows 7 + 8 Unattended DVD + App Installer + Services Disabler + Load All Button + XML Creator
Jump2Reg - Registry: - Oct 4, 2013 - Version 3.0.4 - 98, ME, NT, 2K, XP, VISTA, Seven, Windows 8+ and 32 or 64 bit

XP Unattended CD/DVD creator - Version 4.1.7
Sample xml + Setupcomplete + Add Right click .wim Windows 7 or Windows 8/8.1

#10
gotenks98

gotenks98

    Member

  • Member
  • PipPip
  • 162 posts
  • Joined 02-June 05

Installs for me this way on a running Win 7 via runoncex method so you could do a post install

REG ADD %KEY%\1001 /VE /D "Internet Explorer 10.0.9200.x x64" /f
REG ADD %KEY%\1001 /V 101 /D "CMD /C Start /Wait D:\APPS\IE10_X64\Windows6.1-KB2670838-x64.msu /quiet /norestart" /f
REG ADD %KEY%\1001 /V 102 /D "CMD /C Start /Wait D:\APPS\IE10_X64\Windows6.1-KB2533623-x64.msu /quiet /norestart" /f
REG ADD %KEY%\1001 /V 103 /D "CMD /C Start /Wait D:\APPS\IE10_X64\Windows6.1-KB2731771-x64.msu /quiet /norestart" /f
REG ADD %KEY%\1001 /V 104 /D "CMD /C Start /Wait D:\APPS\IE10_X64\Windows6.1-KB2729094-v2-x64.msu /quiet /norestart" /f
REG ADD %KEY%\1001 /V 105 /D "CMD /C Start /Wait D:\APPS\IE10_X64\Windows6.1-KB2786081-x64.msu /quiet /norestart" /f
REG ADD %KEY%\1001 /V 106 /D "CMD /C Start /Wait D:\APPS\IE10_X64\IE10-Windows6.1-x64-en-us.exe /passive /update-no /closeprograms /norestart" /f
REG ADD %KEY%\1001 /V 107 /D "CMD /C DEL \"%USERPROFILE%\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\Launch Internet Explorer Browser.lnk\"" /f
REG ADD %KEY%\1001 /V 108 /D "REGEDIT /S D:\APPS\IE10_X64\Disable_IE10_Auto_Update.reg" /f

This kind of defeats the purpose of what I am trying to do. I am hoping to deploy it so that when the later updates come I can just add them to the folder just like I did with IE9 and MDT would just work. It is not working at all for ie10

#11
maxXPsoft

maxXPsoft

    MSFN Master

  • Developer
  • 2,889 posts
  • Joined 14-November 03
  • OS:Windows 7 x64
  • Country: Country Flag
I said that was alternative.

I injected like myselfidem showed above

EDIT: Tested in VM and went to windows updates with IE10 installed and this was only ones listed
MDT is probably not updated to handle IE10 and don't wait on an update either since MS is pushing Win 8 mess now. You can do either of the above as a get around or hold your breath

Attached File  IE10injected.png   17.99KB   29 downloads

Edited by maxXPsoft, 02 March 2013 - 12:14 AM.

Download ++> Windows 7 + 8 Unattended DVD + App Installer + Services Disabler + Load All Button + XML Creator
Jump2Reg - Registry: - Oct 4, 2013 - Version 3.0.4 - 98, ME, NT, 2K, XP, VISTA, Seven, Windows 8+ and 32 or 64 bit

XP Unattended CD/DVD creator - Version 4.1.7
Sample xml + Setupcomplete + Add Right click .wim Windows 7 or Windows 8/8.1

#12
myselfidem

myselfidem

    Member

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,559 posts
  • Joined 06-January 10
  • OS:Windows 7 x64
  • Country: Country Flag

This whole thing has been a pain. I have tried suggestions in this thread as well as the other thread. It always errors out with windows could not configure one or more components. This is with just integrating it and installing normally and also integrating it and deploying with MDT. It just does not work. If I try to just deploy all of it the pre-reqs will install but no IE 10 but it does not error out. I tried using the pre-reqs in the document that's extracted and the pre-reqs listed online.


Information on TechNet:

Installing Internet Explorer 10

Internet Explorer 10:

Appendix A: Troubleshooting

*Edit:

You can try first to integrate IE10 and after use MDT with your new image !

Microsoft Deployment Toolkit (MDT) 2012 Update 1

And do not try to integrate Windows6.1-KB2718695-x64.cab or Windows6.1-KB2718695-x86.cab: gives error !

Edited by myselfidem, 02 March 2013 - 07:31 AM.

For Windows 7 OS: SetProductKey.rar (fr-FR/en-US. Integrate keys).

#13
jinkazama

jinkazama

    Member

  • Member
  • PipPip
  • 202 posts
  • Joined 16-November 03
  • OS:Windows 8 x64
  • Country: Country Flag
Disable_IE10_Auto_Update.reg
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main]
"EnableAutoUpgrade"=dword:00000000

is right?

ubrezet.png
userbardriverpackteam3nv0.jpg


#14
maxXPsoft

maxXPsoft

    MSFN Master

  • Developer
  • 2,889 posts
  • Joined 14-November 03
  • OS:Windows 7 x64
  • Country: Country Flag

Disable_IE10_Auto_Update.reg

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main]
"EnableAutoUpgrade"=dword:00000000

is right?

Yes that disables this
Attached File  IE10auto.png   8.06KB   12 downloads
Download ++> Windows 7 + 8 Unattended DVD + App Installer + Services Disabler + Load All Button + XML Creator
Jump2Reg - Registry: - Oct 4, 2013 - Version 3.0.4 - 98, ME, NT, 2K, XP, VISTA, Seven, Windows 8+ and 32 or 64 bit

XP Unattended CD/DVD creator - Version 4.1.7
Sample xml + Setupcomplete + Add Right click .wim Windows 7 or Windows 8/8.1

#15
gotenks98

gotenks98

    Member

  • Member
  • PipPip
  • 162 posts
  • Joined 02-June 05
Question for those who got this working what did you do for testing? Like did you use a VM or real machine. I am currently using virtualbox in testing this and its still not working. I have verified the image I have is good, I redownloaded the msu and exe from microsoft's site directly. I integrated using the Windows ADK using the exact same dism code. So this makes me think something else is causing this and not what I am doing. I am going to try this with VM ware next to see if it works.

Nevermind scratch this, still does not work in VM ware.

Edited by gotenks98, 04 March 2013 - 01:12 PM.


#16
myselfidem

myselfidem

    Member

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,559 posts
  • Joined 06-January 10
  • OS:Windows 7 x64
  • Country: Country Flag
Sure you made something wrong!

*Edit: look at your dism.log file to find errors!

Edited by myselfidem, 04 March 2013 - 01:58 PM.

For Windows 7 OS: SetProductKey.rar (fr-FR/en-US. Integrate keys).

#17
maxXPsoft

maxXPsoft

    MSFN Master

  • Developer
  • 2,889 posts
  • Joined 14-November 03
  • OS:Windows 7 x64
  • Country: Country Flag
I manually mount the image with my right click .wim http://www.msfn.org/...-wim-windows-7/
I then ran a small .cmd file with all the updates and the IE10-Windows6.1-x64-en-us.exe in same folder
I pause each step to watch the results
cd %~dp0
IE10-Windows6.1-x64-en-us.exe /x:%~dp0\IE10SLIP
pause
Dism.exe /image:D:\zMountdir /Add-Package /PackagePath:%~dp0
pause
Dism /Image:D:\zMountdir /Add-Package /PackagePath:%~dp0IE10SLIP\IE-Win7.CAB
Dism /Image:D:\zMountdir /Add-Package /PackagePath:%~dp0IE10SLIP\IE-Spelling-NEU.MSU
Dism /Image:D:\zMountdir /Add-Package /PackagePath:%~dp0IE10SLIP\IE-Hyphenation-NEU.MSU
pause
exit
Dismount image saving
Then installed using VMware Workstation
Image above where I showed turning off that update was from there
Download ++> Windows 7 + 8 Unattended DVD + App Installer + Services Disabler + Load All Button + XML Creator
Jump2Reg - Registry: - Oct 4, 2013 - Version 3.0.4 - 98, ME, NT, 2K, XP, VISTA, Seven, Windows 8+ and 32 or 64 bit

XP Unattended CD/DVD creator - Version 4.1.7
Sample xml + Setupcomplete + Add Right click .wim Windows 7 or Windows 8/8.1

#18
gotenks98

gotenks98

    Member

  • Member
  • PipPip
  • 162 posts
  • Joined 02-June 05
I figured it out. The issue is 2 things. One machine integrated from gave me a different error than my windows 8 machine. If I do it from the windows 8 machine it actually gave me an error I could look into using the log files. It ended up being one of the settings in the unattend.xml file that's depreciated. The problem is I never changed that setting it comes default in the answer file. So I had to delete the internet explorer section of the unattended file and re-add it after I updated the catalog file to show IE10. Once I did this it worked using MDT 2012. This problem could have been easier to figure out had I started the integration from the Windows 8 machine. My thoughts are that there is a bug in the Windows ADK that if you do integration from windows 7 it does it differently than windows 8. I got all kinds of weird errors doing this differently on Windows 7.

#19
Tripredacus

Tripredacus

    K-Mart-ian Legend

  • Super Moderator
  • 10,022 posts
  • Joined 28-April 06
  • OS:Server 2012
  • Country: Country Flag

Donator

Installs for me this way on a running Win 7 via runoncex method so you could do a post install

REG ADD %KEY%\1001 /VE /D "Internet Explorer 10.0.9200.x x64" /f
REG ADD %KEY%\1001 /V 101 /D "CMD /C Start /Wait D:\APPS\IE10_X64\Windows6.1-KB2670838-x64.msu /quiet /norestart" /f
REG ADD %KEY%\1001 /V 102 /D "CMD /C Start /Wait D:\APPS\IE10_X64\Windows6.1-KB2533623-x64.msu /quiet /norestart" /f
REG ADD %KEY%\1001 /V 103 /D "CMD /C Start /Wait D:\APPS\IE10_X64\Windows6.1-KB2731771-x64.msu /quiet /norestart" /f
REG ADD %KEY%\1001 /V 104 /D "CMD /C Start /Wait D:\APPS\IE10_X64\Windows6.1-KB2729094-v2-x64.msu /quiet /norestart" /f
REG ADD %KEY%\1001 /V 105 /D "CMD /C Start /Wait D:\APPS\IE10_X64\Windows6.1-KB2786081-x64.msu /quiet /norestart" /f
REG ADD %KEY%\1001 /V 106 /D "CMD /C Start /Wait D:\APPS\IE10_X64\IE10-Windows6.1-x64-en-us.exe /passive /update-no /closeprograms /norestart" /f
REG ADD %KEY%\1001 /V 107 /D "CMD /C DEL \"%USERPROFILE%\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\Launch Internet Explorer Browser.lnk\"" /f
REG ADD %KEY%\1001 /V 108 /D "REGEDIT /S D:\APPS\IE10_X64\Disable_IE10_Auto_Update.reg" /f


This is working for me but there is one problem. After it kills reloads explorer.exe, IE10 then opens and shows the first-run wizard. Is there any other way to install IE10 where it won't open after install?
MSFN RULES | GimageX HTA for PE 3-5 | lol probloms
tpxmsfn1_zps393339c1.jpg

#20
maxXPsoft

maxXPsoft

    MSFN Master

  • Developer
  • 2,889 posts
  • Joined 14-November 03
  • OS:Windows 7 x64
  • Country: Country Flag
REG ADD %KEY%\1001 /VE /D "Internet Explorer 10.0.9200.x x64" /f

is what I used on a running system
If used in an unattend with xml disabling first run and welcome page it might work

I'll have to start over with my image since I injected IE10 as a test
Download ++> Windows 7 + 8 Unattended DVD + App Installer + Services Disabler + Load All Button + XML Creator
Jump2Reg - Registry: - Oct 4, 2013 - Version 3.0.4 - 98, ME, NT, 2K, XP, VISTA, Seven, Windows 8+ and 32 or 64 bit

XP Unattended CD/DVD creator - Version 4.1.7
Sample xml + Setupcomplete + Add Right click .wim Windows 7 or Windows 8/8.1

#21
Tripredacus

Tripredacus

    K-Mart-ian Legend

  • Super Moderator
  • 10,022 posts
  • Joined 28-April 06
  • OS:Server 2012
  • Country: Country Flag

Donator

Can't disable the first run wizard... so that is out. I have sent this problem along to MS, waiting for an answer. I have a sneaking suspicion that the answer will be to inject it into the image... :rolleyes:
MSFN RULES | GimageX HTA for PE 3-5 | lol probloms
tpxmsfn1_zps393339c1.jpg

#22
Rico.JohnnY

Rico.JohnnY

    Member

  • Member
  • PipPip
  • 246 posts
  • Joined 02-June 04
  • OS:Windows 7 x64
  • Country: Country Flag
This tweak works fine for me

;IE10 - Disable first run wizard: 1 to homepage, 2 to welcome page, to enable just to remove the value
[HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Main]
"DisableFirstRunCustomize"=dword:00000001
[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Internet Explorer\Main]
"DisableFirstRunCustomize"=-
[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Policies\Microsoft\Internet Explorer\Main]
"DisableFirstRunCustomize"=-


#23
maxXPsoft

maxXPsoft

    MSFN Master

  • Developer
  • 2,889 posts
  • Joined 14-November 03
  • OS:Windows 7 x64
  • Country: Country Flag
An install with IE10 injected and xml disabling those things writes to the reg here. Most things related in xml will be written here

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\UnattendBackup\ActiveSetup\DisableFirstRunWizard]
"DisableFirstRunWizard"=dword:00000001

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\UnattendBackup\ActiveSetup\DisableWelcomePage]
"DisableWelcomePage"=dword:00000001
Download ++> Windows 7 + 8 Unattended DVD + App Installer + Services Disabler + Load All Button + XML Creator
Jump2Reg - Registry: - Oct 4, 2013 - Version 3.0.4 - 98, ME, NT, 2K, XP, VISTA, Seven, Windows 8+ and 32 or 64 bit

XP Unattended CD/DVD creator - Version 4.1.7
Sample xml + Setupcomplete + Add Right click .wim Windows 7 or Windows 8/8.1

#24
Domain

Domain
  • Member
  • 8 posts
  • Joined 14-June 05
Hmm, good information, fully tested and working here now.

I don't bother with applying every single patch individually, based my testing only order required is to make sure prerequisites are handled first (otherwise it will fail during IE 10 steps), then Internet Explorer 10, then Hyphenation/Spelling, followed by everything else. My base image is now 6 packages (prerequisites), IE 10, 62 critical, and 31 optional updates to get a Windows 7 image requiring no Windows update patches (not counting KB2533552 and Malicious Software Removal Tool)

dism /Image:.\mount /Add-Package /PackagePath:.\updates\prereq
dism /Image:.\mount /Add-Package /PackagePath:.\updates\ie10\IE-Win7.CAB
dism /Image:.\mount /Add-Package /PackagePath:.\updates\ie10\IE-Hyphenation-NEU.MSU
dism /Image:.\mount /Add-Package /PackagePath:.\updates\ie10\IE-Spelling-NEU.MSU
dism /Image:.\mount /Add-Package /PackagePath:.\updates\crit
dism /Image:.\mount /Add-Package /PackagePath:.\updates\opt

As for welcome screen/first run, this is working fine (as it has since GA release for IE8/IE9/IE10)

<settings pass="specialize">
        <component name="Microsoft-Windows-IE-InternetExplorer" processorArchitecture="amd64">
            <DisableFirstRunWizard>true</DisableFirstRunWizard>
            <Home_Page>about:blank</Home_Page>
</settings>


#25
gotenks98

gotenks98

    Member

  • Member
  • PipPip
  • 162 posts
  • Joined 02-June 05

Hmm, good information, fully tested and working here now.

I don't bother with applying every single patch individually, based my testing only order required is to make sure prerequisites are handled first (otherwise it will fail during IE 10 steps), then Internet Explorer 10, then Hyphenation/Spelling, followed by everything else. My base image is now 6 packages (prerequisites), IE 10, 62 critical, and 31 optional updates to get a Windows 7 image requiring no Windows update patches (not counting KB2533552 and Malicious Software Removal Tool)

dism /Image:.\mount /Add-Package /PackagePath:.\updates\prereq
dism /Image:.\mount /Add-Package /PackagePath:.\updates\ie10\IE-Win7.CAB
dism /Image:.\mount /Add-Package /PackagePath:.\updates\ie10\IE-Hyphenation-NEU.MSU
dism /Image:.\mount /Add-Package /PackagePath:.\updates\ie10\IE-Spelling-NEU.MSU
dism /Image:.\mount /Add-Package /PackagePath:.\updates\crit
dism /Image:.\mount /Add-Package /PackagePath:.\updates\opt

As for welcome screen/first run, this is working fine (as it has since GA release for IE8/IE9/IE10)

<settings pass="specialize">
        <component name="Microsoft-Windows-IE-InternetExplorer" processorArchitecture="amd64">
            <DisableFirstRunWizard>true</DisableFirstRunWizard>
            <Home_Page>about:blank</Home_Page>
</settings>

This is what I am trying to do but I keep getting failures on the updates when it gets like 30+ updates in. It keeps saying the image is no longer serviceable. I have to basically start over if I get this.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users