Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account


Photo

Windows 7x64 slow to shutdown


  • Please log in to reply
9 replies to this topic

#1
Jez

Jez
  • Member
  • 6 posts
  • OS:Windows 7 x64
  • Country: Country Flag
For past 3 months my PC shuts down very slowly - up to 15mins.
All clean boot tests etc are not solving it as yet.
I have also tested with all devices disconnected + antivirus and acronis turned off.
However when in SAFE mode it shutsdown normally - everthing works fine and fast.
My PC is not old an has Windows experience of 7.4.
I have recorded a trace for shutdown. However I dont know what I am looking at.

The link to the etl files for shutdown trace are in skydrive:
http://sdrv.ms/WxHWcK

Can anyone help if you have time please...I am at a real loss as to how this can be fixed?

Thanks in advance.

J


How to remove advertisement from MSFN

#2
MagicAndre1981

MagicAndre1981

    after Windows 7 GA still Vista lover :)

  • Patrons
  • 5,952 posts
  • OS:Vista Ultimate x86
  • Country: Country Flag

Donator

the log is incomplete. It only completes the 2 temporary files. Have you interrupted the shutdown?
Posted Image

#3
Jez

Jez
  • Member
  • 6 posts
  • OS:Windows 7 x64
  • Country: Country Flag
No that is all that is recorded.
I have done it twice now and I always get the following files. Nil other.

shutdown_BASE+CSWITCH+DRIVERS+POWER_1_km_premerge (720Mb)
shutdown_BASE+CSWITCH+DRIVERS+POWER_1_um_premerge (7Mb)
xbootmgr

My screens stays on shutting down for a long time before it shuts down.

I used this command to run the shutdown trace...
xbootmgr -trace shutdown -noPrepReboot -traceFlags BASE+CSWITCH+DRIVERS+POWER -resultPath C:\TEMP

Here is a link to a trace done before the one you have already seen. Not sure if it adds any more information...

http://sdrv.ms/15RdWPM

Let me know if you want me to try it again....

Thanks....

Edited by Jez, 02 March 2013 - 07:30 AM.


#4
MagicAndre1981

MagicAndre1981

    after Windows 7 GA still Vista lover :)

  • Patrons
  • 5,952 posts
  • OS:Vista Ultimate x86
  • Country: Country Flag

Donator

that are only the temporary files.

Run this

xbootmgr -trace shutdown -noPrepReboot -traceFlags BASE+CSWITCH -resultPath C:\TEMP

Posted Image

#5
Jez

Jez
  • Member
  • 6 posts
  • OS:Windows 7 x64
  • Country: Country Flag
I ran that command as suggested..........here is the link....thanks

It appeared to get both now....

http://sdrv.ms/WzSjNc

Edited by Jez, 02 March 2013 - 07:42 PM.


#6
MagicAndre1981

MagicAndre1981

    after Windows 7 GA still Vista lover :)

  • Patrons
  • 5,952 posts
  • OS:Vista Ultimate x86
  • Country: Country Flag

Donator

you still only get the temporary files :blink:

Do a CleanBoot and try to eliminate all 3rd party tools until you can shutdown faster:

https://support.micr...kb/929135/en-us
Posted Image

#7
Jez

Jez
  • Member
  • 6 posts
  • OS:Windows 7 x64
  • Country: Country Flag
That is the problem unfortunatley. I am in a catch 22.
I have tried clean boot many times in the past and have even disabled all the MS items and tried th shutdown.

Have tried safe mode with all services and startup items off - this included all the MS services. This did not speed the shutdown at all. Still took a long time.
I have booted up with minimal items on and I cant get a full trace for you to look at either.

I am at a real loss and have run out of ideas....

Not sure what to do from here.

Edited by Jez, 03 March 2013 - 06:52 AM.


#8
Jez

Jez
  • Member
  • 6 posts
  • OS:Windows 7 x64
  • Country: Country Flag
I checked the perfomance event viewer and here is an excerpt from the log...
The shutdown time is very long.
Does this help??

ShutdownTsVersion 1
ShutdownStartTime 2013-02-25T 10:12:35.379690700Z
ShutdownEndTime 2013-02-25T 10:29:40.514286500Z
ShutdownTime 1025134
ShutdownUserSessionTime 3261
ShutdownUserPolicyTime 0
ShutdownUserProfilesTime 153
ShutdownSystemSessionsTime 7143
ShutdownPreShutdownNotificationsTime 1961
ShutdownServicesTime 4999
ShutdownKernelTime 1014729
ShutdownRootCauseStepImprovementBits 0
ShutdownRootCauseGradualImprovementBits 0
ShutdownRootCauseStepDegradationBits 0
ShutdownRootCauseGradualDegradationBits 0
ShutdownIsDegradation false
ShutdownTimeChange 0

#9
Jez

Jez
  • Member
  • 6 posts
  • OS:Windows 7 x64
  • Country: Country Flag
Solved!
I disabled Clear virtual memory pagefile and it worked...........what a relief.
Here is the excellent link that assisted in solving this...

http://www.vistax64....r-shutdown.html

Through the Local Security Policy

1. Open the Local Security Policy.

2. In the left pane, click on to expand Local Policies and User Rights Assignment, then open Security Settings. (See screenshot below)
secpol-1.jpg
3. In the right pane, right click on Shutdown: Clear virtual memory pagefile and click on Properties.

4. To Enable Clear Paging File at Shutdown
A) Select (dot) Enabled and click on OK. (See screenshot below step 5A)

B) Go to step 6.
5. To Disable Clear Paging File at Shutdown
NOTE: This is the default setting.
A) Select (dot) Disabled and click on OK.
properties.jpg
6. Close Local Group Policy Editor window. Your done.

7. If you enabled this setting, then restart or shutdown the computer to clear the Virtual Memory Paging File.






OPTION THREE
Manually Using Registry Editor

1. Open the Start Menu, then type regedit in the search box and press Enter.
2. If prompted by UAC, then click on the Continue (Vista) or Yes (Windows 7).

4. In regedit, navigate to the location below. (See screenshot below)
Code:


HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

reg_disabled.jpg
5. To Enable Clear Paging File at Shutdown
A) In the right pane, right click on ClearPageFileAtShutdown and click on Modify. (See screenshot above)

B) Type 1 and click on OK. (See screenshot below)
modify_enabled.jpg
C) The registry will now look like this. (See screenshot below)
reg_enabled.jpg
E) Go to step 7.
6. To Disable Clear Paging File at Shutdown
NOTE: This is the default setting.
A) In the right pane, right click on ClearPageFileAtShutdown and click on Modify. (See screenshot above)

B) Type 0 (number zero) and click on OK. (See screenshot below)
modify_disabled.jpg
C) The registry will now look like this. (See screenshot below step 4)
7. Close regedit.

8. If you enabled this setting, then restart or shutdown the computer to clear the Virtual Memory Paging File.
That's it,
Shawn






Published by

Brink's Avatar
Brink
Administrator

Join Date: Apr 2007
Location: Texas, USA
Posts: 30,398
Array

Tutorial Tools
Printable Version Printable Version
Email this Page Email this Page

Applies to
All Vista Versions
64 Bit & 32 Bit

#10
MagicAndre1981

MagicAndre1981

    after Windows 7 GA still Vista lover :)

  • Patrons
  • 5,952 posts
  • OS:Vista Ultimate x86
  • Country: Country Flag

Donator

Nice to hear that you fixed it :)

yes, long kernel shutdown times can be caused by overriding the pagefile.

Edited by MagicAndre1981, 05 March 2013 - 10:40 AM.

Posted Image




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users



How to remove advertisement from MSFN