Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account


Photo

Can't get TFTP Functioning Properly


  • Please log in to reply
4 replies to this topic

#1
hughsprout

hughsprout
  • Member
  • 2 posts
  • OS:none specified
  • Country: Country Flag
Hi,

I have brandnew box with Windows Server 2008 R2. I'm having issues getting TFTP clients to load from it correctly. DHCP is on the same server with the following options set in the scope:

043 Vendor Specific
060 PXEClient
066 Boot Server Name
067 Boot File Name

DHCP seems to be working fine. I see the PXE Client get an IP, Default Gatway and PXE Boot File name. When it attempts to download the file the following error message appears PXE-E79: NBP is too big to fit in free base memory" So far I have tried three different servers:

-TFTPD
-SolarWinds
-WinAgents

All produce the same results. Firewall is off and I have nothing else on the switch except the two machines. The server doesn't have the WDS role installed. I have tried various PXE boot files which I know are working on other deployements.

Anyone have any ideas.

Thanks


How to remove advertisement from MSFN

#2
Tripredacus

Tripredacus

    K-Mart-ian Legend

  • Super Moderator
  • 9,758 posts
  • OS:Server 2012
  • Country: Country Flag

Donator

What exactly do you have set for option 67?
MSFN RULES | GimageX HTA for PE 3-5 | lol probloms
msfn2_zpsc37c7153.jpg

#3
submix8c

submix8c

    Inconceivable!

  • Patrons
  • 4,251 posts
  • OS:none specified
  • Country: Country Flag
???

Have NEVER done this (yet...) but I think Tripredacus may be onto something -
http://qa.social.tec...6a-fe17ce91b8cf

You can't load a full-blown Boot Image - it has to have a "loader" (?) that in turn loads the Image.

Found via Google
"PXE-E79: NBP is too big to fit in free base memory" dhcp windows
and appears to work the same way if loading a Linux Image - must use a "loader" to load the Image.

Someday the tyrants will be unthroned... Jason "Jay" Chasteen; RIP, bro!

Posted Image


#4
hughsprout

hughsprout
  • Member
  • 2 posts
  • OS:none specified
  • Country: Country Flag
Thanks for the reply. I decide to go back to basics and did the following:

- New NIC
- Loaded TFTPD64
- Used its own internal DHCP server
- Had my menu file pointed at my PXE boot image

This time the results were slightly different. I looked like the workstation tried to execute the menu file but then produced the follwing error "mba api not found"

Now, I've been using a PXE builder tool from EMBOOT for about 10 years now. Its version 1.20. I'm wondering if its just too old support execution from a server 2008 and also given its a 64bit o/s. Does anybody know a suitable alternative I could test.
I'm basically just imaging DOS FDD's that contain network boot code.

Thanks

#5
Tripredacus

Tripredacus

    K-Mart-ian Legend

  • Super Moderator
  • 9,758 posts
  • OS:Server 2012
  • Country: Country Flag

Donator

I think the easiest would be to just add the WDS role. You can even boot syslinux from it if that is your concern. I have used this tutorial (at least up to part 2) on Server 2008 R2:
http://www.deployvis...US/Default.aspx
MSFN RULES | GimageX HTA for PE 3-5 | lol probloms
msfn2_zpsc37c7153.jpg




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users



How to remove advertisement from MSFN