Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account



Photo

Which files to manually edit to change keyboard layout to "US"

- - - - -

  • Please log in to reply
6 replies to this topic

#1
leogets

leogets
  • Member
  • 7 posts
  • Joined 05-July 08
Hello,
I used nlite v1.4.7 some time ago to make an xp cd. However, somehow the keyboard layout is set to "United States-International" Hence '2409' but prior it use to be set to "1009".
The US keyboard layout is "0409" but which files would I have to edit (make the changes to) in order for the keyboard layout to show up in the end as "US" / "0409"

In the files Last Session..., WINNT.SIFand HIVESYS.INF not sure of other files .... some sort of suspession that either all or some of these files would have to be edited in order to reflect the changes needed.

could someone please help and point me in the right direction.

Thanks


How to remove advertisement from MSFN

#2
Ponch

Ponch

    MSFN Junkie

  • Patrons
  • 3,305 posts
  • Joined 23-November 05
  • OS:none specified
  • Country: Country Flag
You're sure you want to make a cd and reinstall just for that instead of changing this in the registry or create a reg file ?
Why would you edit Last Session manually if you intend to run nlite with it anyway and so get the GUI?

#3
myselfidem

myselfidem

    Member

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,559 posts
  • Joined 06-January 10
  • OS:Windows 7 x64
  • Country: Country Flag
Hard job...But you can try to edit:

1 - WINNT.SIF:

Section: (example)

[RegionalSettings]
LanguageGroup=1
Language="040c"
SystemLocale="040c"
UserLocale="100c"
UserLocale_DefaultUser="100c"
InputLocale="100c:0000100c"
InputLocale_DefaultUser="100c:0000100c"

2 - Expand NLITE.IN_

Look at the end file section [CT]:
[CT]
HKCU,"Control Panel\International\Geo","Nation",0x00000000,"84"

Change the value to suit your needs (United States= 244)

Microsoft Geographical Location Values

3 - Using Makecab

4 - Create your iso file!

5 - You can also add a reg file inside $OEM$ (adapt to your needs!)

regional.reg
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Control Panel\International\Geo]
"Nation"="84"

[HKEY_CURRENT_USER\Keyboard Layout\Preload]
"2"="00000409"
"3"="0000040c"
"1"="0000100c"

[HKEY_CURRENT_USER\Keyboard Layout\Toggle]
"Hotkey"="1"
"Language Hotkey"="1"
"Layout Hotkey"="2"

And add inside cmdlines.txt
[Commands]
"rundll32 advpack.dll,LaunchINFSection nLite.inf,U"
"regedit /s regional.reg"
"rundll32 setupapi,InstallHinfSection DefaultInstall 128 .\ramdrv.INF"
"hidecon.exe /w i386.bat"
"RunWPI.exe"

Tip:

Expand_Makecab.reg
Windows Registry Editor Version 5.00

; rightclick Expand-Makecab
[HKEY_CLASSES_ROOT\*\shell\Expand\command]
@="expand -r \"%1\""

[HKEY_CLASSES_ROOT\*\shell\MakeCab\command]
@="\"makecab.exe\" \"%1\""

Edited by myselfidem, 09 March 2013 - 07:16 AM.

For Windows 7 OS: SetProductKey.rar (fr-FR/en-US. Integrate keys).

#4
leogets

leogets
  • Member
  • 7 posts
  • Joined 05-July 08
Thank you myselfidem for all your help. Already been using a reg file that I fire up just after XP installs to fix the keyboard issue, but I'd prefer to edit some files manually to fix the issue for good instead.
I just have to edit the WINNT.SIF and the NLITE.IN_ (NLITE.INI)....Thanks


The reg file I've been using doesn't icorperate these lines
[HKEY_CURRENT_USER\Control Panel\International\Geo]
"Nation"="84"
but it still seems to work. I have "Nation"="39" not too sure if this is correct or not for my reg file looks like:
REGEDIT4

; Fix Keyboard Layout for US instead of US-International
[HKEY_CURRENT_USER\Keyboard Layout]

[HKEY_CURRENT_USER\Keyboard Layout\IMEtoggle]

[HKEY_CURRENT_USER\Keyboard Layout\IMEtoggle\scancode]

[HKEY_CURRENT_USER\Keyboard Layout\Preload]
"1"="00000409"

[HKEY_CURRENT_USER\Keyboard Layout\Substitutes]

[HKEY_CURRENT_USER\Keyboard Layout\Toggle]
"Hotkey"="3"
"Language Hotkey"="3"
"Layout Hotkey"="3"

[HKEY_USERS\.DEFAULT\Keyboard Layout]

[HKEY_USERS\.DEFAULT\Keyboard Layout\Preload]
"1"="00000409"

[HKEY_USERS\.DEFAULT\Keyboard Layout\Substitutes]

[HKEY_USERS\.DEFAULT\Keyboard Layout\Toggle]
"Hotkey"="3"
"Language Hotkey"="3"
"Layout Hotkey"="3"

#5
myselfidem

myselfidem

    Member

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,559 posts
  • Joined 06-January 10
  • OS:Windows 7 x64
  • Country: Country Flag
Fine! :yes:

Seems yours is "Nation"="39" => Canada

Mine is and I can use (it was an example):

"Nation"="84" => France

"Nation"="223" => Switzerland

And same inside NLITE.IN_
For Windows 7 OS: SetProductKey.rar (fr-FR/en-US. Integrate keys).

#6
leogets

leogets
  • Member
  • 7 posts
  • Joined 05-July 08
I made these changes in WINNT.SIF:

[RegionalSettings]
LanguageGroup=1
Language="1009" (*This line wasn''t there so I added it)
SystemLocale="1009"
UserLocale="1009"
UserLocale_DefaultUser="1009"
InputLocale="1009:00000409" changed from: ="1009:00002409"
InputLocale_DefaultUser="1009:00000409" changed from: ="1009:00002409"

Problem now is when I go to install XP I get an error on the blue screen saying that keyboard.inf cannot be found
Hit enter to retry. If I choose to skip it, I cannot finish the install of xp after the reboot because there is no way to enter anything without the use of a keyboard.
Do you have any clue as to where I would check as to the reason why this is happening now?
Just checked the original; KEYBOARD.IN_ is in the i386 folder but for some reason wasn't copied over so i'll try a rerip and see what happens.
Yah that was the problem, missing files.

Thanks for the rightclick Expand-Makecab very usefull.

Edited by leogets, 13 March 2013 - 11:16 PM.


#7
myselfidem

myselfidem

    Member

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,559 posts
  • Joined 06-January 10
  • OS:Windows 7 x64
  • Country: Country Flag
You can try:

InputLocale="0409:00000409"
InputLocale_DefaultUser="0409:00000409"

How do I configure the default keyboard layout during login?

http://msdn.microsof...l/bb964665.aspx
For Windows 7 OS: SetProductKey.rar (fr-FR/en-US. Integrate keys).




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users