Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account


Photo

Can't create 64 bit virtual machines after hyper-v was enabled


  • Please log in to reply
3 replies to this topic

#1
radix

radix

    Friend of MSFN

  • Member
  • PipPipPipPipPip
  • 738 posts
  • OS:Windows 8 x64
  • Country: Country Flag
Hello,
After I've enabled Hyper-v in Windows 8 Enterprise 64 bit via "Control Panel > Programs > Turn Windows Features on or off", I can't create 64 bit virtual machines using VirtualBox. Disabling Hyper-v fixed the problem. CPU is Intel Core I7-3770k and virtualization is enabled in bios. Anyone knows a workaround to have Hyper-v and 64 bit virtualization ?
Thanks.


How to remove advertisement from MSFN

#2
Tripredacus

Tripredacus

    K-Mart-ian Legend

  • Super Moderator
  • 9,702 posts
  • OS:Server 2012
  • Country: Country Flag

Donator

Maybe you can be the first to figure it out! Apparently...

Yes, it does conflict with each other. You will get strange errors when both want to use hardware-V, something that's enabled by default in VB. And since Hyper-V runs as a service, it will lock it so VB cannot use it.


https://forums.virtu...t=39822#p178899

It seems to be a foregone conclusion that VirtualBox does not work when Hyper-V is enabled. :}

The common "fix" I can find is to diable Hyper-V... which isn't really a fix at all if you ask me.
http://community.zev.../Post.aspx?ID=9
http://netitude.bc3t...-on-win8prox64/

But i wonder why you need to run both?
MSFN RULES | GimageX HTA for PE 3.x | lol probloms
msfn2_zpsc37c7153.jpg

#3
MagicAndre1981

MagicAndre1981

    after Windows 7 GA still Vista lover :)

  • Patrons
  • 5,949 posts
  • OS:Vista Ultimate x86
  • Country: Country Flag

Donator

But i wonder why you need to run both?


maybe he does WP8 development which requires Hyper-V.
Posted Image

#4
radix

radix

    Friend of MSFN

  • Member
  • PipPipPipPipPip
  • 738 posts
  • OS:Windows 8 x64
  • Country: Country Flag
Disabling is the "fix". Thanks!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users



How to remove advertisement from MSFN