Welcome to MSFN

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


leo

Missing dll

4 posts in this topic

hello, I am trying to install Java jre-6u43 and am getting this error mesage:

Error 1723. There is a problem with this Windows

Installer package. A DLL required or this install to

complete could not be run. Contact your support

personnel or package vendor.

I checked dependency walker and I am missing APPHELP.DLL & USERENV.DLL

I have Kernlex 4.52 and kstubs822 installed.

Could someone help me with this.

Thanks

Edited by leo
0

Share this post


Link to post
Share on other sites

So far this is what I have found out:

APPHELP.DLL

http://www.dependencywalker.com/faq.html

Q. Dependency Walker says I'm missing APPHELP.DLL. Where can I get it from?

A. APPHELP.DLL is used by Windows XP's application compatibility feature. It is a Windows XP/2003/Vista/7/8/+ only DLL. If you see this warning, you most likely installed Internet Explorer 6.0 on your pre- Windows XP computer (Windows 95/98/ME/2000). Internet Explorer 6.0 installs a new SHWAPI.DLL that has a delay-load dependency on APPHELP.DLL. This is normal as SHWAPI.DLL does not expect to find APPHELP.DLL on versions of Windows prior to Windows XP. This warning can be ignored. You do not need (or want) APPHELP.DLL on Windows 95/98/ME/2000.

USERENV.DLL

0

Share this post


Link to post
Share on other sites

Java Fixer

Do you have

[Kernel32.dll]

GetSystemWow64DirectoryA=z2e120

in your Kstub822.ini?

Edited by schwups
0

Share this post


Link to post
Share on other sites

...and I have NO CLUE as to whether some information given in This Topic will help. You'll have to read the whole thing.

edit - Actually post #63 (last screen) made by jds

Well, I've finally managed to "brute force" JRE 6u43 to install (well, it kinda seems to be working), using something like the following process
Edited by submix8c
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.