Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account


Photo

XP hangs; can't create memory dumps

- - - - -

  • Please log in to reply
8 replies to this topic

#1
Click Beetle DX

Click Beetle DX

    Elateridae

  • Member
  • Pip
  • 53 posts
  • OS:XP Pro x86
  • Country: Country Flag
Hello, all.

My desktop running XP has been smooth for several years, no problems to report. Lately (past week) however it's been hanging at least once a day, usually hours into operation but sometimes as little as a few minutes [!]. Needless to say it's heavily affecting my productivity.

I have my system configured to create memory dumps as instructed in the stickied thread here on MSFN. However when I hold right CTRL and tap Scroll Lock twice, the machine merely reboots and no memory dump is created. (I tested this functionality while the machine was running OK, not when it was locked up.)

Perhaps the inability to create the memory dump stems from the fact that I'm booting from a CD, and not a normal Windows boot sequence? (I have DOS on C, to work with DOS stuff. Without the boot CD inserted, that's what the computer boots to. With the CD inserted, it boots to drive D, where XP is installed.) When I access My Computer -> Properties -> Advanced -> Startup and Recovery -> Settings, the message, "The c:\boot.ini file can not be opened. Operating System and Timeout settings can not be changed." appears.

If I'm unable to use the debugging tools to create the memory dump, what other options do I have to try and pinpoint what is causing my machine to hang?

Thanks in advance.


How to remove advertisement from MSFN

#2
dencorso

dencorso

    Adiuvat plus qui nihil obstat

  • Supervisor
  • 5,862 posts
  • OS:98SE
  • Country: Country Flag

Donator

First of all get Malwerebytes Antimalware, run it and let's see what it finds.
Next, get Sysinternals AutoRuns, install, run and let's see what it finds.

#3
Ponch

Ponch

    MSFN Junkie

  • Patrons
  • 3,272 posts
  • OS:none specified
  • Country: Country Flag
I'd say checkdisk on all used partitions.

#4
allen2

allen2

    Not really Newbie

  • Member
  • PipPipPipPipPipPipPip
  • 1,812 posts
This might help creating the dump.
If you own another computer and a null modem cable, you can try remote kernel debugging.

#5
Click Beetle DX

Click Beetle DX

    Elateridae

  • Member
  • Pip
  • 53 posts
  • OS:XP Pro x86
  • Country: Country Flag
Thanks for the (fast) replies.

First of all get Malwerebytes Antimalware, run it and let's see what it finds.


It found nothing (I run a pretty tight ship), aside from telling me both Security Center and Windows Firewall are turned off (which was my doing).

Next, get Sysinternals AutoRuns, install, run and let's see what it finds.


Nothing out of the ordinary, as far as I know (I like to think I run pretty light). Mostly a whole pile of video codecs, but none of them have posed a problem before and I've been running for quite a while with the same ones.

Does the AutoRuns.arn file contain any sensitive information about my computer? I admit to being a bit nervous about sharing it with the public.

I'd say checkdisk on all used partitions.


The first thing I did was to run both a scandisk and defrag on both volumes, followed by a virus scan. Everything came up OK, just as I figured. But the system still hangs.

This might help creating the dump.


No change after making all the instructed changes. My machine still reboots (briefly showing a blue debug screen), but no dump is saved.

If you own another computer and a null modem cable, you can try remote kernel debugging.


I do not own a null modem cable.

I also opened my system and checked all the fans. I've got three extra fans mounted in the case, in addition to the CPU fan, PSU fans and GPU fan. All are OK. The machine is running cool. It's an old machine anyway, and not overclocked, and I'm not really "pushing" the hardware to do anything taxing. So I really don't believe it's a hardware issue.

Edited by Click Beetle DX, 25 April 2013 - 08:17 PM.


#6
dencorso

dencorso

    Adiuvat plus qui nihil obstat

  • Supervisor
  • 5,862 posts
  • OS:98SE
  • Country: Country Flag

Donator

Next, get Sysinternals AutoRuns, install, run and let's see what it finds.


Nothing out of the ordinary, as far as I know (I like to think I run pretty light). Mostly a whole pile of video codecs, but none of them have posed a problem before and I've been running for quite a while with the same ones.

Does the AutoRuns.arn file contain any sensitive information about my computer? I admit to being a bit nervous about sharing it with the public.

I see no need to post it right now. But AutoRuns usually finds a lot of things that are default, so I suggest you go into the "Options" menu, select "Verify Code Signatures" and "Hide Signed Microsoft Entries", and re-run it. Maybe this time something that eluded you before will catch your eye. If not, consider posting a screenshot of autoruns output, which is much less invasive than posting the .arn file.
BTW, by hanging you mean just plain freezing, or does it throw you a good old BSOD?

#7
Click Beetle DX

Click Beetle DX

    Elateridae

  • Member
  • Pip
  • 53 posts
  • OS:XP Pro x86
  • Country: Country Flag

If not, consider posting a screenshot of autoruns output, which is much less invasive than posting the .arn file.


OK, here it is...

http://www.fileconvo...c04c484233c5bcc

BTW, by hanging you mean just plain freezing, or does it throw you a good old BSOD?


Just plain freezing. I wish it were a BSOD, at least then I'd have some vague error message to work with.

#8
Ponch

Ponch

    MSFN Junkie

  • Patrons
  • 3,272 posts
  • OS:none specified
  • Country: Country Flag

The first thing I did was to run both a scandisk and defrag on both volumes

On a side note, performing a defrag on a pc that hangs is not the best idea. :no:

#9
dencorso

dencorso

    Adiuvat plus qui nihil obstat

  • Supervisor
  • 5,862 posts
  • OS:98SE
  • Country: Country Flag

Donator

If I had to place a single bet, mine would be on ESET... is yours v.4 or later and is it fully up-to-date?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users



How to remove advertisement from MSFN