Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account



Photo

Windows 8 - DPC Latency help


  • Please log in to reply
9 replies to this topic

#1
zerowalker

zerowalker
  • Member
  • 8 posts
  • Joined 27-April 13
  • OS:Windows 8 x64
  • Country: Country Flag
I am having a bit of a problem with DPC latency.
It´s nothing really serious, but i would like to track what´s causing it.

I attached latencymon screenshots, hopefully that will help a bit.

In Latencymon it goes from 10-30 to 70-90 from time to time, like every 2-3 sec, and i don´t know why.
I tried disabling my NIC but that didn´t help.

Also tried enabling HPET, but that changed it a bit, but not for the better, and my mouse became slowish.

So i am out of ideas.

Attached Files




How to remove advertisement from MSFN

#2
MagicAndre1981

MagicAndre1981

    after Windows 7 GA still Vista lover :)

  • Patrons
  • 6,157 posts
  • Joined 28-August 05
  • OS:Vista Ultimate x86
  • Country: Country Flag

Donator

run the xperf command I posted in my topic and upload the generated .ETL file.
Posted Image

#3
zerowalker

zerowalker
  • Member
  • 8 posts
  • Joined 27-April 13
  • OS:Windows 8 x64
  • Country: Country Flag
Sorry but what topic are you talking about here?

#4
MagicAndre1981

MagicAndre1981

    after Windows 7 GA still Vista lover :)

  • Patrons
  • 6,157 posts
  • Joined 28-August 05
  • OS:Vista Ultimate x86
  • Country: Country Flag

Donator

this topic:

http://www.msfn.org/...-dpc-interrupt/
Posted Image

#5
zerowalker

zerowalker
  • Member
  • 8 posts
  • Joined 27-April 13
  • OS:Windows 8 x64
  • Country: Country Flag
Okay, here it is.

http://www.sendspace.com/file/cxa3vd

Edited by zerowalker, 28 April 2013 - 03:35 AM.


#6
MagicAndre1981

MagicAndre1981

    after Windows 7 GA still Vista lover :)

  • Patrons
  • 6,157 posts
  • Joined 28-August 05
  • OS:Vista Ultimate x86
  • Country: Country Flag

Donator

you don't have nay issues with DPCs:

Total = 48160
Elapsed Time, > 0 usecs AND <= 1 usecs, 13580, or 28.20%
Elapsed Time, > 1 usecs AND <= 2 usecs, 8797, or 18.27%
Elapsed Time, > 2 usecs AND <= 4 usecs, 11869, or 24.64%
Elapsed Time, > 4 usecs AND <= 8 usecs, 8289, or 17.21%
Elapsed Time, > 8 usecs AND <= 16 usecs, 5368, or 11.15%
Elapsed Time, > 16 usecs AND <= 32 usecs, 212, or 0.44%
Elapsed Time, > 32 usecs AND <= 64 usecs, 35, or 0.07%
Elapsed Time, > 64 usecs AND <= 128 usecs, 10, or 0.02%
Total, 48160


highest values are only betwwen 64 and 128µs, this is outstanding good :)
Posted Image

#7
zerowalker

zerowalker
  • Member
  • 8 posts
  • Joined 27-April 13
  • OS:Windows 8 x64
  • Country: Country Flag
I will have to trace a longer time. Cause it should be worse than that from time to time. I get like 400, or something, but i don´t know from what.

And i see that people have like 10-30 normally. Mine is pretty much at 70+.

Here is another, i kept it going for a longer period this time.

http://www.sendspace.com/file/wr12ug

Thanks

#8
MagicAndre1981

MagicAndre1981

    after Windows 7 GA still Vista lover :)

  • Patrons
  • 6,157 posts
  • Joined 28-August 05
  • OS:Vista Ultimate x86
  • Country: Country Flag

Donator

this time you had a small issue with the DX driver:

Total = 78501 for module dxgkrnl.sys
Elapsed Time, > 128 usecs AND <= 256 usecs, 12, or 0.02%
Elapsed Time, > 256 usecs AND <= 512 usecs, 4, or 0.01%
Elapsed Time, > 512 usecs AND <= 1024 usecs, 9, or 0.01%
Elapsed Time, > 1024 usecs AND <= 2048 usecs, 1, or 0.00%
Total, 78501


try the AMD Catalyst 13.4 or 13.5 Beta drivers.
Posted Image

#9
zerowalker

zerowalker
  • Member
  • 8 posts
  • Joined 27-April 13
  • OS:Windows 8 x64
  • Country: Country Flag
That seem to have helped.

I only seem to get DPC spikes now when i open videos some times. I guess it´s something with loading the codec or such.
But it seems to only be at the load moment, which doesn´t affect anything i think.

It can get up to 900+ it seems if i spam open.

#10
bphlpt

bphlpt

    MSFN Addict

  • Member
  • PipPipPipPipPipPipPip
  • 1,821 posts
  • Joined 12-May 07
  • OS:none specified
  • Country: Country Flag

It can get up to 900+ it seems if i spam open.


Well then, don't do that. LOL Sorry, I couldn't help myself.

Cheers and Regards

Posted Image





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users