• Announcements

    • xper

      MSFN Sponsorship and AdBlockers!   07/10/2016

      Dear members, MSFN is made available via subscriptions, donations and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, become a site sponsor and ads will be disabled automatically and by subscribing you get other sponsor benefits.
MarkW1976

WinPE 4.0 Slow LAN Transfer Speeds

4 posts in this topic

Hi All,

First of all let me thank you for your excellent forum! I have learned so much from you all  Unfortunately I have an issue which I cannot seem to find the answer too and was wondering if you would be kind enough to help me with it.

The problem as the title suggest relates to deployment speeds in using WinPE 4.0 (x64).

We currently have a bespoke deployment system that uses WinPE 3.0(x32), but this needs to be updated to WinPE 4.0 (x64) to allow Windows 8 deployment (Our deployment method uses OEM installation scripts which will only run in WinPE 4.0 (x64)).

The problem is the deployment time is roughly doubled since the upgrade! Both OEM scripts and Ghost64 (V12) take much longer to image the client. At first we thought it was a LAN driver issue, but this was eliminated by using 3 different driver versions and then later a USB->LAN converter, which again was significantly slower. Further investigation revealed the network traffic was dropping out completely rather than running at a constant slower speed. When data was being transferred the speed was comparable to WinPE 3.0, but the problem is the data isn’t being moved all the time. For example, the data will transfer for about 60 seconds and then stop for 30. Robocopy also displays the same characteristic (We transferred 50gb in WinPE 3.0 and the same in 4.0 with the results showing data being intermittently transferred)

All our clients are based on Intel chief river platforms.

The server is a glorified i7 desktop, 8GB RAM, Server 2012. It also has an LSI 9260-4i RAID card and Intel quad ET LAN card (teamed). Both have the latest drivers and the RAID card has the latest firmware.

If you need any further information please do not hesitate in asking.

Any help will be appreciated.

0

Share this post


Link to post
Share on other sites

Instead of using WinPE 4.0 you might try to use Portable or Mini 8 in VHD

You can boot from HDD or USB using Boot Manager Menu and Microsoft Virtual driver

Or boot from RAMDISK using Grub4dos Menu and FiraDisk or WinVBlock driver.

Portable and Mini 8 have the full registry of Installed Windows 8

which is in any case much better than WinPE 4.0

http://www.911cd.net/forums//index.php?showtopic=25333

:)

Edited by wimb
0

Share this post


Link to post
Share on other sites

I have not heard any reports of deployment being slower once switching to WinPE 4. However the environment may be different. Here are some examples...

- File servers (that store the images) data arrays are on RAID10.

- Servers use NIC teaming

- Servers are Intel server board with dual CPU (8 core)

- Servers have at least 24GB RAM

- Servers WDS set to not add PCs to AD

- All switches use link aggregation

0

Share this post


Link to post
Share on other sites

Thanks for the suggestions.

We have made some progress..... Robocopy is now transferring files at the same speed in both enviornments.

Updating the Server LAN drivers and teaming software appears to have fixed this, but ghost is still slow.

This may be the version we are using because we have experience of differing speeds between ghost versions in the past.

I will obtain the V11.5.1 Ghost64 (the same version as our 32bit system) and post the results.

Edit: I think the LAN driver was the same version, but re-configuring the teams fixed the issue.

Edited by MarkW1976
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.