Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account


Photo

Microsoft Exchange 2007 Self Signed Certificate question


  • Please log in to reply
2 replies to this topic

#1
anthonyaudi

anthonyaudi

    Member

  • Member
  • PipPip
  • 149 posts
Hello fellow MSFNers. I have a question for all the Exchange Gurus here.

My certificate recently expired. Now I reissued a new certificate and deleted the old one. All is fine and dandy the certificate now has a good date. However, I am presented with an issue that is making me scratch my head. I am not sure if it is because it cannot be done or I am simply doing it incorrectly.

When I go to https://webmail.mycompany.com/owa I am presented with the following error:

In Firefox: webmail.mycompany.com uses an invalid security certificate.

The certificate is not trusted because it is self-signed.
The certificate is only valid for the following names:
SERVER , SERVER.mycompany.local


In Internet Explorer:

The security certificate presented by this website was not issued by a trusted certificate authority.
The security certificate presented by this website was issued for a different website's address.


Now when I go into my Management Console and into Certificates under the Personal store I have my certificate. Under Trusted Root Certification Authorities I also have the certificate. When I double click on the certificate I have no errors or warnings. All seems good.


The services enabled on this certificate are SMTP IIS POP IMAP.

My question is the following: Is there any way without purchasing a certificate and without having to go to every single computer to import the certificate, to access the OWA homepage right away without having to click "Not Recommended"

If there is can someone please tell me how to do it as I am lost.

I have followed a few how to's but I am always presented with the same error.

When I click inside my exchange management console and run the following command

get-exchangecertificates | fl

The certificate that is valid has the following certificatedomains: server, server.mydomain.local

Is there anyway to have that certificate also have -----webmail.mydomain.com in it?


How to remove advertisement from MSFN

#2
anthonyaudi

anthonyaudi

    Member

  • Member
  • PipPip
  • 149 posts
I guess this is one of those questions where I might not be in the right forum?
Anyone have any clues?

#3
allen2

allen2

    Not really Newbie

  • Member
  • PipPipPipPipPipPipPip
  • 1,812 posts
Indeed you need to add all needed FQDN when creating the self signed certificate (as explained there) and that should solve one problem : the OWA website should only show that the certificate is self signed until you add/deploy the certificate of your certificate autority on the computers needing to access to the OWA.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users



How to remove advertisement from MSFN