Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account



Photo

autounattend file


  • Please log in to reply
18 replies to this topic

#1
digitalmilton

digitalmilton

    Newbie

  • Member
  • 12 posts
  • Joined 22-May 13
  • OS:Windows 7 x86
  • Country: Country Flag
i have created two wim files. i syspreped the images without the unattend files. my unattend files are setup to add a hostname to the pc and add the pc to the domain, however i cannot get them to apply to the image. after imaging the pc just boots to the setup page asking me for a pc name and the time zone, etc. then i have to add to domain. i also try doing it where i use the win 7 dvd with the autoattend file in a thumb drive and after rebooting it discovers the autoattend but i get an error stating, " windows could not parse or process the unattend answer file for pass [specialize]. the settings specified int he answer file cannot be appplied. the erro was detected while processing settings for component [microsoft-windows-shell-setup]. i have a huge rollout to do and really could use a hand. any ideas?

Edited by digitalmilton, 22 May 2013 - 07:13 AM.



How to remove advertisement from MSFN

#2
Tripredacus

Tripredacus

    K-Mart-ian Legend

  • Super Moderator
  • 9,907 posts
  • Joined 28-April 06
  • OS:Server 2012
  • Country: Country Flag

Donator

For the problem of getting the answer file to be read by the WIM file... Rename your answer file unattend.xml. Then mount your image and put the unattend.xml file into mount\windows\system32\sysprep. Then commit your changes and try to apply your image. Alternatively, another option is you can run setup and use the /unattend switch to specify the location of the answer file, rather than having to manually put it in the image.

For the parsing error, you'll need to attach your xml file to a post (make sure to edit out your domain information and product key) so we can look at it. Otherwise you can validate it in WSIM to make sure you do not have any errors it can find.
MSFN RULES | GimageX HTA for PE 3-5 | lol probloms
msfn2_zpsc37c7153.jpg

#3
digitalmilton

digitalmilton

    Newbie

  • Member
  • 12 posts
  • Joined 22-May 13
  • OS:Windows 7 x86
  • Country: Country Flag
thanks for your reply! i've attached a sample of my xml file to this message. i'm a noob so forgive me for this, but what is the exact syntax for mount\windows\system32\sysprep and where exactly would i do that? i begin by mounting using DISM, right?

i'm not sure what you mean by running setup and using /unattend switch to specify the location of the xml file. do you mean i put the dvd into the drive and somehow point it to the xml file? where would i do that exactly? again, i'm a noob so please be patient with me.

thanks again!

Attached Files


Edited by digitalmilton, 22 May 2013 - 08:34 AM.


#4
digitalmilton

digitalmilton

    Newbie

  • Member
  • 12 posts
  • Joined 22-May 13
  • OS:Windows 7 x86
  • Country: Country Flag
tripredacus...

i've tried both your suggestions and nothing works.

#5
Tripredacus

Tripredacus

    K-Mart-ian Legend

  • Super Moderator
  • 9,907 posts
  • Joined 28-April 06
  • OS:Server 2012
  • Country: Country Flag

Donator

WSIM should have failed validation on this answer file. For example, the value of TimeZone is invalid. The correct value in your case would be:

<TimeZone>Eastern Standard Time</TimeZone>

MSFN RULES | GimageX HTA for PE 3-5 | lol probloms
msfn2_zpsc37c7153.jpg

#6
digitalmilton

digitalmilton

    Newbie

  • Member
  • 12 posts
  • Joined 22-May 13
  • OS:Windows 7 x86
  • Country: Country Flag
Is that my only error? did you spot anything else i should fix??? sorry for the hassle, it's the desperation talking.

#7
digitalmilton

digitalmilton

    Newbie

  • Member
  • 12 posts
  • Joined 22-May 13
  • OS:Windows 7 x86
  • Country: Country Flag
tripredacus...
is there anything else in my answer file that would cause the parsing error? i changed the time zone to what you suggested and the parsing error still exists.

#8
Tripredacus

Tripredacus

    K-Mart-ian Legend

  • Super Moderator
  • 9,907 posts
  • Joined 28-April 06
  • OS:Server 2012
  • Country: Country Flag

Donator

Yes. The ComputerName object may be invalid. Replace it with * instead and see what kind of name it generates, also if the error is gone.
MSFN RULES | GimageX HTA for PE 3-5 | lol probloms
msfn2_zpsc37c7153.jpg

#9
digitalmilton

digitalmilton

    Newbie

  • Member
  • 12 posts
  • Joined 22-May 13
  • OS:Windows 7 x86
  • Country: Country Flag
i've made some config changes so that the image points to the unattend.xml and the oobe.xml file. now the error i get tells me, "windows could not prepare the partition selected for installation". so it would seem that somehow my disk configuration needs to be amended.

#10
digitalmilton

digitalmilton

    Newbie

  • Member
  • 12 posts
  • Joined 22-May 13
  • OS:Windows 7 x86
  • Country: Country Flag
tripredacus....

the answer file is finally being read except for two crucial parts. the computer name is not being automatically assigned per my company's naming convention and it is also not being joined to the domain. i have followed the syntax shown in the directory services tab of the server properties in WDS (new client naming policy). for joining the domain, under unattendedjoin_neutral, i have listed the domain under joindomain and the machineobjectOU is listed as workstation.

debugjoin is false
unsecurejoin is false
debugjoinonlyonthiserror is 0.

any ideas???

#11
Tripredacus

Tripredacus

    K-Mart-ian Legend

  • Super Moderator
  • 9,907 posts
  • Joined 28-April 06
  • OS:Server 2012
  • Country: Country Flag

Donator

I have no experience in joining a computer to a domain via the answer file. There are multiple topics about it in this section. Just search for MachineObjectOU to find other (potentially similar) posts and see how their files are built and if they had the same problem.
MSFN RULES | GimageX HTA for PE 3-5 | lol probloms
msfn2_zpsc37c7153.jpg

#12
digitalmilton

digitalmilton

    Newbie

  • Member
  • 12 posts
  • Joined 22-May 13
  • OS:Windows 7 x86
  • Country: Country Flag
I've literally reached a point of desperation. i cannot get my answer file to assign a computer name based on my WDS server's directory services naming convention. it always defaults to asking me to assign a computername. i imaged my pc based on this link:
http://www.danscours...-windowspe.html

with this link i created my wim file and pe disk. i then created my xml file. i've attached it to this post.

i have a rollout that is due very soon and i've checked every resource i could find online and either they don't work or there are steps that are confusing me or unnecessary.

does anyone even know of any kind of a support line that i could call and speak to someone??

for anybody in the nyc area, the beer would be on me for anyone who provides a viable answer.

Attached Files



#13
maxXPsoft

maxXPsoft

    MSFN Master

  • Developer
  • 2,889 posts
  • Joined 14-November 03
  • OS:Windows 7 x64
  • Country: Country Flag
Also <TimeZone>Eastern Standard Time</TimeZone>

sure you read this?
Computer_name
If ComputerName is missing, you must enter a computer name during Windows® Welcome.

If ComputerName is set to an asterisk (*) or is an empty string, a random computer name will be generated. This random name has at most eight characters from the RegisteredOwner and/or RegisteredOrganization strings plus random characters.

Computer_name is a string with a maximum length of 15 characters.
Download ++> Windows 7 + 8 Unattended DVD + App Installer + Services Disabler + Load All Button + XML Creator
Jump2Reg - Registry: - Oct 4, 2013 - Version 3.0.4 - 98, ME, NT, 2K, XP, VISTA, Seven, Windows 8+ and 32 or 64 bit

XP Unattended CD/DVD creator - Version 4.1.7
Sample xml + Setupcomplete + Add Right click .wim Windows 7 or Windows 8/8.1

#14
digitalmilton

digitalmilton

    Newbie

  • Member
  • 12 posts
  • Joined 22-May 13
  • OS:Windows 7 x86
  • Country: Country Flag
Thanks, MaxXPsoft...

I have tried the * and it still doesn't produce any type of computer name, random or otherwise. what i'm trying to avoid is having to assign a computer name on my own since i want the server to assign one based on my company's naming convention.

#15
Tripredacus

Tripredacus

    K-Mart-ian Legend

  • Super Moderator
  • 9,907 posts
  • Joined 28-April 06
  • OS:Server 2012
  • Country: Country Flag

Donator

Computer name via the answer file leaves much to be desired. If neither of those fit your company's naming pattern, you should set it to * and then use scripts after deployment to change the computer name appropriately.
MSFN RULES | GimageX HTA for PE 3-5 | lol probloms
msfn2_zpsc37c7153.jpg

#16
maxXPsoft

maxXPsoft

    MSFN Master

  • Developer
  • 2,889 posts
  • Joined 14-November 03
  • OS:Windows 7 x64
  • Country: Country Flag
What I was trying to say is your <RegisteredOwner> possibly too long, abbreviate it and add *
Tripredacus answer may e best for you
Download ++> Windows 7 + 8 Unattended DVD + App Installer + Services Disabler + Load All Button + XML Creator
Jump2Reg - Registry: - Oct 4, 2013 - Version 3.0.4 - 98, ME, NT, 2K, XP, VISTA, Seven, Windows 8+ and 32 or 64 bit

XP Unattended CD/DVD creator - Version 4.1.7
Sample xml + Setupcomplete + Add Right click .wim Windows 7 or Windows 8/8.1

#17
digitalmilton

digitalmilton

    Newbie

  • Member
  • 12 posts
  • Joined 22-May 13
  • OS:Windows 7 x86
  • Country: Country Flag
i appreciate everyone's help very much!

i've created a new unattend file and point my image to the file. after imaging, i get this error.....


windows could not parse or process the unattend answer file for pass [specialize]. The settings specified in the answer file cannot be applied. The error was detected while processing settings for component [Microsoft Windows Shell Setup].

can't figure out what in specialize is doing this????

#18
digitalmilton

digitalmilton

    Newbie

  • Member
  • 12 posts
  • Joined 22-May 13
  • OS:Windows 7 x86
  • Country: Country Flag
first of all, i want to say how much i appreciate everyone's help!!! thank you all!!!

i've written a new unattend file, named it autounattend.xml
i pointed my image to it and after imaging, this is what i get....



windows could not parse or process the unattend answer file for pass [specialize]. The settings specified in the answer file cannot be applied. The error was detected while processing settings for component [Microsoft Windows Shell Setup].


not sure what in the specialize pass is causing this????

#19
maxXPsoft

maxXPsoft

    MSFN Master

  • Developer
  • 2,889 posts
  • Joined 14-November 03
  • OS:Windows 7 x64
  • Country: Country Flag

windows could not parse or process the unattend answer file for pass [specialize].

Do This and capture the logs http://www.msfn.org/...486#entry888486
Download ++> Windows 7 + 8 Unattended DVD + App Installer + Services Disabler + Load All Button + XML Creator
Jump2Reg - Registry: - Oct 4, 2013 - Version 3.0.4 - 98, ME, NT, 2K, XP, VISTA, Seven, Windows 8+ and 32 or 64 bit

XP Unattended CD/DVD creator - Version 4.1.7
Sample xml + Setupcomplete + Add Right click .wim Windows 7 or Windows 8/8.1




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users