Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account


Photo

Enabling analogue sound on my MSI 970A-G46 motherboard

- - - - -

  • Please log in to reply
7 replies to this topic

#1
Phaenius

Phaenius

    Member

  • Member
  • PipPip
  • 177 posts
  • OS:Windows 7 x64
  • Country: Country Flag
Can anyone tell me how to enable analogue output on my MSI 970A-G46 motherboard (via Realtek integrated audio card) ? I installed the drivers, but I only have Realtek Digital Output and Realtek Digital Output (Optical) available. The analogue output (Realtek High Definition Audio) returns "Not plugged in" error. How can I enable this output ? What exactly shall I plug in ? Everything is plugged in. On old AC'97, it used to be 2 jumpers that needed to short some pins on the motherboard, but I don't know if this is the case with the new Realtek HD anymore (who has a different connector). Thanks.

Motherboard manual can be found here: http://www.msi.com/s...nual-18822.html


How to remove advertisement from MSFN

#2
Tripredacus

Tripredacus

    K-Mart-ian Legend

  • Super Moderator
  • 9,710 posts
  • OS:Server 2012
  • Country: Country Flag

Donator

Are you connecting to the rear or front panel audio? I just tested with some cheapo speakers, connecting to the green rear jack and it was detected as analog. Its not the same board but is the same audio controller.
MSFN RULES | GimageX HTA for PE 3.x | lol probloms
msfn2_zpsc37c7153.jpg

#3
Phaenius

Phaenius

    Member

  • Member
  • PipPip
  • 177 posts
  • OS:Windows 7 x64
  • Country: Country Flag
Rear. The 3.5 mm jacks. For the front output I have a Creative card.

#4
Phaenius

Phaenius

    Member

  • Member
  • PipPip
  • 177 posts
  • OS:Windows 7 x64
  • Country: Country Flag
Well, I solved it meanwhile, after reading a post on other forum. It needed to disable the front panel jack detection in the Realtek sound manager utility.

In Romania we have a saying "eu centrez, eu dau cu capul", meaning I cross the ball, I head it towards goal. In this case, I posed the question and I answered it. :)

#5
Phaenius

Phaenius

    Member

  • Member
  • PipPip
  • 177 posts
  • OS:Windows 7 x64
  • Country: Country Flag
And now I have another problem. I have 2 sound cards in my system, one is integrated (Realtek HD via SB950 chipset), the other is a PCI Creative X-Fi card. Each one has analogue and digital outputs (I wish they hadn't). Problem is at each system boot, computer decides on its own which output to use and I have to uninstall and reinstall the other card if I want to use its analogue output. :realmad: This is annoying. How can I fix this, so that I select one option and it stays like that until I say different ?

#6
Tripredacus

Tripredacus

    K-Mart-ian Legend

  • Super Moderator
  • 9,710 posts
  • OS:Server 2012
  • Country: Country Flag

Donator

Well, I solved it meanwhile, after reading a post on other forum. It needed to disable the front panel jack detection in the Realtek sound manager utility.


I had a feeling that was it. I don't have any of my motherboards in chassis when I test them, but I remember this being a problem a while back.

As far as multiple sound cards, the only OS I got them to work in was XP 64bit.

I did some searching around and all I can find about the behaviours of the sound cards is driver related. Also I do see many complaints of people wanting the audio "streaming" to go back to how it was in XP. Apparently, something had changed starting with Vista, which might be related to the other issues some of us have encountered going from XP to 7.
MSFN RULES | GimageX HTA for PE 3.x | lol probloms
msfn2_zpsc37c7153.jpg

#7
Phaenius

Phaenius

    Member

  • Member
  • PipPip
  • 177 posts
  • OS:Windows 7 x64
  • Country: Country Flag
Well, that's nothing I can do about it. I won't revert to XP or Vista. I do like 7 better. I wish it was a solution for this. For the last reboots, my computer was nice and didn't switch the cards, but it can strike at any time. And along with the switch back, I must perform all the settings, which are defaulted.

#8
puntoMX

puntoMX

    n00b of Masters and Vice Versa

  • Super Moderator
  • 4,845 posts
  • OS:Windows 8.1 x64
  • Country: Country Flag

Well, I solved it meanwhile, after reading a post on other forum. It needed to disable the front panel jack detection in the Realtek sound manager utility.

That is only when the wiring is AC-97 and not HD, so you disable the auto sensing pins on the mobo connector (and some rerouting for other pins). Just as an sidenote.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users



How to remove advertisement from MSFN