Sign in to follow this  
Followers 0
DiracDeBroglie

Windows Media Player 12 64-bit version; How to set as default player?

5 posts in this topic

A trivial question maybe, but I didn't manage to find an answer yet. How can I set WMP12 64-bit version as default player in Window 7 64-bit? My current default player is WMP12 32-bit version, and I would like to change that. Some time ago I had the same problem with IE, but then the problem went away by itself with the arrival of IE10.

thanks in advance, j

0

Share this post


Link to post
Share on other sites

Not an 'overall' solution since Windows handles applications by filetype... However, take a look at this example:

http://rhubbarb.wordpress.com/2011/09/23/vlc-dvd-w7/

We see in this location:

HKEY_LOCAL_MACHINE\SOFTWARE\Classes\DVD\shell\play\command

That the command is:

%ProgramFiles(x86)%\Windows Media Player\wmplayer.exe” /prefetch:4 /device:DVD “%L

So, in the example of DVD playback, I would imagine that changing the path from ProgramFiles(x86) to ProgramFiles would suffice to change it to the 64bit version.

0

Share this post


Link to post
Share on other sites

Hi,

I just tried to edit the following key:

HKEY_CLASSES_ROOT\WMP11.AssocFile.3G2\shell\play\command "%ProgramFiles(x86)%\Windows Media Player\wmplayer.exe" /prefetch:6 /Play "%L"

and change %ProgramFiles(x86)% into %ProgramFiles%.

However, regedit.exe always gives me a 'Permission denied'. I've tried to change the User permission to Full Control but also that does not work.

Any idea how to edit the registry keys using regedit.exe? Or how to make the changes to the User permissions go through. I've ran regedit.exe in Administrator mode though.

Thanks in advance,

j

0

Share this post


Link to post
Share on other sites

From what I understand, HKCR is just a "viewing point" of keys kept in other places, including HKEY_LOCAL_MACHINE\Software\Classes. I think you should try working in the actual location in HKLM instead. But as for why you get a permission error, maybe the ownership of the key needs to be changed.

0

Share this post


Link to post
Share on other sites

Finally got the problem sorted out. The WMP12 64-bit version is now the DEFAULT on my Windows 7 computer.

As for the permission errors in RegEdit, I noticed that those keys I wanted to edit were owned by SYSTEM. So I changed temporary the owner of those keys to USER (my name), altered the keys from %ProgramFiles(86)% to %ProgramFiles% and changed the owner back to SYSTEM. However, altering the paths to %ProgramFiles% in severel keys related to .AVI, .MOV, ... video file extentions didn't help me any further; the default WMP remained stuck at its 32-bit version.

BTW, prior to fussing with the registry I took a System Restore Point after having cleaned up the system first with CCleaner and Wise Registry Cleaner.

Then I stumbled upon the following link:

http://answers.microsoft.com/en-us/windows/forum/windows_7-windows_programs/making-windows-media-player-64-bit-default/bd4872b3-75e8-4d81-ae8a-df50798d5113

and that solved my problem completely.

After having followed the instructions in previous link, one still needs to make the WMP12 64-bit version the default version for all the video file extensions (.MOV, .MP4, .AVI, .3GP, ....). This can be accomplished the usual way; right-click the video file with a particular video file extension you want to open with the 64-bit version of WMP, then select Open With > Choose Default Program ... > (a pane pops up with Recommended Programs and Other Programs) select the Browse button en navigate to C:\Program Files\Windows Media Player and select wmplayer.exe, which should be the 64-bit version. Make sure that in the pane (with Recommended Programs and Other Programs) the BOX |Always use the selected program to open this kind of file| is checked. Repeat this procedure for all (.MOV, .MP4, .AVI, .3GP, ....) video file extensions and all video files will open with the 64-bit version of WMP upon double clicking them.

In previous link there is the command unregmp2 /SwapTo:64 which needs to be invoked from the elevated command prompt (Run CMD as administrator). In my particular case unregmp2 /SwapTo:64 caused some activity on the system drive of mine, but no error message appeared and after having implemented the rest of the RegEdit procedure all went well and I changed the default player to the 64-bit version. So it 'looked like' unregmp2 /SwapTo:64 worked properly.

However, some authors on some internet fora noted that unregmp2 /SwapTo:64 does/may not (always) work in Windows 7 (beta?). For those who might be interested, one could skip running unregmp2 /SwapTo:64 in aforementioned link and go ahead with the RegEdit procudure and see if one can change the default player to the 64-bit version. If that doesn't work, then one can still re-run the RegEdit procedure but preceded by the unregmp2 /SwapTo:64 command, as foreseen in the link. Reverting the whole procedure involves the command unregmp2 /SwapTo:32 .

Some links:

http://www.winvistatips.com/another-method-setting-wmp64-your-default-player-t168726.html

http://zachd.com/pss/pss.html#wmp12

http://forums.mydigitallife.info/archive/index.php/t-9672.html

Regards,

j

Edited by DiracDeBroglie
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.