Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 



Sign in to follow this  
rd30831

How to not have network loaded?

Recommended Posts

rd30831    0

Using WAIK 3, installed from KB3AIK_EN.iso, and using the help file "Windows Preinstallation Environment (Windows PE) User's Guide"; I followed the steps from the "Walkthrough: Boot Windows PE from CD-ROM" .

It booted, but loaded the network, I guess due to Wpeinit.exe, which "installs Plug and Play devices, processes Unattend.xml settings, and loads network resources."

How can I have it install PnP, but not load the network?

According to the help, that can be done later, via "Wpeutil InitializeNetwork".

So how to have the WinPE 3 CD boot, but not load the network automatically?

(Most of the guides I've seen are about how to make WinPE do more, not less.)

Edited 7-12-13, as yesterday's site maintenance seems to have deleted the responses.

When the command prompt is given, running ipconfig reports that both DHCP and Autoconfiguration are Enabled. I'd rather that networking not be enabled yet, no asking for an IP address via DHCP or APIPA.

I'm using WinPE for recovery/utility work, and would rather enable the network only when I need it.

Edited by rd30831

Share this post


Link to post
Share on other sites

rd30831    0

I finally got around to testing the simplest idea: commenting out the wpeinit line in startnet.cmd.

At the prompt, ipconfig showed nothing done, and I was able to insert a USB thumb drive

Share this post


Link to post
Share on other sites
Tripredacus    283

Oh yeah, sorry about this topic. I had crafted an awesome response to this but it was on a day that the database got rolled back and I forgot which topic it was.

I had suggested that you import a NIC configuration with netsh, and have the configuration be an invalid static IP address.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×