Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account



Photo

IPB Update July 2013 (to version 3.4.5)

- - - - -

  • This topic is locked This topic is locked
79 replies to this topic

#26
LoneCrusader

LoneCrusader

    Resistere pro causa resistentiam.

  • MSFN Sponsor
  • 813 posts
  • Joined 11-May 09
  • OS:98SE
  • Country: Country Flag

Donator

I know you're hard at work on the new upgrade, and with any "upgrade" there are bound to be plenty of glitches. Hopefully at least the database errors will be solved. :thumbup


Issues:

When quoting someone, their entire post is displayed as a "block" rather than plain text with Quote tags and one cannot easily separate parts of it to avoid unnecessary redundancy or to address specific points. It also cannot be simply "copied" and reused because when copied, the quote tags are lost.

Sometimes the cursor is lost when posting, and only switching to another active window and then returning to the browser will make it reappear. (Firefox 3.6.28)

I hope the topic Subtitles can be reinstated, I think they are very useful and should not be removed.

Sometimes there are very valid reasons for creating back-to-back separate posts. Granted, it should not be "abused," but the board should not auto-merge them by default either. This is what we have Moderators for.

Please return to the previous theme (or similar) as soon as possible.
<rant> I know it's not your fault xper :} , but why do these board upgrades always have to break the previous theme? :realmad: </rant>


Edited by LoneCrusader, 12 July 2013 - 02:37 PM.



How to remove advertisement from MSFN

#27
Tripredacus

Tripredacus

    K-Mart-ian Legend

  • Super Moderator
  • 9,913 posts
  • Joined 28-April 06
  • OS:Server 2012
  • Country: Country Flag

Donator

I know it is something a user probably doesn't care about... :whistle:

 

But I think it would be nice if the link to the forum rules were up top someplace. It took me forever to realise where the link was... WAAAY at the bottom. :sneaky:

 

Otherwise, I think it looks pretty cool so far. Especially since the design is different than other boards of this version I frequent. :thumbup


MSFN RULES | GimageX HTA for PE 3-5 | lol probloms
msfn2_zpsc37c7153.jpg

#28
JorgeA

JorgeA

    FORMAT B: /V /S

  • MSFN Sponsor
  • 3,225 posts
  • Joined 08-April 10
  • OS:Vista Home Premium x64
  • Country: Country Flag

folks please... only bugs and suggestions. Short and simple. It is hard to me to find the way through all those post.

 

Bugs, suggestions, observations and please be short and simple.

 

Thanks.

Sorry xper, all along I was only reporting what appeared to be bugs or glitches so that they could be attended to at some point.

 

But thanks for asking politely :yes:,  and good luck with the upgrade as it continues.

 

BTW, the Forum is looking visually better than earlier this morning. And I do like it that you can now delete words by using CTRL-Del, it does simplify that aspect of posting.

 

--JorgeA



#29
-X-

-X-

    Member

  • MSFN Sponsor
  • 2,421 posts
  • Joined 08-January 04
  • OS:XP Pro x86
  • Country: Country Flag

Donator

Advanced search produces the following: There appears to be an error with the database.

Download all Windows XP Post SP3 High-Priority Updates with a simple double click @ xdot.tk post-12166-0-42859000-1399044129.png ]
               If someone helps you fix a problem, please report back so they and others can benefit from the solution. Thanks!


#30
submix8c

submix8c

    Inconceivable!

  • Patrons
  • 4,331 posts
  • Joined 14-September 05
  • OS:none specified
  • Country: Country Flag
re - post #26... "Go to first unread post" is there at the top! I MAY be inadvertently blocking it though. Just I was used to "automagically" going there.

Someday the tyrants will be unthroned... Jason "Jay" Chasteen; RIP, bro!

Posted Image


#31
Tripredacus

Tripredacus

    K-Mart-ian Legend

  • Super Moderator
  • 9,913 posts
  • Joined 28-April 06
  • OS:Server 2012
  • Country: Country Flag

Donator

There is a problem with the post editor when you type some stuff. Then you press "Enter" (or Return for you oldies) and then put in manual IMG tagged content. While the hard return appears in the editor before posting and while editing the post, it isn't respected on the actual post. Sometimes I need to do 2 or 3 extra "Enter" between the content and the image.

Proof in the test forum.

EDIT: also, when clicking the number of topic followers up top, I can't see the users. I know I should be able to see the users that follow the topic because it has that function on reboot.
MSFN RULES | GimageX HTA for PE 3-5 | lol probloms
msfn2_zpsc37c7153.jpg

#32
bphlpt

bphlpt

    MSFN Addict

  • Member
  • PipPipPipPipPipPipPip
  • 1,798 posts
  • Joined 12-May 07
  • OS:none specified
  • Country: Country Flag

 

There seems to be no option in the comment editor for code view rather than output view.

It's there, it's the &amp;amp;lt; &amp;amp;gt; icon in the editor. Hover it and you'll see it says Code.
I'm not seeing this. What do I do to switch back and forth between the two modes, ie Code and WYSIWYG? Can you show me a screenshot?

And is there a reason that it no longer shows who and when the quote is from? (such as the one from Tarun above)

Cheers and Regards

Edited by bphlpt, 12 July 2013 - 08:06 PM.

Posted Image


#33
LoneCrusader

LoneCrusader

    Resistere pro causa resistentiam.

  • MSFN Sponsor
  • 813 posts
  • Joined 11-May 09
  • OS:98SE
  • Country: Country Flag

Donator

The "Reply to this topic" button has disappeared from the bottom of topics, but remains at the top.

"Use Full Editor" option is also disappeared, along with all of the post controls (Font/Emoticons/Quote/Lists etc etc). The "More Reply Options" button doesn't take you to the Full Editor, or allow access to any of the missing items I listed.


EDIT:
"Use Full Editor" button does appear in Private Messenger, but it also is lacking the post controls above.

EDIT#2:
Emoticons are no longer animated? (had to enter the code manually due to problem above) :blink:

Edited by LoneCrusader, 12 July 2013 - 10:40 PM.


#34
JorgeA

JorgeA

    FORMAT B: /V /S

  • MSFN Sponsor
  • 3,225 posts
  • Joined 08-April 10
  • OS:Vista Home Premium x64
  • Country: Country Flag
&amp;nbsp;

The "Reply to this topic" button has disappeared from the bottom of topics, but remains at the top.

"Use Full Editor" option is also disappeared, along with all of the post controls (Font/Emoticons/Quote/Lists etc etc). The "More Reply Options" button doesn't take you to the Full Editor, or allow access to any of the missing items I listed.


EDIT:
"Use Full Editor" button does appear in Private Messenger, but it also is lacking the post controls above.

EDIT#2:
Emoticons are no longer animated? (had to enter the code manually due to problem above) :blink:

&amp;nbsp;

I can confirm that there are no formatting controls or emoticons listed anywhere, and that there is no option to go to full editor. I was going to post (unrelated) in another thread with a link to an article, but there appears to be no way to insert a link. No automated way, at least.

In my case, I didn't see a Multiquote button, either.

I don't know what that &amp;nbsp business is about, either. They showed up at either end of the quote.

Maybe it's all part of the ongoing changeover process and the controls will come back soon.

--JorgeA

Edited by JorgeA, 12 July 2013 - 10:59 PM.


#35
xper

xper

    Insane Clown

  • Administrator
  • 20,158 posts
  • Joined 16-August 01
  • OS:Windows 7 x64
  • Country: Country Flag
working on it.

--------------------------------------------------------------------------------------------

Become an MSFN Sponsor Now! Keep Up MSFN Running

Read MSFN Forum Rules
Not a member? Donate here!


#36
MagicAndre1981

MagicAndre1981

    after Windows 7 GA still Vista lover :)

  • Patrons
  • 6,093 posts
  • Joined 28-August 05
  • OS:Vista Ultimate x86
  • Country: Country Flag

Donator

&nbsp;


 I can't find the link to mark all forums as read :angel

Left bottom corner.


I still can't find it :(


Btw, when I quote I always get this "&nbsp;" inserted into the text.
Posted Image

#37
tomasz86

tomasz86

    www.windows2000.tk

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,520 posts
  • Joined 27-November 10
  • OS:XP Pro x86
  • Country: Country Flag

The topic description was actually removed years ago. The key reasons were because 1. They were either never used, and 2. They were redundant topic titles when used. As a fellow webmaster who also used this board software, I agree completely with the decision to remove them. Both of their points were very valid.

The topic description was always available on the older board version as far as I remember... At least I used them in several of my topics. Now those descriptions are gone :(

Nothing at all wrong with the default theme. It's crisp, clean, and has a nice professional look. It's also much lighter so that it will load faster and perform better.

The older one was cleaner though:
http://web.archive.o...msfn.org/board/
Posted Image
Unofficial Service Pack 5.2 for MS Windows 2000 <- use this topic if you need help with UURollup, Update Rollup 2 and other unofficial packages

#38
CharlotteTheHarlot

CharlotteTheHarlot

    MSFN Master

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,054 posts
  • Joined 24-September 07
  • OS:none specified
  • Country: Country Flag

Just give me some time please. I'm checking this thread hourly. Thanks.

Important: Clear your cache often until we sort out this mess.

Thanks for the comment Xper. You have made substantial progress since yesterday. :thumbup:

P.S. I am previewing this reply right now and there are no editor controls whatsoever.

P.S.S. although your quote indeed has the metadata right here in the reply ( name= timestamp= etc ) it is not showing in the preview and presumably anywhere else. Consequently quotes will not contain any attribution unless the quoter adds it in separately.

P.S.S.S. about line spacing ... One big difference from the pre-upgrade is that previously there was padding after "quote" and "/quote" blocks. That is now presumably missing from the style sheet and the consequence is that the comment after a "quote" is butted up against the quote ( see in this very reply ). Also, compared to pre-upgrade there is actually increased line spacing or padding within comment sentences ( again, see this comment ) so that the lines appear slightly spaced too much. These are just tweaks to be made I know, so I am just mentioning them.

... Let him who hath understanding reckon the Number Of The Beast ...


#39
MagicAndre1981

MagicAndre1981

    after Windows 7 GA still Vista lover :)

  • Patrons
  • 6,093 posts
  • Joined 28-August 05
  • OS:Vista Ultimate x86
  • Country: Country Flag

Donator

ok, now I found it ( Mark Community Read ). This is too hidden. Put it somewhere else, please.
Posted Image

#40
CharlotteTheHarlot

CharlotteTheHarlot

    MSFN Master

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,054 posts
  • Joined 24-September 07
  • OS:none specified
  • Country: Country Flag
It looks like Xper changed the bullet list spacing okay, but the word wrap somehow got broke. I just edited the top post and added more chars to the sample bullet list and noticed something funny. Does anyone else show it as spanning infinite to the right ( no word wrap? ). I'll fix it once a few people have a look at it, please respond below whether you see the problem or not.

I still cannot seem to get to any editor controls, whether editing an existing post or adding a new reply.

Still something strange going on with CRLF in the editor compared to the preview. Sometimes they appear to get eaten ( separate sentences get squished together ). It pays to always preview before clicking submit.

... Let him who hath understanding reckon the Number Of The Beast ...


#41
xper

xper

    Insane Clown

  • Administrator
  • 20,158 posts
  • Joined 16-August 01
  • OS:Windows 7 x64
  • Country: Country Flag

RTE editor fixed

Broken quotes fixed

Spacing fixed


--------------------------------------------------------------------------------------------

Become an MSFN Sponsor Now! Keep Up MSFN Running

Read MSFN Forum Rules
Not a member? Donate here!


#42
CharlotteTheHarlot

CharlotteTheHarlot

    MSFN Master

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,054 posts
  • Joined 24-September 07
  • OS:none specified
  • Country: Country Flag

RTE editor fixed

Broken quotes fixed

Spacing fixed

 

Awesome. That was fast!

 

I forgot to hit post on the top 1st comment, so anyone looking at it should check it now ( to see the word wrap thing ).


... Let him who hath understanding reckon the Number Of The Beast ...


#43
LoneCrusader

LoneCrusader

    Resistere pro causa resistentiam.

  • MSFN Sponsor
  • 813 posts
  • Joined 11-May 09
  • OS:98SE
  • Country: Country Flag

Donator

RTE editor fixed

Broken quotes fixed

Spacing fixed

Quotes have now gone back to being a pre-formatted "block" that doesn't show the quote tags, etc as it was before. :}



#44
xper

xper

    Insane Clown

  • Administrator
  • 20,158 posts
  • Joined 16-August 01
  • OS:Windows 7 x64
  • Country: Country Flag

 

RTE editor fixed

Broken quotes fixed

Spacing fixed

Quotes have now gone back to being a pre-formatted "block" that doesn't show the quote tags, etc as it was before. :}

 

Try to turn of RTE (top left corner button in RTE) when you quote post.


--------------------------------------------------------------------------------------------

Become an MSFN Sponsor Now! Keep Up MSFN Running

Read MSFN Forum Rules
Not a member? Donate here!


#45
LoneCrusader

LoneCrusader

    Resistere pro causa resistentiam.

  • MSFN Sponsor
  • 813 posts
  • Joined 11-May 09
  • OS:98SE
  • Country: Country Flag

Donator

RTE editor fixed
Broken quotes fixed
Spacing fixed

Quotes have now gone back to being a pre-formatted "block" that doesn't show the quote tags, etc as it was before. :}
Try to turn of RTE (top left corner button in RTE) when you quote post.
That fixed it. But it also comes with another problem... when this option is turned off, it disables all of the post controls, including Bold, Italic, Insert Link, emoticons.. the whole panel is grayed out.

#46
xper

xper

    Insane Clown

  • Administrator
  • 20,158 posts
  • Joined 16-August 01
  • OS:Windows 7 x64
  • Country: Country Flag

Thats the way RTE works.


--------------------------------------------------------------------------------------------

Become an MSFN Sponsor Now! Keep Up MSFN Running

Read MSFN Forum Rules
Not a member? Donate here!


#47
LoneCrusader

LoneCrusader

    Resistere pro causa resistentiam.

  • MSFN Sponsor
  • 813 posts
  • Joined 11-May 09
  • OS:98SE
  • Country: Country Flag

Donator

Thats the way RTE works.

So, in other words, this is something "broken" by the upgrade? All of those controls worked before, even though the editor worked in plain text mode.

Essentially it won't allow us to insert those formatting controls (tags) unless the method of "viewing" them in finished form is turned on?

#48
tomasz86

tomasz86

    www.windows2000.tk

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,520 posts
  • Joined 27-November 10
  • OS:XP Pro x86
  • Country: Country Flag
When you hover a username with mouse you get this window:

DhVAa0G.png

but the problem is that there's no way to use it with a touchscreen device. Tapping on a username just redirects you to the user profile. On the old board instead of mouse hovering there was a small button next to the username so it so it was possible to use it without a mouse too.
Posted Image
Unofficial Service Pack 5.2 for MS Windows 2000 <- use this topic if you need help with UURollup, Update Rollup 2 and other unofficial packages

#49
bphlpt

bphlpt

    MSFN Addict

  • Member
  • PipPipPipPipPipPipPip
  • 1,798 posts
  • Joined 12-May 07
  • OS:none specified
  • Country: Country Flag

OK, the BBCode mode button is now visible and working.

 

One thing I really hate about the way this new version works is that the helpful editing buttons, insert link, bold, underline, etc, are ONLY available in WYSIWYG mode.  In BBCode mode you have to do all of that manually.  The old version had those buttons available in BBCode mode, and yes I know that the old version didn't have a WYSIWYG mode at all, I just liked the old version better.  This comment is not directed at the MSFN staff, but just a complaint about the way that IPBoard messed up something that was working perfectly well already.

 

EDIT:  looks like LoneCrusader already made the same complaint. LOL

 

EDIT2:  Another complaint is that in BBCode mode word wrap does not function in the edit box, at least not when using any version of Chrome.  This is a known problem that the IPBoard folks say is a problem with Chrome, not with the IPBoard software, but I have a hard time believing that.

 

Many thanks for all your hard work xper!

 

Cheers and Regards


Edited by bphlpt, 13 July 2013 - 01:39 AM.

Posted Image


#50
jaclaz

jaclaz

    The Finder

  • Developer
  • 14,584 posts
  • Joined 23-July 04
  • OS:none specified
  • Country: Country Flag

@xper

The "default posts per page" has changed from 20 to 25.

This is not normally an issue, but it will create some minor quirk where the page where a post was is mentioned (like in the "monster 7200.11 thread" often happens) and has a serious issue with rounding :w00t: (or whatever :unsure:).

A post link (which was perfectly "legal" and working) such as:

http://www.msfn.org/...=128807&st=2352

which point(ed) evidently to post #2353 now resolves to:

http://www.msfn.org/...11-hdds/page-96

i.e. to post #2376 :ph34r:

 

Cannot say if it can be solved, at the times of the reboot.pro update, the IPB guys didn't even manage to understand (or want to understand) the issue.  :realmad:

JFYI:

http://reboot.pro/to...with-the-board/

http://community.inv...-version-r37167

 

Easy way to reproduce.

The post by bphlt just above is #51 in this thread.

I would refer to it (and it has ALWAYS worked like this since the dawn of time) as:

http://www.msfn.org/...ic=163450&st=50

while last post on previous page by tomasz86, which is #50 would be referred to as:

http://www.msfn.org/...ic=163450&st=49

Now BOTH links lead you on http://www.msfn.org/...uly-2013/page-3

 

jaclaz






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users