Phenomic

Firefox 22.0 not installing in win2k UU

13 posts in this topic

I'm running Firefox 21.0 but "check for updates" says "Firefox is up to date". If I download the v22.0 installer it says it needs XP sp2.

0

Share this post


Link to post
Share on other sites

I just use Firefox portable which can update itself regardless of the OS version. If you want to use the normal built-in updater you'll need to install this addon:

http://forums.mozillazine.org/viewtopic.php?f=37&t=2482475&sid=&p=12171485#p12171485

If you just want to install the new version manually then you'll have to use Application Compatibility Launcher... but how did you install Firefox 21 then? :sneaky:

0

Share this post


Link to post
Share on other sites

ok it worked this time, default download is "Firefox Setup Stub 22.0.exe" but full version "Firefox Setup 22.0.exe" works for mauall install. I wonder why it stopped auto-updating though.

0

Share this post


Link to post
Share on other sites

Firefox 12 or later are blocking Autoupdate notifier on Windows 2000.

So I think that it would not work on Windows 2000.

ok it worked this time, default download is "Firefox Setup Stub 22.0.exe" but full version "Firefox Setup 22.0.exe" works for mauall install. I wonder why it stopped auto-updating though.

0

Share this post


Link to post
Share on other sites

Firefox 12 or later are blocking Autoupdate notifier on Windows 2000.

So I think that it would not work on Windows 2000.

It should autoupdate with the addon linked above in #2.

0

Share this post


Link to post
Share on other sites

Thank you. I have in about:config , "app.update.url" with default value "https://aus3.mozilla.org/update/3/%PRODUCT%/%VERSION%/%BUILD_ID%/%BUILD_TARGET%/%LOCALE%/%CHANNEL%/%OS_VERSION%/%DISTRIBUTION%/%DISTRIBUTION_VERSION%/update.xml"

You said to create new key "app.update.url.override" and replace "%OS_VERSION%" with "Windows_NT% 205.1.3.0% 20 (x86)" ?

0

Share this post


Link to post
Share on other sites

Yes. :thumbup

Thank you. I have in about:config , "app.update.url" with default value "https://aus3.mozilla.org/update/3/%PRODUCT%/%VERSION%/%BUILD_ID%/%BUILD_TARGET%/%LOCALE%/%CHANNEL%/%OS_VERSION%/%DISTRIBUTION%/%DISTRIBUTION_VERSION%/update.xml"

You said to create new key "app.update.url.override" and replace "%OS_VERSION%" with "Windows_NT% 205.1.3.0% 20 (x86)" ?

0

Share this post


Link to post
Share on other sites

I think you can also create user.js in profile directory and add:

user_pref("app.update.url.override", "https://aus3.mozilla.org/update/3/%PRODUCT%/%VERSION%/%BUILD_ID%/%BUILD_TARGET%/%LOCALE%/%CHANNEL%/Windows_NT%205.1.3.0%20(x86)/%DISTRIBUTION%/%DISTRIBUTION_VERSION%/update.xml");
0

Share this post


Link to post
Share on other sites

So it works, the latest firefox version 23.0.1 auto-updated with "app.update.url.override". Thanks BWC. :)

0

Share this post


Link to post
Share on other sites

Auto-update stopped working, hangs.

I downloaded full version Firefox and it says it requires XP sp2 to work.

Any ideas?

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.