• Announcements

    • xper

      MSFN Sponsorship and AdBlockers!   07/10/2016

      Dear members, MSFN is made available via subscriptions, donations and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, become a site sponsor and ads will be disabled automatically and by subscribing you get other sponsor benefits.
xper

IPB Update July 2013 (to version 3.4.5) - BUGS Only

268 posts in this topic

Please one bug per post, short and simple.

0

Share this post


Link to post
Share on other sites

The syntax for linking to a specific post has been since the very early days that of:

http://www.msfn.org/board/index.php?showtopic=137119&st=20http://www.msfn.org/board/index.php? <- base addressshowtopic=137119 <- topic/thread number&st=20 <- offset to post #

This syntax does not work properly anymore.

ALREADY POSTED LINKS in that form (that has always been valid) even at the time of the previous Board update (for which at the time I wrote temporarily the converter, which obviously now doesn't work anymore because of the newish "page" syntax):
http://www.msfn.org/...or-forum-issue/
are now "botched".

This link:

http://www.msfn.org/board/index.php?showtopic=163450&st=49

should lead to post #50 (i.e. 49+1) in the "closed thread":

http://www.msfn.org/board/topic/163450-ipb-update-july-2013-to-version-345/?p=1044604

BUT, instead leads to:

http://www.msfn.org/board/topic/163450-ipb-update-july-2013-to-version-345/page-3

i.e.:

http://www.msfn.org/board/topic/163450-ipb-update-july-2013-to-version-345/?p=1044606

EXACTLY like this:

http://www.msfn.org/board/index.php?showtopic=163450&st=50

(which CASUALLY lands correctly)

.

If you increase the offset of 1 you get to NEXT PAGE (instead of the immediately following post)! :w00t:

http://www.msfn.org/board/index.php?showtopic=163450&st=51

leads to:

http://www.msfn.org/board/topic/163450-ipb-update-july-2013-to-version-345/page-4

i.e.:

http://www.msfn.org/board/topic/163450-ipb-update-july-2013-to-version-345/?p=1044696

I hope the issue is clear.

jaclaz

0

Share this post


Link to post
Share on other sites

I'm not receiving e-mail notifications of new posts to topics that I'm subscribed to.

My settings are to automatically follow any topic that I reply to, and to get immediate notification of new posts via e-mail. But that's not happening.

Same for private messages -- no e-mail notifications arriving, despite having checked all the boxes related to personal conversations.

Not sure if this can be considered a "bug" exactly, but e-mail notifications are a displayed forum feature that isn't (yet) working.

--JorgeA

0

Share this post


Link to post
Share on other sites

This known bug that IPB url parsing are a bit off if the urls contain the ' (apostrophe) character(s).

I do encounter some other urls that contain apostrophe.

But as always the IPB dev said it was not a 'bug'

http://community.invisionpower.com/resources/bugs.html/_/ip-board/link-is-broken-if-contains-or-r40575

and thus shows no desire to 'fix' it.

anyway, this is IPB fault in general not the MSFN.

0

Share this post


Link to post
Share on other sites

JorgeA, check your Notification Options and Followed Content.

Thank you. Those settings are what I meant when reporting that:

My settings are to automatically follow any topic that I reply to, and to get immediate notification of new posts via e-mail. But that's not happening.

Same for private messages -- no e-mail notifications arriving, despite having checked all the boxes related to personal conversations.

But more details are in order:

The setting, "Auto follow topics I reply to. Notification frequency:", is checked off, and set to "Immediate."

The setting, "Notification method to use for replies to followed topics", is set to e-mail.

All three settings under "Private Messages" are also checked off for e-mail notification.

Finally, Followed Content does list all the topics (threads) that I have opted to subscribe to. Since elsewhere (see above) I have selected, as a global setting, immediate e-mail notification of replies in followed topics, then I suppose that nothing further needs to be done (for example, with that "change" button on the right of each followed topic). Should I also individually set each followed topic to "Notify me of updates"? That would seem to be redundant given the other settings, but you never know...

In case you're wondering, :) my e-mail address under "My Settings" is correct.

Is there anything else that needs to be done, to resume getting e-mail notifications of new posts in followed topics?

Thanks!

--JorgeA

EDIT: additional info

Edited by JorgeA
0

Share this post


Link to post
Share on other sites

I'm not recieving emails for messages.

Seems to me auto emails are broken board wide

0

Share this post


Link to post
Share on other sites

This main topic post used to look fine, now it's a disaster as the formatting fails halfway through.

and now it gives this error

Fatal error: Maximum execution time of 60 seconds exceeded in /home/msfnorg/public_html/board/ips_kernel/HTMLPurifier/HTMLPurifier/Config.php on line 0

XP-x64_guide_A.7z

Edited by Kurt_Aust
0

Share this post


Link to post
Share on other sites

topic?

0

Share this post


Link to post
Share on other sites

holy crap, huge one! anyway, it works fine here. cannot reproduce.

Suggestion: Divide that post in several (4-5 perhaps) smaller ones.

0

Share this post


Link to post
Share on other sites

I'm getting mail from topics i'm subscribed.

0

Share this post


Link to post
Share on other sites

"Gamers Hangout" forum has a different icon

0

Share this post


Link to post
Share on other sites

We have a member who decided to use an username written in Katakana: viz. ハイドン (strangely enough it means "Hydn", a European name).

There's no way to cause the forum to show his profile now (the error is different in FF and in Opera, but certainly is due to the strange characters used.).

Before the upgrade it used to work. Also some of the other members with odd names one can see in the 1st page one gets after clicking in the "Members" tab on the top row of the forum UI also do show the same issue... in fact, all usernames containing the hash (or sharp) character, as well as those containing "bigger than" and "less than", fail to be displayed. So, in other words, up to now I know that, besides Katakana characters, the presence of the following characters in the username do cause the issue I'm reporting here:

 # > < 
0

Share this post


Link to post
Share on other sites

I'm getting mail from topics i'm subscribed.

So then, those of us who are not getting e-mail notifications -- is there anything we can do? :}

--JorgeA

0

Share this post


Link to post
Share on other sites

Did you try to unsubscribe, then subscribe once more?

Now that the IP.B software was upgraded it may solve it...

0

Share this post


Link to post
Share on other sites

Some, (not all) emoticons are no longer animated when added from the emoticons menu.

The "Thumbup" one works, and is animated. :thumbup

However, the "Wacko" and "Blink" (and possibly others) emoticons, when added from the emoticons menu aren't animated:

:wacko::blink:


But when they are direct linked by IMG tags, they work:

wacko.gifblink.gif

This doesn't work: :blink:This does:[img=http://www.msfn.org/board/public/style_emoticons/default/wacko.gif][img=http://www.msfn.org/board/public/style_emoticons/default/blink.gif]
0

Share this post


Link to post
Share on other sites

Did you try to unsubscribe, then subscribe once more?

Now that the IP.B software was upgraded it may solve it...

Thanks dencorso, I'll try that.

Should I unsubscribe, then leave MSFN, go back into "Content I Follow" and re-subscribe?

Or -- in case it makes a difference -- should I unsubscribe and then resubscribe without leaving MSFN?

--JorgeA

Edited by JorgeA
0

Share this post


Link to post
Share on other sites

I'd unsubscribe, leave MSFN, clean the browser's cookies and close the browser (all instances of it)...

Then open the browser anew, login to MSFN, go to the thread and subscribe.

Do it to just a couple of threads and let's see whether it makes any difference.

0

Share this post


Link to post
Share on other sites

Two bugs when using Internet Explorer 8:

4w8U3Zt.png

0

Share this post


Link to post
Share on other sites

post-1-0-41907800-1373966523_thumb.png

Looks fine here. Chrome.

post-1-0-05584300-1373966905_thumb.png

Also on IE

0

Share this post


Link to post
Share on other sites

That why I said Internet Explorer 8 :whistle:

0

Share this post


Link to post
Share on other sites

I don't have IE8 and cannot test it.

0

Share this post


Link to post
Share on other sites

I will do this later this month because i'm on 3G/HDSPA limited connection right now.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.